aboutsummaryrefslogtreecommitdiff
path: root/net/scapy
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2005-12-15 14:29:01 +0000
committerRenato Botelho <garga@FreeBSD.org>2005-12-15 14:29:01 +0000
commit00662abb3c83b6809f001eae1b4f800ac20ed3c6 (patch)
tree0a187797192c0c50dc0a547291da9e5d79500adf /net/scapy
parentada4b0ce35c871b66cf2d096fa0ad0c5ce2bed5d (diff)
downloadports-00662abb3c83b6809f001eae1b4f800ac20ed3c6.tar.gz
ports-00662abb3c83b6809f001eae1b4f800ac20ed3c6.zip
Notes
Diffstat (limited to 'net/scapy')
-rw-r--r--net/scapy/Makefile32
-rw-r--r--net/scapy/distinfo3
-rw-r--r--net/scapy/pkg-descr13
3 files changed, 48 insertions, 0 deletions
diff --git a/net/scapy/Makefile b/net/scapy/Makefile
new file mode 100644
index 000000000000..d61d58aaaa87
--- /dev/null
+++ b/net/scapy/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: scapy
+# Date created: 08 dec 2005
+# Whom: vanhu <vanhu@netasq.com>
+#
+# $FreeBSD$
+#
+# TODO: - configurable --enable-xxx for various additional dependancies
+
+PORTNAME= scapy
+PORTVERSION= 1.0.2
+CATEGORIES= net
+MASTER_SITES= http://secdev.org/projects/scapy/files/
+
+MAINTAINER= vanhu@netasq.com
+COMMENT= Powerful interactive packet manipulation program in python
+
+RUN_DEPENDS= ${PYTHON_SITELIBDIR}/dnet.so:${PORTSDIR}/net/py-libdnet \
+ ${PYTHON_SITELIBDIR}/pcap.py:${PORTSDIR}/net/py-pcap
+
+MAN1= scapy.1
+MANCOMPRESSED= yes
+
+PLIST_FILES= bin/scapy
+
+USE_PYTHON= yes
+NO_BUILD= yes
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/scapy.py ${PREFIX}/bin/scapy
+ ${INSTALL_MAN} ${WRKSRC}/scapy.1.gz ${MAN1PREFIX}/man/man1
+
+.include <bsd.port.mk>
diff --git a/net/scapy/distinfo b/net/scapy/distinfo
new file mode 100644
index 000000000000..32e59e13802a
--- /dev/null
+++ b/net/scapy/distinfo
@@ -0,0 +1,3 @@
+MD5 (scapy-1.0.2.tar.gz) = c4cac0a657079492710b31a6aed0672a
+SHA256 (scapy-1.0.2.tar.gz) = e71c6917f00ed0269144680029ea3270650ee1a6200f32e1ffe1c8b958da0293
+SIZE (scapy-1.0.2.tar.gz) = 104563
diff --git a/net/scapy/pkg-descr b/net/scapy/pkg-descr
new file mode 100644
index 000000000000..e8002709c156
--- /dev/null
+++ b/net/scapy/pkg-descr
@@ -0,0 +1,13 @@
+Scapy is a powerful interactive packet manipulation program. It is
+able to forge or decode packets of a wide number of protocols, send
+them on the wire, capture them, match requests and replies, and much
+more. It can easily handle most classical tasks like scanning,
+tracerouting, probing, unit tests, attacks or network discovery (it
+can replace hping, 85% of nmap, arpspoof, arp-sk, arping, tcpdump,
+tethereal, p0f, etc.). It also performs very well at a lot of other
+specific tasks that most other tools can't handle, like sending
+invalid frames, injecting your own 802.11 frames, combining technics
+(VLAN hopping+ARP cache poisoning, VOIP decoding on WEP encrypted
+channel, ...), etc.
+
+WWW: http://secdev.org/projects/scapy