aboutsummaryrefslogtreecommitdiff
path: root/net/scapy
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2006-11-05 07:22:03 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2006-11-05 07:22:03 +0000
commit925eb88fa448fba734abfc467adcb1e6d04e4fc0 (patch)
tree02cfe20e1d254e877ff06b646a61cf6c622a5539 /net/scapy
parente1f3aca1384659ef00fe0313dbebfd461d372d28 (diff)
downloadports-925eb88fa448fba734abfc467adcb1e6d04e4fc0.tar.gz
ports-925eb88fa448fba734abfc467adcb1e6d04e4fc0.zip
Notes
Diffstat (limited to 'net/scapy')
-rw-r--r--net/scapy/Makefile26
-rw-r--r--net/scapy/distinfo6
2 files changed, 25 insertions, 7 deletions
diff --git a/net/scapy/Makefile b/net/scapy/Makefile
index 786484fce4bf..8e5cd8b61747 100644
--- a/net/scapy/Makefile
+++ b/net/scapy/Makefile
@@ -7,7 +7,7 @@
# TODO: - configurable --enable-xxx for various additional dependancies
PORTNAME= scapy
-PORTVERSION= 1.0.4
+PORTVERSION= 1.0.5
CATEGORIES= net
MASTER_SITES= http://secdev.org/projects/scapy/files/
@@ -18,15 +18,33 @@ RUN_DEPENDS= ${PYTHON_SITELIBDIR}/dnet.so:${PORTSDIR}/net/py-libdnet \
${PYTHON_SITELIBDIR}/pcap.py:${PORTSDIR}/net/py-pcap
MAN1= scapy.1
-MANCOMPRESSED= yes
+MANCOMPRESSED= no
PLIST_FILES= bin/scapy
USE_PYTHON= yes
NO_BUILD= yes
+OPTIONS= PYX "Support for PostScript and PDF graphs drawing" off \
+ PYCRYPTO "Support for py-crypto for WEP decoding" off \
+ PYGNUPLOT "Support for py-gnuplot wrapper to plot graphs" off
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_PYX)
+RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/pyx/__init__.py:${PORTSDIR}/graphics/py-PyX
+.endif
+
+.if defined(WITH_PYCRYPTO)
+RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/Crypto/__init__.py:${PORTSDIR}/security/py-pycrypto
+.endif
+
+.if defined(WITH_PYGNUPLOT)
+RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/Gnuplot/__init__.py:${PORTSDIR}/math/py-gnuplot
+.endif
+
do-install:
${INSTALL_SCRIPT} ${WRKSRC}/scapy.py ${PREFIX}/bin/scapy
- ${INSTALL_MAN} ${WRKSRC}/scapy.1.gz ${MAN1PREFIX}/man/man1
+ ${INSTALL_MAN} ${WRKSRC}/scapy.1 ${MAN1PREFIX}/man/man1
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/net/scapy/distinfo b/net/scapy/distinfo
index 3b00b7aa289a..f213ad7a7adc 100644
--- a/net/scapy/distinfo
+++ b/net/scapy/distinfo
@@ -1,3 +1,3 @@
-MD5 (scapy-1.0.4.tar.gz) = c156668cfab4c1fde276f81e0b85b5d9
-SHA256 (scapy-1.0.4.tar.gz) = 340bebb26bbf8cb37bdbcfb7b8df9225ad384a0b3f0b33b55ca0b8ba6c9a3b02
-SIZE (scapy-1.0.4.tar.gz) = 132677
+MD5 (scapy-1.0.5.tar.gz) = b094a03472375c3add5415345b8d79d6
+SHA256 (scapy-1.0.5.tar.gz) = a8a77854dfdc6cee71344527510e64d1985222d20637c08f0b46b8d709c2e766
+SIZE (scapy-1.0.5.tar.gz) = 144746