aboutsummaryrefslogtreecommitdiff
path: root/net/scribe/Makefile
diff options
context:
space:
mode:
authorLi-Wen Hsu <lwhsu@FreeBSD.org>2012-01-12 09:25:04 +0000
committerLi-Wen Hsu <lwhsu@FreeBSD.org>2012-01-12 09:25:04 +0000
commita12ce191e99b44ae1d2ffb0b641a5016811148c4 (patch)
tree3cf41068774c7fc6e8712c217126cecf382b6342 /net/scribe/Makefile
parentf351900f8005c3bb06a5bcd3cab6124d14534921 (diff)
downloadports-a12ce191e99b44ae1d2ffb0b641a5016811148c4.tar.gz
ports-a12ce191e99b44ae1d2ffb0b641a5016811148c4.zip
Notes
Diffstat (limited to 'net/scribe/Makefile')
-rw-r--r--net/scribe/Makefile19
1 files changed, 7 insertions, 12 deletions
diff --git a/net/scribe/Makefile b/net/scribe/Makefile
index bda8eeeae3b5..ea2ac33d4e25 100644
--- a/net/scribe/Makefile
+++ b/net/scribe/Makefile
@@ -5,10 +5,10 @@
#
PORTNAME= scribe
-PORTVERSION= 2.2
-PORTREVISION= 3
+DISTVERSION= 2.2.2011.07.27
CATEGORIES= net
-MASTER_SITES= http://cloud.github.com/downloads/facebook/scribe/
+MASTER_SITES= https://github.com/facebook/scribe/tarball/${GITVERSION}/
+DISTNAME= facebook-scribe-${GITVERSION}
MAINTAINER= jnlin@csie.nctu.edu.tw
COMMENT= Aggregating log data streamed in real time
@@ -21,7 +21,9 @@ RUN_DEPENDS= p5-Class-Accessor>0:${PORTSDIR}/devel/p5-Class-Accessor \
p5-Thrift>0:${PORTSDIR}/devel/p5-Thrift \
${PYTHON_SITELIBDIR}/thrift/__init__.py:${PORTSDIR}/devel/py-thrift
-BROKEN= does not compile
+GITVERSION= 6600084
+FETCH_ARGS= -pRr
+WRKSRC= ${WRKDIR}/${DISTNAME}
ACLOCAL_ARGS= -I ./aclocal
AUTOMAKE_ARGS= -a
@@ -35,19 +37,12 @@ USE_GMAKE= yes
USE_PYTHON= yes
USE_RC_SUBR= ${PORTNAME}
-post-extract:
- ${MV} ${WRKDIR}/${PORTNAME} ${WRKSRC}
-
post-patch:
${REINPLACE_CMD} -e 's|/usr/local/scribe|${LOCALBASE}/etc|' ${WRKSRC}/src/env_default.h
-post-build:
- ${LOCALBASE}/bin/thrift -o ${WRKSRC} -I ${LOCALBASE}/share --gen "perl" ${WRKSRC}/if/scribe.thrift
- cd ${WRKSRC} && ${PATCH} < ${FILESDIR}/scribe.pm.patch
-
post-install:
${MKDIR} ${PREFIX}/${SITE_PERL_REL}/Scribe/Thrift
- ${CP} ${WRKSRC}/gen-perl/*.pm ${PREFIX}/${SITE_PERL_REL}/Scribe/Thrift
+ ${CP} -R ${WRKSRC}/src/gen-perl/ ${PREFIX}/${SITE_PERL_REL}
${MKDIR} ${EXAMPLESDIR}
${CP} ${WRKSRC}/examples/* ${EXAMPLESDIR}