aboutsummaryrefslogtreecommitdiff
path: root/net/scribe
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2012-08-05 06:02:30 +0000
committerMartin Wilke <miwi@FreeBSD.org>2012-08-05 06:02:30 +0000
commit5348ba2904a4b7fadc09726e1204a28325ad350e (patch)
tree11cf19c39e64d4f63ba047d4f48420a32979eee6 /net/scribe
parentc4b4de439260d4ed7a33a54aa2dd0df400929468 (diff)
downloadports-5348ba2904a4b7fadc09726e1204a28325ad350e.tar.gz
ports-5348ba2904a4b7fadc09726e1204a28325ad350e.zip
Notes
Diffstat (limited to 'net/scribe')
-rw-r--r--net/scribe/Makefile3
-rw-r--r--net/scribe/files/patch-src-file.cpp11
2 files changed, 12 insertions, 2 deletions
diff --git a/net/scribe/Makefile b/net/scribe/Makefile
index 8ce9677d2c0a..01b88281551c 100644
--- a/net/scribe/Makefile
+++ b/net/scribe/Makefile
@@ -6,6 +6,7 @@
PORTNAME= scribe
DISTVERSION= 2.2.2012.01.07
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= https://github.com/facebook/scribe/tarball/${GITVERSION}/
DISTNAME= facebook-scribe-${GITVERSION}
@@ -21,8 +22,6 @@ RUN_DEPENDS= p5-Class-Accessor>0:${PORTSDIR}/devel/p5-Class-Accessor \
p5-Thrift>0:${PORTSDIR}/devel/p5-Thrift \
${PYTHON_SITELIBDIR}/thrift/__init__.py:${PORTSDIR}/devel/py-thrift
-BROKEN= does not compile
-
GITVERSION= 63e4824
FETCH_ARGS= -pRr
WRKSRC= ${WRKDIR}/${DISTNAME}
diff --git a/net/scribe/files/patch-src-file.cpp b/net/scribe/files/patch-src-file.cpp
new file mode 100644
index 000000000000..8393b124f419
--- /dev/null
+++ b/net/scribe/files/patch-src-file.cpp
@@ -0,0 +1,11 @@
+--- src/file.cpp.orig 2012-06-28 12:42:20.000000000 +0800
++++ src/file.cpp 2012-06-28 12:42:30.000000000 +0800
+@@ -245,7 +245,7 @@
+ boost::filesystem::directory_iterator dir_iter(path), end_iter;
+
+ for ( ; dir_iter != end_iter; ++dir_iter) {
+- _return.push_back(dir_iter->filename());
++ _return.push_back(dir_iter->path().filename().string());
+ }
+ }
+ } catch (const std::exception& e) {