aboutsummaryrefslogtreecommitdiff
path: root/net/sdl2_net
diff options
context:
space:
mode:
authorMarcus von Appen <mva@FreeBSD.org>2013-06-21 19:56:27 +0000
committerMarcus von Appen <mva@FreeBSD.org>2013-06-21 19:56:27 +0000
commitc5a4db7c111615dacf0bd184c7b78e927dce311b (patch)
tree16b6a36999fedc7fbad7af76e86d017a12040f78 /net/sdl2_net
parent2b6d9fd950bcce21b937ac81c7faa89131ebdfe9 (diff)
downloadports-c5a4db7c111615dacf0bd184c7b78e927dce311b.tar.gz
ports-c5a4db7c111615dacf0bd184c7b78e927dce311b.zip
Notes
Diffstat (limited to 'net/sdl2_net')
-rw-r--r--net/sdl2_net/Makefile21
-rw-r--r--net/sdl2_net/distinfo2
-rw-r--r--net/sdl2_net/pkg-descr5
-rw-r--r--net/sdl2_net/pkg-plist7
4 files changed, 35 insertions, 0 deletions
diff --git a/net/sdl2_net/Makefile b/net/sdl2_net/Makefile
new file mode 100644
index 000000000000..3152f4b4e747
--- /dev/null
+++ b/net/sdl2_net/Makefile
@@ -0,0 +1,21 @@
+# $FreeBSD$
+
+PORTNAME= sdl2_net
+PORTVERSION= 2.0.p1
+CATEGORIES= net
+MASTER_SITES= http://www.libsdl.org/tmp/SDL_net/release/
+DISTNAME= SDL2_net-2.0.0
+
+MAINTAINER= mva@FreeBSD.org
+COMMENT= A small sample cross-platform networking library
+
+USE_AUTOTOOLS= libtool
+USE_SDL= sdl2
+USES= pathfix pkgconfig:build
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+USE_LDCONFIG= yes
+
+CONFIGURE_ARGS+=--disable-gui
+
+.include <bsd.port.mk>
diff --git a/net/sdl2_net/distinfo b/net/sdl2_net/distinfo
new file mode 100644
index 000000000000..42c83e9033b3
--- /dev/null
+++ b/net/sdl2_net/distinfo
@@ -0,0 +1,2 @@
+SHA256 (SDL2_net-2.0.0.tar.gz) = 28dac7dac4c91f432b025b86a2425047d42ee943be671c4e3c23e81f702f4547
+SIZE (SDL2_net-2.0.0.tar.gz) = 345094
diff --git a/net/sdl2_net/pkg-descr b/net/sdl2_net/pkg-descr
new file mode 100644
index 000000000000..23b662c64f0f
--- /dev/null
+++ b/net/sdl2_net/pkg-descr
@@ -0,0 +1,5 @@
+This is a small sample cross-platform networking library, with a sample chat
+client and server application. The chat client uses the GUIlib GUI framework
+library.
+
+WWW: http://www.libsdl.org/projects/SDL_net/
diff --git a/net/sdl2_net/pkg-plist b/net/sdl2_net/pkg-plist
new file mode 100644
index 000000000000..da8521386901
--- /dev/null
+++ b/net/sdl2_net/pkg-plist
@@ -0,0 +1,7 @@
+include/SDL2/SDL_net.h
+lib/libSDL2_net-2.0.so
+lib/libSDL2_net-2.0.so.0
+lib/libSDL2_net.a
+lib/libSDL2_net.la
+lib/libSDL2_net.so
+libdata/pkgconfig/SDL2_net.pc