aboutsummaryrefslogtreecommitdiff
path: root/net/sdl_net
diff options
context:
space:
mode:
authorDaichi GOTO <daichi@FreeBSD.org>2003-07-31 07:25:30 +0000
committerDaichi GOTO <daichi@FreeBSD.org>2003-07-31 07:25:30 +0000
commit7b4865e4d6047f37da56cc2a6320a2dc2f3d5891 (patch)
tree71af039683e882e3431bb6255036cc54ca29f1a0 /net/sdl_net
parentd2182f50d32a1af706de9702949eab79ed610f10 (diff)
downloadports-7b4865e4d6047f37da56cc2a6320a2dc2f3d5891.tar.gz
ports-7b4865e4d6047f37da56cc2a6320a2dc2f3d5891.zip
Notes
Diffstat (limited to 'net/sdl_net')
-rw-r--r--net/sdl_net/Makefile20
1 files changed, 8 insertions, 12 deletions
diff --git a/net/sdl_net/Makefile b/net/sdl_net/Makefile
index f82e1b177755..fbeac7acd4b1 100644
--- a/net/sdl_net/Makefile
+++ b/net/sdl_net/Makefile
@@ -14,22 +14,18 @@ DISTNAME= SDL_net-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= A small sample cross-platform networking library
-LIB_DEPENDS= SDL-1.1.5:${PORTSDIR}/devel/sdl12 \
- GUI.0:${PORTSDIR}/graphics/guilib
+LIB_DEPENDS= GUI.0:${PORTSDIR}/graphics/guilib
-SDL_CONFIG?= ${LOCALBASE}/bin/sdl11-config
-
-USE_LIBTOOL= yes
+USE_SDL= yes
+USE_REINPLACE= yes
USE_GMAKE= yes
+USE_LIBTOOL= yes
+LIBTOOLFLAGS= --disable-ltlibs --release-ignore
INSTALLS_SHLIB= yes
-CONFIGURE_ENV= SDL_CONFIG="${SDL_CONFIG}"
-
-post-extract:
- @find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
- 's|-release \$$\(LT_RELEASE\)||g'
post-configure:
- @${PERL} -pi -e 's|^deplibs_check_method=.*|deplibs_check_method=pass_all|' \
- ${WRKSRC}/libtool
+ @${REINPLACE_CMD} -e \
+ 's|^deplibs_check_method=.*|deplibs_check_method=pass_all|' \
+ ${WRKSRC}/libtool
.include <bsd.port.mk>