aboutsummaryrefslogtreecommitdiff
path: root/net/sdl_net
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2017-02-27 12:38:47 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2017-02-27 12:38:47 +0000
commit56cc2eba0d4d0a6f64e20b47d98e629e8f9df8eb (patch)
treee764205ba83f2bf799aaeeeb68be4ac6653708d4 /net/sdl_net
parent2d619bb69d0cdc306ffeef9b3c7c10d6e83d5702 (diff)
downloadports-56cc2eba0d4d0a6f64e20b47d98e629e8f9df8eb.tar.gz
ports-56cc2eba0d4d0a6f64e20b47d98e629e8f9df8eb.zip
Notes
Diffstat (limited to 'net/sdl_net')
-rw-r--r--net/sdl_net/Makefile1
-rw-r--r--net/sdl_net/files/patch-SDLnetsys.h10
2 files changed, 6 insertions, 5 deletions
diff --git a/net/sdl_net/Makefile b/net/sdl_net/Makefile
index c66e87c1168b..72987f910f4b 100644
--- a/net/sdl_net/Makefile
+++ b/net/sdl_net/Makefile
@@ -12,6 +12,7 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Small sample cross-platform networking library
LICENSE= ZLIB
+LICENSE_FILE= ${WRKSRC}/COPYING
GNU_CONFIGURE= yes
INSTALL_TARGET= install-strip
diff --git a/net/sdl_net/files/patch-SDLnetsys.h b/net/sdl_net/files/patch-SDLnetsys.h
index db99084f9e97..870a5394e7ad 100644
--- a/net/sdl_net/files/patch-SDLnetsys.h
+++ b/net/sdl_net/files/patch-SDLnetsys.h
@@ -1,8 +1,8 @@
---- SDLnetsys.h.orig Sun Jul 2 02:28:47 2000
-+++ SDLnetsys.h Wed Sep 20 18:42:27 2000
-@@ -41,6 +41,11 @@
- #include <unistd.h>
+--- SDLnetsys.h.orig 2012-01-15 16:20:10 UTC
++++ SDLnetsys.h
+@@ -54,6 +54,11 @@ typedef int socklen_t;
#include <fcntl.h>
+ #include <netinet/in.h>
#ifndef __BEOS__
+#ifdef __FreeBSD__
+#include <sys/types.h>
@@ -11,4 +11,4 @@
+#endif /* FreeBSD */
#include <arpa/inet.h>
#endif
- #include <netinet/in.h>
+ #ifdef linux /* FIXME: what other platforms have this? */