aboutsummaryrefslogtreecommitdiff
path: root/net/sdr
diff options
context:
space:
mode:
authorBill Fenner <fenner@FreeBSD.org>2004-02-02 00:55:08 +0000
committerBill Fenner <fenner@FreeBSD.org>2004-02-02 00:55:08 +0000
commit4e2842b561dc69de56c2f792bd4096e1d5689799 (patch)
tree59cca62501995772ea3ab57251c84bdc4e93e702 /net/sdr
parentb17d5d8ee97e916490f467220fa30c00af2a6022 (diff)
downloadports-4e2842b561dc69de56c2f792bd4096e1d5689799.tar.gz
ports-4e2842b561dc69de56c2f792bd4096e1d5689799.zip
Notes
Diffstat (limited to 'net/sdr')
-rw-r--r--net/sdr/files/Makefile.freebsd4
-rw-r--r--net/sdr/files/patch-ab2
-rw-r--r--net/sdr/files/patch-ac11
3 files changed, 3 insertions, 14 deletions
diff --git a/net/sdr/files/Makefile.freebsd b/net/sdr/files/Makefile.freebsd
index e412d81c1f99..303950175fa9 100644
--- a/net/sdr/files/Makefile.freebsd
+++ b/net/sdr/files/Makefile.freebsd
@@ -1,6 +1,6 @@
CC = gcc -g -O -fwritable-strings
-INCLUDES = -I${X11BASE}/include -I${LOCALBASE}/include/tk8.2 -I${LOCALBASE}/include/tcl8.2 -I${LOCALBASE}/include/uclmmbase
-LIBS = -L${LOCALBASE}/lib -ltk82 -ltcl82 -luclmmbase -L${X11BASE}/lib -lX11 -lz -lm
+INCLUDES = -I${X11BASE}/include -I${LOCALBASE}/include/tk8.4 -I${LOCALBASE}/include/tcl8.4 -I${LOCALBASE}/include/uclmmbase
+LIBS = -L${LOCALBASE}/lib -ltk84 -ltcl84 -luclmmbase -L${X11BASE}/lib -lX11 -lz -lm
CFLAGS = $(INCLUDES) -DDIFF_BYTE_ORDER -DFREEBSD -DNORANDPROTO -DDEFINED_ERRLIST -Wall -DAUTH -DHAVE_ZLIB -DFreeBSD
all:: sdr
diff --git a/net/sdr/files/patch-ab b/net/sdr/files/patch-ab
index ca6c5f8fe01f..bb154934fbd1 100644
--- a/net/sdr/files/patch-ab
+++ b/net/sdr/files/patch-ab
@@ -5,7 +5,7 @@
parsed_plugins.tcl: ../src/plugin2tcl.tcl
- tclsh8.0 ../src/plugin2tcl.tcl
-+ tclsh8.2 ../src/plugin2tcl.tcl
++ tclsh8.4 ../src/plugin2tcl.tcl
uweb: $(WWWOBJS)
$(CC) -ggdb -o uweb $(WWWOBJS) $(LIBS)
diff --git a/net/sdr/files/patch-ac b/net/sdr/files/patch-ac
deleted file mode 100644
index 8499cceb284b..000000000000
--- a/net/sdr/files/patch-ac
+++ /dev/null
@@ -1,11 +0,0 @@
---- ../src/plugin2tcl.tcl.orig Sun Mar 19 20:33:42 2000
-+++ ../src/plugin2tcl.tcl Sun Mar 19 20:35:39 2000
-@@ -8,7 +8,7 @@
- puts $file "set createrules \"$createrules\""
- foreach ary {tooldata mediadata fmts protos protonames fmtnames mappings attrs attrnames attrvaluenames attrflags noattrflags noattrlist defattrlist withattrs macros macrokeys fmtlayers} {
- foreach key [array names $ary] {
-- puts $file "set [set ary]($key) \"[set [set ary]($key)]\""
-+ puts $file [list set [set ary]($key) [set [set ary]($key)]]
- }
- }
- close $file