aboutsummaryrefslogtreecommitdiff
path: root/net/sendemail
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2005-12-19 14:35:09 +0000
committerRenato Botelho <garga@FreeBSD.org>2005-12-19 14:35:09 +0000
commitd967bcd92fc4bb4a1299f0d2eec337dfce343a01 (patch)
tree949b57c543a0e3ebd8fd9a3b4a63e54eee147c3b /net/sendemail
parent5fdf9179f0e603b6031093891c4a411763764bcf (diff)
downloadports-d967bcd92fc4bb4a1299f0d2eec337dfce343a01.tar.gz
ports-d967bcd92fc4bb4a1299f0d2eec337dfce343a01.zip
Notes
Diffstat (limited to 'net/sendemail')
-rw-r--r--net/sendemail/Makefile37
-rw-r--r--net/sendemail/distinfo3
-rw-r--r--net/sendemail/pkg-descr8
3 files changed, 48 insertions, 0 deletions
diff --git a/net/sendemail/Makefile b/net/sendemail/Makefile
new file mode 100644
index 000000000000..109dc34621e5
--- /dev/null
+++ b/net/sendemail/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: sendEmail
+# Date created: 2005-12-17
+# Whom: Ion-Mihai "IOnut" Tetcu <itetcu@people.tecnik93.com>
+#
+# $FreeBSD$
+#
+# $Tecnik: ports/net/sendemail/Makefile,v 1.1 2005/12/17 01:22:24 itetcu Exp $
+
+PORTNAME= sendEmail
+PORTVERSION= 1.52
+CATEGORIES= net
+MASTER_SITES= http://caspian.dotconf.net/menu/Software/SendEmail/ \
+ http://people.tecnik93.com/~itetcu/FreeBSD/ports/${PORTNAME}/sources/
+DISTNAME= ${PORTNAME}-v${PORTVERSION}
+
+MAINTAINER= itetcu@people.tecnik93.com
+COMMENT= Lightweight, completly command line based, SMTP email agent
+
+NO_BUILD= yes
+USE_PERL5_RUN= yes
+USE_REINPLACE= yes
+
+PLIST_FILES= bin/sendEmail
+PORTDOCS= CHANGELOG README TODO
+
+post-patch:
+ @${REINPLACE_CMD} -e "s,/usr/bin/perl,${PERL},g" \
+ ${WRKSRC}/${PORTNAME}
+
+do-install:
+ cd ${WRKSRC} && ${INSTALL_SCRIPT} ${PORTNAME} ${PREFIX}/bin
+.ifndef(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ cd ${WRKSRC} && ${INSTALL_DATA} CHANGELOG README TODO ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/net/sendemail/distinfo b/net/sendemail/distinfo
new file mode 100644
index 000000000000..7a82d9ad6ba4
--- /dev/null
+++ b/net/sendemail/distinfo
@@ -0,0 +1,3 @@
+MD5 (sendEmail-v1.52.tar.gz) = 92b73ab3ae764f99a345b8db479b5fe5
+SHA256 (sendEmail-v1.52.tar.gz) = 4eac1e20e324e2401771c9fbdffc4d958101862a93f9b1f874b2d340366249f4
+SIZE (sendEmail-v1.52.tar.gz) = 23253
diff --git a/net/sendemail/pkg-descr b/net/sendemail/pkg-descr
new file mode 100644
index 000000000000..4542288d477f
--- /dev/null
+++ b/net/sendemail/pkg-descr
@@ -0,0 +1,8 @@
+SendEmail is a lightweight, completly command line based, SMTP email agent. If
+you have the need to send email from a command prompt this tool is perfect. It
+was designed to be used in bash scripts, Perl programs, and web sites, but it
+is also quite useful in many other contexts. SendEmail is written in Perl and
+is unique in that it requires no special modules. It has a straight forward
+interface, making it very easy to use. It can send atttachements.
+
+WWW: http://caspian.dotconf.net/menu/Software/SendEmail/