aboutsummaryrefslogtreecommitdiff
path: root/net/sendemail
diff options
context:
space:
mode:
authorIon-Mihai Tetcu <itetcu@FreeBSD.org>2012-06-04 22:48:35 +0000
committerIon-Mihai Tetcu <itetcu@FreeBSD.org>2012-06-04 22:48:35 +0000
commit59a9476e9401f85a0cb34ca87c3a0aaee3687a0d (patch)
tree7a0ffba090dc5322e477788131b9e12d481b10cc /net/sendemail
parent1d2c6eab7ac6a90624c019fb20ae78b76c893cb0 (diff)
downloadports-59a9476e9401f85a0cb34ca87c3a0aaee3687a0d.tar.gz
ports-59a9476e9401f85a0cb34ca87c3a0aaee3687a0d.zip
Notes
Diffstat (limited to 'net/sendemail')
-rw-r--r--net/sendemail/Makefile2
-rw-r--r--net/sendemail/files/patch-sendEmail11
2 files changed, 12 insertions, 1 deletions
diff --git a/net/sendemail/Makefile b/net/sendemail/Makefile
index 62d5ce61a855..2c5dac418e56 100644
--- a/net/sendemail/Makefile
+++ b/net/sendemail/Makefile
@@ -4,10 +4,10 @@
#
# $FreeBSD$
#
-# $Tecnik: ports/net/sendemail/Makefile,v 1.1 2005/12/17 01:22:24 itetcu Exp $
PORTNAME= sendEmail
PORTVERSION= 1.56
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= http://caspian.dotconf.net/menu/Software/SendEmail/ \
http://T32.TecNik93.com/FreeBSD/ports/${PORTNAME}/sources/
diff --git a/net/sendemail/files/patch-sendEmail b/net/sendemail/files/patch-sendEmail
new file mode 100644
index 000000000000..3e45240131fb
--- /dev/null
+++ b/net/sendemail/files/patch-sendEmail
@@ -0,0 +1,11 @@
+--- ./sendEmail.orig 2012-06-05 01:35:29.000000000 +0300
++++ ./sendEmail 2012-06-05 01:36:44.000000000 +0300
+@@ -1903,7 +1903,7 @@
+ if ($conf{'tls_server'} == 1 and $conf{'tls_client'} == 1 and $opt{'tls'} =~ /^(yes|auto)$/) {
+ printmsg("DEBUG => Starting TLS", 2);
+ if (SMTPchat('STARTTLS')) { quit($conf{'error'}, 1); }
+- if (! IO::Socket::SSL->start_SSL($SERVER, SSL_version => 'SSLv3 TLSv1')) {
++ if (! IO::Socket::SSL->start_SSL($SERVER)) {
+ quit("ERROR => TLS setup failed: " . IO::Socket::SSL::errstr(), 1);
+ }
+ printmsg("DEBUG => TLS: Using cipher: ". $SERVER->get_cipher(), 3);