aboutsummaryrefslogtreecommitdiff
path: root/net/serveez/Makefile
diff options
context:
space:
mode:
authorDavid W. Chapman Jr. <dwcjr@FreeBSD.org>2002-08-08 19:38:49 +0000
committerDavid W. Chapman Jr. <dwcjr@FreeBSD.org>2002-08-08 19:38:49 +0000
commit8d8485620b9172928111d9b858fc4c8d0e414e63 (patch)
tree38802d499f02f02201cc41e7a5411c4941a74cbe /net/serveez/Makefile
parent100f3b6208a18403ba41da09dab54ee6597fc2ed (diff)
downloadports-8d8485620b9172928111d9b858fc4c8d0e414e63.tar.gz
ports-8d8485620b9172928111d9b858fc4c8d0e414e63.zip
Notes
Diffstat (limited to 'net/serveez/Makefile')
-rw-r--r--net/serveez/Makefile19
1 files changed, 11 insertions, 8 deletions
diff --git a/net/serveez/Makefile b/net/serveez/Makefile
index 206684b67cf4..0f56310d01a4 100644
--- a/net/serveez/Makefile
+++ b/net/serveez/Makefile
@@ -8,23 +8,26 @@
PORTNAME= serveez
PORTVERSION= 0.1.3
+PORTREVISOIN= 1
CATEGORIES= net devel
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org
-LIB_DEPENDS= guile:${PORTSDIR}/lang/guile \
- gnugetopt:${PORTSDIR}/devel/libgnugetopt \
- bz2:${PORTSDIR}/archivers/bzip2
+LIB_DEPENDS= gnugetopt.1:${PORTSDIR}/devel/libgnugetopt \
+ guile.10:${PORTSDIR}/lang/guile
+.if !exists(/usr/bin/bzip2)
+LIB_DEPENDS+= bz2.1:${PORTSDIR}/archivers/bzip2
+.endif
GUILE_CONFIG?= ${LOCALBASE}/bin/guile-config
-USE_LIBTOOL= yes
-GNU_CONFIGURE= yes
-CONFIGURE_ENV= \
- CPPFLAGS="${CXXFLAGS} -I${LOCALBASE}/include `${GUILE_CONFIG} compile`" \
- LDFLAGS="-L${LOCALBASE}/lib -lgnugetopt `${GUILE_CONFIG} link`"
+
USE_GMAKE= yes
+USE_LIBTOOL= yes
+LIBTOOLFLAGS= --disable-ltlibs --release-ignore
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include `${GUILE_CONFIG} compile`" \
+ LDFLAGS="-L${LOCALBASE}/lib -lgnugetopt `${GUILE_CONFIG} link`"
INSTALLS_SHLIB= yes
MAN1= serveez.1