aboutsummaryrefslogtreecommitdiff
path: root/net/serveez
diff options
context:
space:
mode:
authorOliver Lehmann <oliver@FreeBSD.org>2005-06-02 20:28:41 +0000
committerOliver Lehmann <oliver@FreeBSD.org>2005-06-02 20:28:41 +0000
commit392aa128b51ff968e6db11f38b7ba6f6d0dedd33 (patch)
tree539bd22aa3ba684b6facf9ee9560d8d0cdb7c812 /net/serveez
parenta210c68356ff0dded5c7b63ac4b2d501473a84e2 (diff)
downloadports-392aa128b51ff968e6db11f38b7ba6f6d0dedd33.tar.gz
ports-392aa128b51ff968e6db11f38b7ba6f6d0dedd33.zip
Notes
Diffstat (limited to 'net/serveez')
-rw-r--r--net/serveez/Makefile8
1 files changed, 6 insertions, 2 deletions
diff --git a/net/serveez/Makefile b/net/serveez/Makefile
index cbf71296e66b..2e3636b138a0 100644
--- a/net/serveez/Makefile
+++ b/net/serveez/Makefile
@@ -25,11 +25,11 @@ GUILE_CONFIG?= ${LOCALBASE}/bin/guile-config
USE_GETOPT_LONG= yes
USE_GMAKE= yes
-USE_INC_LIBTOOL_VER=13
-LIBTOOLFLAGS= --disable-ltlibs --release-ignore
+USE_LIBTOOL_VER=15
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
INSTALLS_SHLIB= yes
+USE_REINPLACE= yes
MAN1= serveez.1 serveez-config.1
INFO= serveez serveez-api
@@ -37,4 +37,8 @@ INFO= serveez serveez-api
CPPFLAGS= `${GUILE_CONFIG} compile`
LDFLAGS= `${GUILE_CONFIG} link`
+post-patch:
+ @${REINPLACE_CMD} -e 's|-release||g' \
+ ${WRKSRC}/src/libserveez/Makefile.in
+
.include <bsd.port.mk>