aboutsummaryrefslogtreecommitdiff
path: root/net/serveez
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2013-03-02 06:39:31 +0000
committerMartin Wilke <miwi@FreeBSD.org>2013-03-02 06:39:31 +0000
commit0feba63ed6d2197326ab75ed11c25b6bc86e8958 (patch)
tree60d4a92d2ab9ac47a4aaf8b7f72b94d53504687e /net/serveez
parenta5ef2886f823761c9dc36f1fbf116b95729ac5b0 (diff)
downloadports-0feba63ed6d2197326ab75ed11c25b6bc86e8958.tar.gz
ports-0feba63ed6d2197326ab75ed11c25b6bc86e8958.zip
Notes
Diffstat (limited to 'net/serveez')
-rw-r--r--net/serveez/Makefile26
-rw-r--r--net/serveez/distinfo4
-rw-r--r--net/serveez/files/patch-src__libserveez__defines.h17
-rw-r--r--net/serveez/files/patch-src__networking-headers.h11
-rw-r--r--net/serveez/pkg-descr25
-rw-r--r--net/serveez/pkg-plist40
6 files changed, 56 insertions, 67 deletions
diff --git a/net/serveez/Makefile b/net/serveez/Makefile
index 68a386d8546a..ef6f130d6015 100644
--- a/net/serveez/Makefile
+++ b/net/serveez/Makefile
@@ -1,37 +1,35 @@
-# ex:ts=8
-# Ports collection makefile for: serveez
-# Date created: May 16, 2002
-# Whom: ijliao
-#
+# Created by: ijliao
# $FreeBSD$
-#
PORTNAME= serveez
-PORTVERSION= 0.1.7
+PORTVERSION= 0.2.0
CATEGORIES= net devel
MASTER_SITES= GNU
MAINTAINER= ports@FreeBSD.org
-COMMENT= A server framework
+COMMENT= Server framework
-LICENSE= GPLv2 # (or later)
-LICENSE_FILE= ${WRKSRC}/COPYING
+LICENSE= GPLv3 # (or later)
-LIB_DEPENDS= guile.21:${PORTSDIR}/lang/guile
+LIB_DEPENDS= guile:${PORTSDIR}/lang/guile
-USE_GMAKE= yes
+USE_XZ= yes
USE_AUTOTOOLS= libtool
-CONFIGURE_ARGS= --with-guile=${LOCALBASE}
+CONFIGURE_ARGS= --enable-libserveez-install
USE_LDCONFIG= yes
MAKE_JOBS_SAFE= yes
MAN1= serveez.1 serveez-config.1
-INFO= serveez serveez-api
+INFO= serveez
post-patch:
@${REINPLACE_CMD} -e \
'/^SUBDIRS/s|test||' ${WRKSRC}/Makefile.in
@${REINPLACE_CMD} -e \
's| -release .*||' ${WRKSRC}/src/libserveez/Makefile.in
+ @${REINPLACE_CMD} -e \
+ '/date -r/s|^|#|' ${WRKSRC}/src/irc-server/Makefile.in
+ @${ECHO_CMD} 'static char created[] = "2013-01-29 15:17 UTC";' \
+ > ${WRKSRC}/src/irc-server/timestamp.c
.include <bsd.port.mk>
diff --git a/net/serveez/distinfo b/net/serveez/distinfo
index 9dd3328a38b4..e9364e3ab812 100644
--- a/net/serveez/distinfo
+++ b/net/serveez/distinfo
@@ -1,2 +1,2 @@
-SHA256 (serveez-0.1.7.tar.gz) = 7272b29c731790160d2b3174be1529bc145f7d5557554e4add01e5820750c694
-SIZE (serveez-0.1.7.tar.gz) = 896966
+SHA256 (serveez-0.2.0.tar.xz) = 0508ddc828e0b13e4ce2a646f05e573313a917010cbcfa1f3c132fea6520b05c
+SIZE (serveez-0.2.0.tar.xz) = 812360
diff --git a/net/serveez/files/patch-src__libserveez__defines.h b/net/serveez/files/patch-src__libserveez__defines.h
new file mode 100644
index 000000000000..21f8e2a77421
--- /dev/null
+++ b/net/serveez/files/patch-src__libserveez__defines.h
@@ -0,0 +1,17 @@
+--- src/libserveez/defines.h.orig 2013-01-20 23:49:50.000000000 +0900
++++ src/libserveez/defines.h 2013-02-25 14:11:54.000000000 +0900
+@@ -34,6 +34,14 @@
+ #include <winsock2.h>
+ #endif
+
++#ifdef HAVE_SYS_TYPES_H
++#include <sys/types.h>
++#endif
++
++#ifdef HAVE_SYS_SOCKET_INET_H
++#include <sys/socket.h>
++#endif
++
+ #ifdef HAVE_ARPA_INET_H
+ #include <arpa/inet.h>
+ #endif
diff --git a/net/serveez/files/patch-src__networking-headers.h b/net/serveez/files/patch-src__networking-headers.h
new file mode 100644
index 000000000000..2da9d19d7c10
--- /dev/null
+++ b/net/serveez/files/patch-src__networking-headers.h
@@ -0,0 +1,11 @@
+--- src/networking-headers.h.orig
++++ src/networking-headers.h
+@@ -25,6 +25,8 @@
+ */
+ # define IPV6_OK 0
+ #else
++# include <sys/types.h>
++# include <sys/socket.h>
+ # include <arpa/inet.h>
+ # include <netinet/in.h>
+ /* See:
diff --git a/net/serveez/pkg-descr b/net/serveez/pkg-descr
index 3f058dc3b826..53bf7b934523 100644
--- a/net/serveez/pkg-descr
+++ b/net/serveez/pkg-descr
@@ -1,15 +1,16 @@
-Serveez is a server framework. It provides routines and help for implementing
-IP based servers (currently TCP, UDP and ICMP). It is also possible to use
-named pipes for all connection oriented protocols. We think it is worth the
-effort because many people need server functionality within their applications.
-However, many people experience problems with select()- or poll()-loops, and
-with non-blocking operations. This application demonstrates various aspects of
-advanced network programming in a portable manner. You can use it for
+Serveez is a server framework. It provides routines and help for
+implementing IP based servers (currently TCP, UDP and ICMP). It is also
+possible to use named pipes for all connection oriented protocols. We
+think it is worth the effort because many people need server
+functionality within their applications. However, many people
+experience problems with select()- or poll()-loops, and with
+non-blocking operations. This application demonstrates various aspects
+of advanced network programming in a portable manner. You can use it for
implementing your own servers or for understanding how certain network
-services and operations work. The package includes a number of servers that
-work already: an HTTP server, an IRC server, a Gnutella spider and some others.
-One of the highlights is that you can run all protocols on the same port. The
-application itself is single threaded but it uses helper processes for
-concurrent name resolution and ident lookups.
+services and operations work. The package includes a number of servers
+that work already: an HTTP server, an IRC server, a Gnutella spider and
+some others. One of the highlights is that you can run all protocols on
+the same port. The application itself is single threaded but it uses
+helper processes for concurrent name resolution and ident lookups.
WWW: http://www.gnu.org/software/serveez/
diff --git a/net/serveez/pkg-plist b/net/serveez/pkg-plist
index 86796ad40d72..2926151555c8 100644
--- a/net/serveez/pkg-plist
+++ b/net/serveez/pkg-plist
@@ -1,43 +1,10 @@
-bin/mkpassword
bin/serveez
bin/serveez-config
include/libserveez.h
-include/libserveez/alloc.h
-include/libserveez/array.h
-include/libserveez/asprintf.h
-include/libserveez/binding.h
-include/libserveez/boot.h
-include/libserveez/cfg.h
-include/libserveez/codec/codec.h
-include/libserveez/core.h
-include/libserveez/coserver/coserver.h
-include/libserveez/defines.h
-include/libserveez/dynload.h
-include/libserveez/hash.h
-include/libserveez/icmp-socket.h
-include/libserveez/interface.h
-include/libserveez/mutex.h
-include/libserveez/passthrough.h
-include/libserveez/pipe-socket.h
-include/libserveez/portcfg.h
-include/libserveez/raw-socket.h
-include/libserveez/server-core.h
-include/libserveez/server-loop.h
-include/libserveez/server-socket.h
-include/libserveez/server.h
-include/libserveez/snprintf.h
-include/libserveez/socket.h
-include/libserveez/sparsevec.h
-include/libserveez/tcp-socket.h
-include/libserveez/udp-socket.h
-include/libserveez/util.h
-include/libserveez/vector.h
-include/libserveez/windoze.h
-include/svzconfig.h
lib/libserveez.a
lib/libserveez.la
lib/libserveez.so
-lib/libserveez.so.0
+lib/libserveez.so.1
share/aclocal/serveez.m4
%%DATADIR%%/echo-server.scm
%%DATADIR%%/eval-server.scm
@@ -46,9 +13,4 @@ share/aclocal/serveez.m4
%%DATADIR%%/mandel-client.scm
%%DATADIR%%/mandel-server.scm
%%DATADIR%%/mandel-shared.scm
-%%DATADIR%%/serveez-procedures.txt
-%%DATADIR%%/serveez.scm
@dirrm %%DATADIR%%
-@dirrm include/libserveez/coserver
-@dirrm include/libserveez/codec
-@dirrm include/libserveez