aboutsummaryrefslogtreecommitdiff
path: root/net/service-discovery-applet
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2006-05-06 23:09:26 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2006-05-06 23:09:26 +0000
commit9ba457eba9e0f51fa37b8d3ddb2ede8ae86d7905 (patch)
tree8c4863a09e1171bf4ccfbd206342c52a50fff6ea /net/service-discovery-applet
parent8486b71dc9cda29ba10e7f3f8b7ff24a303a7896 (diff)
downloadports-9ba457eba9e0f51fa37b8d3ddb2ede8ae86d7905.tar.gz
ports-9ba457eba9e0f51fa37b8d3ddb2ede8ae86d7905.zip
Notes
Diffstat (limited to 'net/service-discovery-applet')
-rw-r--r--net/service-discovery-applet/Makefile40
-rw-r--r--net/service-discovery-applet/distinfo3
-rw-r--r--net/service-discovery-applet/files/patch-plugins_gconfterminal.py11
-rw-r--r--net/service-discovery-applet/files/patch-plugins_xvncviewer.py17
-rw-r--r--net/service-discovery-applet/files/patch-servers_Makefile.in11
-rw-r--r--net/service-discovery-applet/pkg-descr5
-rw-r--r--net/service-discovery-applet/pkg-plist44
7 files changed, 131 insertions, 0 deletions
diff --git a/net/service-discovery-applet/Makefile b/net/service-discovery-applet/Makefile
new file mode 100644
index 000000000000..2807eed23f37
--- /dev/null
+++ b/net/service-discovery-applet/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: service-discovery-applet
+# Date Created: 06 May 2006
+# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
+#
+# $FreeBSD$
+# $MCom$
+#
+
+PORTNAME= service-discovery-applet
+PORTVERSION= 0.4.1
+CATEGORIES= net dns gnome
+MASTER_SITES= http://0pointer.de/~sebest/
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= A GNOME applet that shows available network services using mDNS
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/${PYTHON_VERSION}/site-packages/avahi/__init__.py:${PORTSDIR}/net/py-avahi
+RUN_DEPENDS= ${LOCALBASE}/lib/${PYTHON_VERSION}/site-packages/avahi/__init__.py:${PORTSDIR}/net/py-avahi
+
+USE_X_PREFIX= yes
+USE_GETTEXT= yes
+USE_PYTHON= yes
+USE_GNOME= gnomehack gnomeprefix intlhack pygnomedesktop
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+INSTALLS_ICONS= yes
+CONFIGURE_ARGS= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+GCONF_SCHEMAS= service-discovery-applet.schemas
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|g' \
+ ${WRKSRC}/plugins/gconfterminal.py
+
+post-install:
+ @${X11BASE}/bin/gtk-update-icon-cache -f -q --ignore-theme-index \
+ ${PREFIX}/share/gnome/service-discovery-applet/icons
+
+.include <bsd.port.mk>
diff --git a/net/service-discovery-applet/distinfo b/net/service-discovery-applet/distinfo
new file mode 100644
index 000000000000..d5ec947f2cc0
--- /dev/null
+++ b/net/service-discovery-applet/distinfo
@@ -0,0 +1,3 @@
+MD5 (service-discovery-applet-0.4.1.tar.gz) = 9160ca6ab87836086675a7eeb082b75f
+SHA256 (service-discovery-applet-0.4.1.tar.gz) = 45ffb522d0a714c4e99c78c7d025a0d07b49cb7f3458cfcb08006cefb80fff78
+SIZE (service-discovery-applet-0.4.1.tar.gz) = 173828
diff --git a/net/service-discovery-applet/files/patch-plugins_gconfterminal.py b/net/service-discovery-applet/files/patch-plugins_gconfterminal.py
new file mode 100644
index 000000000000..5350ae501020
--- /dev/null
+++ b/net/service-discovery-applet/files/patch-plugins_gconfterminal.py
@@ -0,0 +1,11 @@
+--- plugins/gconfterminal.py.orig Sat May 6 18:53:01 2006
++++ plugins/gconfterminal.py Sat May 6 18:53:10 2006
+@@ -16,7 +16,7 @@ from sdapplet.pluginutils import *
+
+ try:
+ import gettext
+- gettext.bindtextdomain("service-discovery-applet", "/usr/share/locale")
++ gettext.bindtextdomain("service-discovery-applet", "%%PREFIX%%/share/locale")
+ gettext.textdomain("service-discovery-applet")
+ _ = gettext.gettext
+ import pygtk
diff --git a/net/service-discovery-applet/files/patch-plugins_xvncviewer.py b/net/service-discovery-applet/files/patch-plugins_xvncviewer.py
new file mode 100644
index 000000000000..6bf6220f039c
--- /dev/null
+++ b/net/service-discovery-applet/files/patch-plugins_xvncviewer.py
@@ -0,0 +1,17 @@
+--- plugins/xvncviewer.py.orig Sat May 6 15:19:12 2006
++++ plugins/xvncviewer.py Sat May 6 15:20:13 2006
+@@ -19,11 +19,11 @@ class plugin_xvncviewer:
+ def __init__(self):
+ self.service_type = ["_rfb._tcp"]
+ self.author = "Sebastien Estienne"
+- self.description = "Start a VNC connections with xvncviewer"
++ self.description = "Start a VNC connections with vncviewer"
+
+ def connect(self, use_host_names, name, stype, hostname, address, port, txts):
+- print "connecting using xvncviewer"
+- cmdline = ["xvncviewer", "-xrm", "*passwordDialog:true", hostname ]
++ print "connecting using vncviewer"
++ cmdline = ["vncviewer", "-xrm", "*passwordDialog:true",]
+ print cmdline
+ pid = subprocess.Popen(cmdline, close_fds=True).pid
+
diff --git a/net/service-discovery-applet/files/patch-servers_Makefile.in b/net/service-discovery-applet/files/patch-servers_Makefile.in
new file mode 100644
index 000000000000..72f9f08f624b
--- /dev/null
+++ b/net/service-discovery-applet/files/patch-servers_Makefile.in
@@ -0,0 +1,11 @@
+--- servers/Makefile.in.orig Sat May 6 15:01:00 2006
++++ servers/Makefile.in Sat May 6 15:01:20 2006
+@@ -367,7 +367,7 @@ uninstall-am: uninstall-info-am uninstal
+ @INTLTOOL_SERVER_RULE@
+
+ all: GNOME_ServiceDiscoveryApplet.server
+- sed -i \
++ sed -i "" \
+ -e 's,@bindir\@,$(bindir),g' \
+ -e 's,@iconsdir\@,$(ICONSDIR),g' \
+ GNOME_ServiceDiscoveryApplet.server
diff --git a/net/service-discovery-applet/pkg-descr b/net/service-discovery-applet/pkg-descr
new file mode 100644
index 000000000000..db14690613f5
--- /dev/null
+++ b/net/service-discovery-applet/pkg-descr
@@ -0,0 +1,5 @@
+Service-discovery-applet is a GNOME applet that interfaces with the Avahi
+mDNS Service Discovery system to graphically show a list of available
+network services.
+
+WWW: http://www.avahi.org/
diff --git a/net/service-discovery-applet/pkg-plist b/net/service-discovery-applet/pkg-plist
new file mode 100644
index 000000000000..2f5f8265d0c9
--- /dev/null
+++ b/net/service-discovery-applet/pkg-plist
@@ -0,0 +1,44 @@
+bin/service-discovery-applet
+bin/service-discovery-config
+lib/%%PYTHON_VERSION%%/site-packages/sdapplet/__init__.py
+lib/%%PYTHON_VERSION%%/site-packages/sdapplet/__init__.pyc
+lib/%%PYTHON_VERSION%%/site-packages/sdapplet/__init__.pyo
+lib/%%PYTHON_VERSION%%/site-packages/sdapplet/pluginloader.py
+lib/%%PYTHON_VERSION%%/site-packages/sdapplet/pluginloader.pyc
+lib/%%PYTHON_VERSION%%/site-packages/sdapplet/pluginloader.pyo
+lib/%%PYTHON_VERSION%%/site-packages/sdapplet/pluginutils.py
+lib/%%PYTHON_VERSION%%/site-packages/sdapplet/pluginutils.pyc
+lib/%%PYTHON_VERSION%%/site-packages/sdapplet/pluginutils.pyo
+libdata/bonobo/servers/GNOME_ServiceDiscoveryApplet.server
+share/gnome/service-discovery-applet/icons/24x24/_ftp._tcp.png
+share/gnome/service-discovery-applet/icons/24x24/_http._tcp.png
+share/gnome/service-discovery-applet/icons/24x24/_https._tcp.png
+share/gnome/service-discovery-applet/icons/24x24/_rfb._tcp.png
+share/gnome/service-discovery-applet/icons/24x24/_sftp-ssh._tcp.png
+share/gnome/service-discovery-applet/icons/24x24/_ssh._tcp.png
+share/gnome/service-discovery-applet/icons/24x24/service-discovery-applet.png
+share/gnome/service-discovery-applet/icons/48x48/_ftp._tcp.png
+share/gnome/service-discovery-applet/icons/48x48/_http._tcp.png
+share/gnome/service-discovery-applet/icons/48x48/_https._tcp.png
+share/gnome/service-discovery-applet/icons/48x48/_rfb._tcp.png
+share/gnome/service-discovery-applet/icons/48x48/_sftp-ssh._tcp.png
+share/gnome/service-discovery-applet/icons/48x48/_ssh._tcp.png
+share/gnome/service-discovery-applet/icons/48x48/service-discovery-applet.png
+share/gnome/service-discovery-applet/icons/icon-theme.cache
+share/gnome/service-discovery-applet/interfaces/service-discovery-config.glade
+share/gnome/service-discovery-applet/plugins/ekiga.py
+share/gnome/service-discovery-applet/plugins/gconfterminal.py
+share/gnome/service-discovery-applet/plugins/nautilus.py
+share/gnome/service-discovery-applet/plugins/xvncviewer.py
+share/locale/da/LC_MESSAGES/service-discovery-applet.mo
+share/locale/de/LC_MESSAGES/service-discovery-applet.mo
+share/locale/fr/LC_MESSAGES/service-discovery-applet.mo
+@dirrm share/gnome/service-discovery-applet/plugins
+@dirrm share/gnome/service-discovery-applet/interfaces
+@dirrm share/gnome/service-discovery-applet/icons/48x48
+@dirrm share/gnome/service-discovery-applet/icons/24x24
+@dirrm share/gnome/service-discovery-applet/icons
+@dirrm share/gnome/service-discovery-applet
+@dirrm lib/%%PYTHON_VERSION%%/site-packages/sdapplet
+@dirrmtry lib/%%PYTHON_VERSION%%/site-packages
+@dirrmtry lib/%%PYTHON_VERSION%%