aboutsummaryrefslogtreecommitdiff
path: root/net/serviio
diff options
context:
space:
mode:
authorMikhail Teterin <mi@FreeBSD.org>2011-02-28 00:15:23 +0000
committerMikhail Teterin <mi@FreeBSD.org>2011-02-28 00:15:23 +0000
commitcc46d7ad5207b3c9bc343537981d5833719cef59 (patch)
tree1a9f2258637a4a10c03af9fb407e4988954bd3e6 /net/serviio
parent53b3401a74edce34d8db41a43a9c71efbcf7f4b2 (diff)
downloadports-cc46d7ad5207b3c9bc343537981d5833719cef59.tar.gz
ports-cc46d7ad5207b3c9bc343537981d5833719cef59.zip
Notes
Diffstat (limited to 'net/serviio')
-rw-r--r--net/serviio/Makefile53
-rw-r--r--net/serviio/distinfo2
-rw-r--r--net/serviio/pkg-descr19
-rw-r--r--net/serviio/pkg-plist27
4 files changed, 101 insertions, 0 deletions
diff --git a/net/serviio/Makefile b/net/serviio/Makefile
new file mode 100644
index 000000000000..49bc8603f5af
--- /dev/null
+++ b/net/serviio/Makefile
@@ -0,0 +1,53 @@
+# New ports collection makefile for: serviio
+# Date created: 2011-01-03
+# Whom: Mikhail Teterin <mi@aldan.algebra.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= serviio
+PORTVERSION= 0.5
+CATEGORIES= net multimedia java www
+MASTER_SITES= http://download.serviio.org/releases/
+EXTRACT_SUFX= -linux.tar.gz
+
+MAINTAINER= mi@aldan.algebra.com
+COMMENT= Transcoding DLNA-server implemented in Java
+
+RUN_DEPENDS= ffmpeg:${PORTSDIR}/multimedia/ffmpeg
+
+NO_BUILD= yes
+USE_JAVA= yes
+USE_DOS2UNIX= derby.properties
+
+PKGMESSAGE= ${WRKSRC}/pkg-message
+SUB_FILES+= pkg-message serviiod serviio-console
+USE_RC_SUBR= serviio
+SUB_LIST+= USER=${USERS}
+RESTRICTED= License does not allow selling
+
+USERS= dlna
+GROUPS= dlna
+
+do-install:
+ ${MKDIR} ${JAVAJARDIR}/${PORTNAME}
+ ${INSTALL_DATA} ${WRKSRC}/lib/*.jar ${JAVAJARDIR}/${PORTNAME}/
+ ${MKDIR} ${PREFIX}/etc/${PORTNAME}
+.for f in profiles log4j
+ ${INSTALL_DATA} ${WRKSRC}/config/$f.xml ${ETCDIR}/$f.dist.xml
+ ${TEST} -e ${ETCDIR}/$f.xml ||
+ ${INSTALL_DATA} ${WRKSRC}/config/$f.xml ${ETCDIR}/
+.endfor
+ ${INSTALL_DATA} ${FILESDIR}/console-log4j.properties \
+ ${ETCDIR}/console-log4j.dist.properties
+ ${TEST} -e ${ETCDIR}/console-log4.dist.properties ||
+ ${INSTALL_DATA} ${FILESDIR}/console-log4j.properties ${ETCDIR}/
+ ${INSTALL_SCRIPT} ${WRKDIR}/serviiod ${PREFIX}/sbin
+ ${INSTALL_SCRIPT} ${WRKDIR}/serviio-console ${PREFIX}/bin
+
+post-install:
+ # =========================================================
+ @${FMT} ${PKGMESSAGE}
+ # =========================================================
+
+.include <bsd.port.mk>
diff --git a/net/serviio/distinfo b/net/serviio/distinfo
new file mode 100644
index 000000000000..9e66c48849bf
--- /dev/null
+++ b/net/serviio/distinfo
@@ -0,0 +1,2 @@
+SHA256 (serviio-0.5-linux.tar.gz) = 1001e1fcf379c4d582e015ecdf19a01579c1019197bcf53ce16d4816ff1f87a8
+SIZE (serviio-0.5-linux.tar.gz) = 7566385
diff --git a/net/serviio/pkg-descr b/net/serviio/pkg-descr
new file mode 100644
index 000000000000..9651f6248cce
--- /dev/null
+++ b/net/serviio/pkg-descr
@@ -0,0 +1,19 @@
+Serviio is a free DLNA media server. It allows you to stream your
+media files (music, video or images) to any DLNA-certified renderer
+device (e.g. a TV set, Bluray player, games console) on your home
+network.
+
+Serviio uses a priority-based metadata extraction so that you can
+choose what metadata should describe your media files (e.g. audio
+track name, DVD cover, TV series and episodes names, etc.). These
+include metadata embedded into the media files themselves, locally
+stored metadata files and metadata that can be obtained online.
+With this powerful tool you will be able to build your Serviio media
+library easily and effectively.
+
+Serviio works with any DLNA compliant device (TV, Playstation 3,
+etc.) and some other (XBox 360). It supports profiles for particular
+devices so that it can be tuned to maximise the device's potential
+and/or minimize lack of media format playback support (via transcoding).
+
+WWW: http://www.serviio.org/
diff --git a/net/serviio/pkg-plist b/net/serviio/pkg-plist
new file mode 100644
index 000000000000..0a0bd426ec8e
--- /dev/null
+++ b/net/serviio/pkg-plist
@@ -0,0 +1,27 @@
+sbin/serviiod
+bin/serviio-console
+%%JAVAJARDIR%%/serviio/serviio-client.jar
+%%JAVAJARDIR%%/serviio/serviio.jar
+%%JAVAJARDIR%%/serviio/log4j.jar
+%%JAVAJARDIR%%/serviio/freemarker.jar
+%%JAVAJARDIR%%/serviio/derby.jar
+%%JAVAJARDIR%%/serviio/jaudiotagger.jar
+%%JAVAJARDIR%%/serviio/sanselan.jar
+%%JAVAJARDIR%%/serviio/slf4j-api.jar
+%%JAVAJARDIR%%/serviio/jul-to-slf4j.jar
+%%JAVAJARDIR%%/serviio/slf4j-log4j12.jar
+%%JAVAJARDIR%%/serviio/jcl-over-slf4j.jar
+%%JAVAJARDIR%%/serviio/jcs.jar
+%%JAVAJARDIR%%/serviio/concurrent.jar
+%%JAVAJARDIR%%/serviio/xstream.jar
+%%JAVAJARDIR%%/serviio/org.restlet.jar
+%%JAVAJARDIR%%/serviio/org.restlet.ext.xstream.jar
+%%JAVAJARDIR%%/serviio/httpcore.jar
+@dirrm %%JAVAJARDIR%%/serviio
+@unexec cmp %D/%%ETCDIR%%/profiles.xml %D/%%ETCDIR%%/profiles.dist.xml && rm -f %D/%%ETCDIR%%/profiles.xml || echo Modified profiles.xml remains in %D/%%ETCDIR%%
+@unexec cmp %D/%%ETCDIR%%/log4j.xml %D/%%ETCDIR%%/log4j.dist.xml && rm -f %D/%%ETCDIR%%/log4j.xml || echo Modified log4j.xml remains in %D/%%ETCDIR%%
+@unexec cmp %D/%%ETCDIR%%/console-log4j.properties %D/%%ETCDIR%%/console-log4j.dist.properties && rm -f %D/%%ETCDIR%%/console-log4j.properties || echo Modified console-log4j.properties remains in %D/%%ETCDIR%%
+%%ETCDIR%%/profiles.dist.xml
+%%ETCDIR%%/log4j.dist.xml
+%%ETCDIR%%/console-log4j.dist.properties
+@dirrmtry %%ETCDIR%%