aboutsummaryrefslogtreecommitdiff
path: root/net/sflowtool
diff options
context:
space:
mode:
authorOlli Hauer <ohauer@FreeBSD.org>2014-05-31 09:59:24 +0000
committerOlli Hauer <ohauer@FreeBSD.org>2014-05-31 09:59:24 +0000
commit52bb5e052bfabbf9d66e77795be82d013498edc6 (patch)
tree5b9229913a9d16ef0a875ab4da1025afef1a37e7 /net/sflowtool
parent4a998e29a96943e4e8efb19213a7a95f0d18cc28 (diff)
downloadports-52bb5e052bfabbf9d66e77795be82d013498edc6.tar.gz
ports-52bb5e052bfabbf9d66e77795be82d013498edc6.zip
Notes
Diffstat (limited to 'net/sflowtool')
-rw-r--r--net/sflowtool/Makefile2
-rw-r--r--net/sflowtool/distinfo4
-rw-r--r--net/sflowtool/files/patch-src__sflowtool.c39
3 files changed, 42 insertions, 3 deletions
diff --git a/net/sflowtool/Makefile b/net/sflowtool/Makefile
index 0332ef0647e8..d322ee6275cb 100644
--- a/net/sflowtool/Makefile
+++ b/net/sflowtool/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= sflowtool
-PORTVERSION= 3.30
+PORTVERSION= 3.32
CATEGORIES= net
MASTER_SITES= http://www.inmon.com/bin/
diff --git a/net/sflowtool/distinfo b/net/sflowtool/distinfo
index 0222b6e0dba9..96f831fb562e 100644
--- a/net/sflowtool/distinfo
+++ b/net/sflowtool/distinfo
@@ -1,2 +1,2 @@
-SHA256 (sflowtool-3.30.tar.gz) = 38e7929889ce4f9de6bc55b61dc209b842902434a822c60bc572a3d9f6c3843c
-SIZE (sflowtool-3.30.tar.gz) = 169194
+SHA256 (sflowtool-3.32.tar.gz) = edb40902e76377b12a08a513bf49776e0a70e43c7f541f77de995cc23ccb7343
+SIZE (sflowtool-3.32.tar.gz) = 171316
diff --git a/net/sflowtool/files/patch-src__sflowtool.c b/net/sflowtool/files/patch-src__sflowtool.c
new file mode 100644
index 000000000000..16be85fb1f76
--- /dev/null
+++ b/net/sflowtool/files/patch-src__sflowtool.c
@@ -0,0 +1,39 @@
+--- ./src/sflowtool.c.orig 2014-05-27 21:09:17.000000000 +0200
++++ ./src/sflowtool.c 2014-05-31 09:15:00.000000000 +0200
+@@ -442,7 +442,7 @@
+ void *my_calloc(size_t bytes) {
+ void *mem = calloc(1, bytes);
+ if(mem == NULL) {
+- fprintf(ERROUT, "calloc(%u) failed: %s\n", bytes, strerror(errno));
++ fprintf(ERROUT, "calloc(%zu) failed: %s\n", bytes, strerror(errno));
+ exit(-1);
+ }
+ return mem;
+@@ -554,7 +554,7 @@
+ register char c, *r = in, *w = out;
+ int maxlen = (strlen(in) * 3) + 1;
+ if(outlen < maxlen) return "URLEncode: not enough space";
+- while (c = *r++) {
++ while ((c = *r++)) {
+ if(isalnum(c)) *w++ = c;
+ else if(isspace(c)) *w++ = '+';
+ else {
+@@ -3075,7 +3075,7 @@
+ uint8_t *uuid;
+ char hostname[SFL_MAX_HOSTNAME_LEN+1];
+ char os_release[SFL_MAX_OSRELEASE_LEN+1];
+- char uuidStr[100];
++ u_char uuidStr[100];
+ if(getString(sample, hostname, SFL_MAX_HOSTNAME_LEN) > 0) {
+ sf_log(sample,"hostname %s\n", hostname);
+ }
+@@ -3921,7 +3921,8 @@
+ static void readPacket(int soc)
+ {
+ struct sockaddr_in6 peer;
+- int alen, cc;
++ int cc;
++ u_int alen;
+ #define MAX_PKT_SIZ 65536
+ char buf[MAX_PKT_SIZ];
+ alen = sizeof(peer);