aboutsummaryrefslogtreecommitdiff
path: root/net/sflowtool
diff options
context:
space:
mode:
authorFrank J. Laszlo <laszlof@FreeBSD.org>2007-03-28 02:44:47 +0000
committerFrank J. Laszlo <laszlof@FreeBSD.org>2007-03-28 02:44:47 +0000
commit4df8e791b4f53e1f64bf167d5586581f041bed11 (patch)
tree2080838ec853b0e3ccbd9b36d7a6919965d73df1 /net/sflowtool
parent65bf7034dcc217a1893204ab56474051621d1252 (diff)
downloadports-4df8e791b4f53e1f64bf167d5586581f041bed11.tar.gz
ports-4df8e791b4f53e1f64bf167d5586581f041bed11.zip
Notes
Diffstat (limited to 'net/sflowtool')
-rw-r--r--net/sflowtool/Makefile7
-rw-r--r--net/sflowtool/distinfo6
-rw-r--r--net/sflowtool/files/sflowtool.in21
3 files changed, 28 insertions, 6 deletions
diff --git a/net/sflowtool/Makefile b/net/sflowtool/Makefile
index 6cb8ef3ebb88..87292ddd5e19 100644
--- a/net/sflowtool/Makefile
+++ b/net/sflowtool/Makefile
@@ -1,19 +1,20 @@
# New ports collection makefile for: sflowtool
# Date created: 21 Mar 2006
-# Whom: Gregory Edigarov <greg@velcom.com>
+# Whom: Gregory Edigarov <greg@bestnet.kharkov.ua>
#
# $FreeBSD$
#
PORTNAME= sflowtool
-PORTVERSION= 3.9
+PORTVERSION= 3.10
CATEGORIES= net
MASTER_SITES= http://www.inmon.com/bin/
-MAINTAINER= greg@velcom.com
+MAINTAINER= greg@bestnet.kharkov.ua
COMMENT= This is a sFlow capture and sFlow-to-NetFlow conversion tool
GNU_CONFIGURE= yes
+USE_RC_SUBR= ${PORTNAME}
PLIST_FILES= bin/sflowtool
PORTDOCS= README
diff --git a/net/sflowtool/distinfo b/net/sflowtool/distinfo
index 6aa757e2e9cb..3df021fbe747 100644
--- a/net/sflowtool/distinfo
+++ b/net/sflowtool/distinfo
@@ -1,3 +1,3 @@
-MD5 (sflowtool-3.9.tar.gz) = 1e7d2012ea2d84576e0077d695c8462c
-SHA256 (sflowtool-3.9.tar.gz) = 1ff824443354a49b8fb70c925b2e27a35b016ddfa69926da78a55fde5f2bb0a8
-SIZE (sflowtool-3.9.tar.gz) = 114317
+MD5 (sflowtool-3.10.tar.gz) = b087e5817f54e77e589fcc910b253125
+SHA256 (sflowtool-3.10.tar.gz) = dae2edbfd4682338e8ffbf1ff1e26bd08137027417c97f4bfc622c8ab610ace5
+SIZE (sflowtool-3.10.tar.gz) = 122119
diff --git a/net/sflowtool/files/sflowtool.in b/net/sflowtool/files/sflowtool.in
new file mode 100644
index 000000000000..0f83f2f43329
--- /dev/null
+++ b/net/sflowtool/files/sflowtool.in
@@ -0,0 +1,21 @@
+#!/bin/sh
+#
+# PROVIDE: sflowtool
+# REQUIRE: DAEMON
+
+. %%RC_SUBR%%
+
+name="sflowtool"
+rcvar=`set_rcvar`
+command="%%PREFIX%%/bin/sflowtool"
+
+load_rc_config $name
+# Set defaults
+: ${sflowtool_enable="NO"}
+: ${sflowtool_flags=""}
+: ${sflowtool_pidfile="/var/run/${name}.pid"}
+
+start_cmd="/usr/sbin/daemon -f -p ${sflowtool_pidfile} ${command} ${sflowtool_flags}"
+start_postcmd="echo Starting ${name}."
+
+run_rc_command "$1"