aboutsummaryrefslogtreecommitdiff
path: root/net/silc-client/Makefile
diff options
context:
space:
mode:
authorAndrej Zverev <az@FreeBSD.org>2013-09-15 14:54:36 +0000
committerAndrej Zverev <az@FreeBSD.org>2013-09-15 14:54:36 +0000
commite47ac01488c933a3a8a38b32ba35d4f9c4992493 (patch)
tree91f65c922c2cbbcdd7ea9f42b5c0a34dcfedcb0c /net/silc-client/Makefile
parent3796ff69397692329dd89edad8abbabebdc2e36c (diff)
downloadports-e47ac01488c933a3a8a38b32ba35d4f9c4992493.tar.gz
ports-e47ac01488c933a3a8a38b32ba35d4f9c4992493.zip
Notes
Diffstat (limited to 'net/silc-client/Makefile')
-rw-r--r--net/silc-client/Makefile6
1 files changed, 2 insertions, 4 deletions
diff --git a/net/silc-client/Makefile b/net/silc-client/Makefile
index c560d9956a90..0321e0a23a9b 100644
--- a/net/silc-client/Makefile
+++ b/net/silc-client/Makefile
@@ -23,12 +23,10 @@ CONFLICTS= silc-toolkit-1.1.* silc-irssi-plugin-1.1.*
USE_BZIP2= yes
GNU_CONFIGURE= yes
USE_GNOME= glib20
-USES= pkgconfig
-USE_GMAKE= yes
+USES= pkgconfig gmake
USE_LDCONFIG= yes
CONFIGURE_ARGS= --docdir=${DOCSDIR} \
--without-libtoolfix
-WANT_PERL= yes
OPTIONS_DEFINE= PTHREADS IPV6 ICONV PERL
OPTIONS_DEFINE_i386= ASM
@@ -94,7 +92,7 @@ CONFIGURE_ARGS+= --without-iconv
.endif
.if ${PORT_OPTIONS:MPERL}
-USE_PERL5= yes
+USES+= perl5
PERL_ARCHNAME!= perl -V:archname 2>/dev/null || ${ECHO_CMD}
PLIST_SUB+= WITH_PERL="" PERL_ARCHNAME="${PERL_ARCHNAME:S/archname='//:S/';//}"
CONFIGURE_ARGS+= --with-perl-lib=${PREFIX}/lib/${PORTNAME}/perl