aboutsummaryrefslogtreecommitdiff
path: root/net/silc-client/Makefile
diff options
context:
space:
mode:
authorMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2001-11-09 07:46:16 +0000
committerMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2001-11-09 07:46:16 +0000
commit22f6a5de2184e95d6e400606afa1d63138fbc6f0 (patch)
tree7a361c041032b25121bb3a4cbd32dba5a2f5c1d1 /net/silc-client/Makefile
parentf11935b0d55d48cad44c74a2f47a70ed69ee5ab1 (diff)
downloadports-22f6a5de2184e95d6e400606afa1d63138fbc6f0.tar.gz
ports-22f6a5de2184e95d6e400606afa1d63138fbc6f0.zip
Notes
Diffstat (limited to 'net/silc-client/Makefile')
-rw-r--r--net/silc-client/Makefile67
1 files changed, 67 insertions, 0 deletions
diff --git a/net/silc-client/Makefile b/net/silc-client/Makefile
new file mode 100644
index 000000000000..3b408e78471c
--- /dev/null
+++ b/net/silc-client/Makefile
@@ -0,0 +1,67 @@
+# New ports collection makefile for: silc client
+# Date created: Thu Nov 8 01:50:05 BRST 2001
+# Whom: Mario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= silc
+PORTVERSION= 0.6.4
+CATEGORIES= net security
+MASTER_SITES= http://www.silcnet.org/download/ \
+ ftp://ftp.silcnet.org/pub/silc/
+PKGNAMESUFFIX= -client
+DISTNAME= ${PORTNAME}${PKGNAMESUFFIX}-${PORTVERSION}
+
+MAINTAINER= lioux@FreeBSD.org
+
+USE_BZIP2= yes
+GNU_CONFIGURE= yes
+USE_GLIB= yes
+CONFIGURE_ARGS= --with-docdir=share/doc/${PORTNAME} \
+ --with-etcdir=${PREFIX}/etc/${PORTNAME} \
+ --with-helpdir=share/${PORTNAME}/help \
+ --with-simdir=libexec/${PORTNAME}/modules
+PLIST_SUB= INSTALL_DIR="${INSTALL_DIR}"
+
+INSTALL_DIR?= ${INSTALL} -d -o ${BINOWN} -g ${BINGRP} -m 755
+
+.ifdef(NOPORTDOCS)
+EXTRA_PATCHES+= ${FILESDIR}/extra-patch-Makefile.in-noportdocs
+.endif
+
+.ifdef(WITHOUT_OPTIMIZED_ASM)
+CONFIGURE_ARGS+= --disable-asm
+.endif
+
+.ifndef(WITH_PTHREADS)
+CONFIGURE_ARGS+= --disable-threads
+.else
+CONFIGURE_ENV+= CFLAGS="${CFLAGS} ${PTHREAD_CFLAGS} ${PTHREAD_LIBS}"
+.endif
+
+pre-everything::
+.ifndef(WITHOUT_OPTIMIZED_ASM)
+ @${ECHO_MSG} '===> Define WITHOUT_OPTIMIZED_ASM to disable assembler optimizations'
+.endif
+.ifndef(WITH_PTHREADS)
+ @${ECHO_MSG} '===> Define WITH_PTHREADS to enable pthreads support'
+.endif
+ @${ECHO_MSG}
+.ifndef(WITH_OPTIMIZED_CFLAGS)
+ @${ECHO_MSG} '===> Define WITH_OPTIMIZED_CFLAGS to enable compilation optimizations'
+ @${ECHO_MSG} '===> which is known to break some platforms (e.g., alpha)'
+.endif
+
+post-patch:
+.ifndef(WITH_OPTIMIZED_CFLAGS)
+ @${PERL} -pi -e 's/-O2//' ${WRKSRC}/${CONFIGURE_SCRIPT}
+.endif
+
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} != "i386"
+WITHOUT_OPTIMIZED_ASM= yes
+.endif
+
+.include <bsd.port.post.mk>