aboutsummaryrefslogtreecommitdiff
path: root/net/silc-client
diff options
context:
space:
mode:
authorWesley Shields <wxs@FreeBSD.org>2008-07-24 02:57:09 +0000
committerWesley Shields <wxs@FreeBSD.org>2008-07-24 02:57:09 +0000
commitecc807e9d06cf5029c856a766f7c15004c08c4f2 (patch)
treeac65f60dd801436fb8e3efd874f92b681b57dfa4 /net/silc-client
parent35b0fcbc51bc487fbb4fcb04175a56d5a51fa1a1 (diff)
downloadports-ecc807e9d06cf5029c856a766f7c15004c08c4f2.tar.gz
ports-ecc807e9d06cf5029c856a766f7c15004c08c4f2.zip
Notes
Diffstat (limited to 'net/silc-client')
-rw-r--r--net/silc-client/Makefile5
-rw-r--r--net/silc-client/files/extra-patch-apps__irssi__src__fe-common__Makefile.in11
2 files changed, 15 insertions, 1 deletions
diff --git a/net/silc-client/Makefile b/net/silc-client/Makefile
index 9da2afdf9ff5..f60464c8dd00 100644
--- a/net/silc-client/Makefile
+++ b/net/silc-client/Makefile
@@ -46,7 +46,10 @@ CONFIGURE_ARGS+= --with-silc-plugin=${PREFIX}/lib/irssi \
CFLAGS+= -fPIC
RUN_DEPENDS= irssi:${PORTSDIR}/irc/irssi
# We don't want to install the man page and configuration file for this case
-EXTRA_PATCHES= ${FILESDIR}/extra-patch-apps__irssi__Makefile.in
+# Also, the port makes an extra symlink which causes IRSSI to load the plugin
+# twice. This causes weird behavior such as /me output showing up twice.
+EXTRA_PATCHES= ${FILESDIR}/extra-patch-apps__irssi__Makefile.in \
+ ${FILESDIR}/extra-patch-apps__irssi__src__fe-common__Makefile.in
.else
MAN1= silc.1
.endif
diff --git a/net/silc-client/files/extra-patch-apps__irssi__src__fe-common__Makefile.in b/net/silc-client/files/extra-patch-apps__irssi__src__fe-common__Makefile.in
new file mode 100644
index 000000000000..20df2c9830d9
--- /dev/null
+++ b/net/silc-client/files/extra-patch-apps__irssi__src__fe-common__Makefile.in
@@ -0,0 +1,11 @@
+--- apps/irssi/src/fe-common/silc/Makefile.in.orig 2008-07-23 21:08:35.000000000 -0400
++++ apps/irssi/src/fe-common/silc/Makefile.in 2008-07-23 21:08:47.000000000 -0400
+@@ -651,8 +651,6 @@
+ libfe_common_silc.a: libfe_common_silc.la
+ cp .libs/libfe_common_silc.a .
+
+-@SILCPLUGIN_TRUE@install-data-hook: libfe_common_silc.la
+-@SILCPLUGIN_TRUE@ -ln -s libfe_common_silc.so $(DESTDIR)$(moduledir)/libfe_silc.so
+ # Tell versions [3.59,3.63) of GNU make to not export all variables.
+ # Otherwise a system limit (for SysV at least) may be exceeded.
+ .NOEXPORT: