aboutsummaryrefslogtreecommitdiff
path: root/net/silc-client
diff options
context:
space:
mode:
authorMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2001-11-09 07:46:16 +0000
committerMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2001-11-09 07:46:16 +0000
commit22f6a5de2184e95d6e400606afa1d63138fbc6f0 (patch)
tree7a361c041032b25121bb3a4cbd32dba5a2f5c1d1 /net/silc-client
parentf11935b0d55d48cad44c74a2f47a70ed69ee5ab1 (diff)
downloadports-22f6a5de2184e95d6e400606afa1d63138fbc6f0.tar.gz
ports-22f6a5de2184e95d6e400606afa1d63138fbc6f0.zip
Notes
Diffstat (limited to 'net/silc-client')
-rw-r--r--net/silc-client/Makefile67
-rw-r--r--net/silc-client/distinfo1
-rw-r--r--net/silc-client/files/extra-patch-Makefile.in-noportdocs34
-rw-r--r--net/silc-client/files/patch-Makefile.in14
-rw-r--r--net/silc-client/files/patch-configure11
-rw-r--r--net/silc-client/files/patch-doc:Makefile.in10
-rw-r--r--net/silc-client/pkg-comment1
-rw-r--r--net/silc-client/pkg-descr17
-rw-r--r--net/silc-client/pkg-plist104
9 files changed, 259 insertions, 0 deletions
diff --git a/net/silc-client/Makefile b/net/silc-client/Makefile
new file mode 100644
index 000000000000..3b408e78471c
--- /dev/null
+++ b/net/silc-client/Makefile
@@ -0,0 +1,67 @@
+# New ports collection makefile for: silc client
+# Date created: Thu Nov 8 01:50:05 BRST 2001
+# Whom: Mario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= silc
+PORTVERSION= 0.6.4
+CATEGORIES= net security
+MASTER_SITES= http://www.silcnet.org/download/ \
+ ftp://ftp.silcnet.org/pub/silc/
+PKGNAMESUFFIX= -client
+DISTNAME= ${PORTNAME}${PKGNAMESUFFIX}-${PORTVERSION}
+
+MAINTAINER= lioux@FreeBSD.org
+
+USE_BZIP2= yes
+GNU_CONFIGURE= yes
+USE_GLIB= yes
+CONFIGURE_ARGS= --with-docdir=share/doc/${PORTNAME} \
+ --with-etcdir=${PREFIX}/etc/${PORTNAME} \
+ --with-helpdir=share/${PORTNAME}/help \
+ --with-simdir=libexec/${PORTNAME}/modules
+PLIST_SUB= INSTALL_DIR="${INSTALL_DIR}"
+
+INSTALL_DIR?= ${INSTALL} -d -o ${BINOWN} -g ${BINGRP} -m 755
+
+.ifdef(NOPORTDOCS)
+EXTRA_PATCHES+= ${FILESDIR}/extra-patch-Makefile.in-noportdocs
+.endif
+
+.ifdef(WITHOUT_OPTIMIZED_ASM)
+CONFIGURE_ARGS+= --disable-asm
+.endif
+
+.ifndef(WITH_PTHREADS)
+CONFIGURE_ARGS+= --disable-threads
+.else
+CONFIGURE_ENV+= CFLAGS="${CFLAGS} ${PTHREAD_CFLAGS} ${PTHREAD_LIBS}"
+.endif
+
+pre-everything::
+.ifndef(WITHOUT_OPTIMIZED_ASM)
+ @${ECHO_MSG} '===> Define WITHOUT_OPTIMIZED_ASM to disable assembler optimizations'
+.endif
+.ifndef(WITH_PTHREADS)
+ @${ECHO_MSG} '===> Define WITH_PTHREADS to enable pthreads support'
+.endif
+ @${ECHO_MSG}
+.ifndef(WITH_OPTIMIZED_CFLAGS)
+ @${ECHO_MSG} '===> Define WITH_OPTIMIZED_CFLAGS to enable compilation optimizations'
+ @${ECHO_MSG} '===> which is known to break some platforms (e.g., alpha)'
+.endif
+
+post-patch:
+.ifndef(WITH_OPTIMIZED_CFLAGS)
+ @${PERL} -pi -e 's/-O2//' ${WRKSRC}/${CONFIGURE_SCRIPT}
+.endif
+
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} != "i386"
+WITHOUT_OPTIMIZED_ASM= yes
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/net/silc-client/distinfo b/net/silc-client/distinfo
new file mode 100644
index 000000000000..6c15d58be630
--- /dev/null
+++ b/net/silc-client/distinfo
@@ -0,0 +1 @@
+MD5 (silc-client-0.6.4.tar.bz2) = ff876b47b4a83e31775a8e9e25cd300f
diff --git a/net/silc-client/files/extra-patch-Makefile.in-noportdocs b/net/silc-client/files/extra-patch-Makefile.in-noportdocs
new file mode 100644
index 000000000000..56f87c3d8be7
--- /dev/null
+++ b/net/silc-client/files/extra-patch-Makefile.in-noportdocs
@@ -0,0 +1,34 @@
+--- Makefile.in.orig Fri Nov 9 02:21:14 2001
++++ Makefile.in Fri Nov 9 02:22:13 2001
+@@ -145,9 +145,9 @@
+
+ AUTOMAKE_OPTIONS = 1.0 no-dependencies foreign
+
+-COMMONDIRS = lib irssi silc silcd doc includes
+-SUBDIRS = lib irssi doc includes
+-DIST_SUBDIRS = lib irssi doc includes
++COMMONDIRS = lib irssi silc silcd includes
++SUBDIRS = lib irssi includes
++DIST_SUBDIRS = lib irssi includes
+
+ #
+ # INCLUDE defines
+@@ -514,7 +514,6 @@
+ -mkdir -p $(etcdir)
+ -mkdir -p $(modulesdir)
+ -mkdir -p $(helpdir)
+- -mkdir -p $(docdir)
+ -mkdir -p $(logsdir)
+
+ generate-server-key:
+@@ -543,8 +542,8 @@
+ $(etcdir)/silc.conf; \
+ fi
+
+-@SILC_DIST_CLIENT_TRUE@install-data-hook: install-dirs sim-install doc-install etc-install
+-@SILC_DIST_CLIENT_FALSE@install-data-hook: install-dirs generate-server-key sim-install doc-install etc-install
++@SILC_DIST_CLIENT_TRUE@install-data-hook: install-dirs sim-install etc-install
++@SILC_DIST_CLIENT_FALSE@install-data-hook: install-dirs generate-server-key sim-install etc-install
+ # Tell versions [3.59,3.63) of GNU make to not export all variables.
+ # Otherwise a system limit (for SysV at least) may be exceeded.
+ .NOEXPORT:
diff --git a/net/silc-client/files/patch-Makefile.in b/net/silc-client/files/patch-Makefile.in
new file mode 100644
index 000000000000..54d1c3e2e4b0
--- /dev/null
+++ b/net/silc-client/files/patch-Makefile.in
@@ -0,0 +1,14 @@
+--- Makefile.in.orig Fri Nov 9 00:27:10 2001
++++ Makefile.in Fri Nov 9 00:27:16 2001
+@@ -538,11 +538,6 @@
+ $(INSTALL_DATA) $(srcdir)/TODO $(docdir)/
+
+ etc-install:
+- -@if test '!' -f $(etcdir)/silcd.conf ; then \
+- $(INSTALL_DATA) $(srcdir)/doc/example_silcd.conf \
+- $(etcdir)/silcd.conf; \
+- chmod go= $(etcdir)/silcd.conf; \
+- fi
+ -@if test '!' -f $(etcdir)/silc.conf ; then \
+ $(INSTALL_DATA) $(srcdir)/doc/example_silc.conf \
+ $(etcdir)/silc.conf; \
diff --git a/net/silc-client/files/patch-configure b/net/silc-client/files/patch-configure
new file mode 100644
index 000000000000..fe7627008c78
--- /dev/null
+++ b/net/silc-client/files/patch-configure
@@ -0,0 +1,11 @@
+--- configure.orig Thu Nov 8 22:59:50 2001
++++ configure Thu Nov 8 23:01:39 2001
+@@ -8472,7 +8472,7 @@
+ fi
+ ;;
+ *-freebsd2.2*)
+- CFLAGS="$CFLAGS -D_THREAD_SAFE"
++ CFLAGS="$CFLAGS"
+ ;;
+ *-sysv5uw7*) # UnixWare 7
+ if test "$GCC" != "yes"; then
diff --git a/net/silc-client/files/patch-doc:Makefile.in b/net/silc-client/files/patch-doc:Makefile.in
new file mode 100644
index 000000000000..29538ba8a2b5
--- /dev/null
+++ b/net/silc-client/files/patch-doc:Makefile.in
@@ -0,0 +1,10 @@
+--- doc/Makefile.in.orig Fri Nov 9 02:17:35 2001
++++ doc/Makefile.in Fri Nov 9 02:17:43 2001
+@@ -118,7 +118,6 @@
+ EXTRA_DIST = \
+ CodingStyle \
+ FAQ \
+- example_silcd.conf \
+ example_silc.conf \
+ draft-riikonen*.txt $(SILC_EXTRA_DIST)
+
diff --git a/net/silc-client/pkg-comment b/net/silc-client/pkg-comment
new file mode 100644
index 000000000000..98317511b77d
--- /dev/null
+++ b/net/silc-client/pkg-comment
@@ -0,0 +1 @@
+Secure Internet Live Conferencing (SILC) network client
diff --git a/net/silc-client/pkg-descr b/net/silc-client/pkg-descr
new file mode 100644
index 000000000000..eead8f7efb1d
--- /dev/null
+++ b/net/silc-client/pkg-descr
@@ -0,0 +1,17 @@
+[ from developer's site FAQ ]
+
+This is a SILC network client
+
+Q: What is SILC?
+
+A: SILC (Secure Internet Live Conferencing) is a protocol which
+provides secure conferencing services in the Internet over insecure
+channel. SILC is IRC like although internally they are very different.
+Biggest similarity between SILC and IRC is that they both provide
+conferencing services and that SILC has almost same commands as
+IRC. Other than that they are nothing alike.
+
+Biggest differences are that SILC is secure what IRC is not in any
+way. The network model is also entirely different compared to IRC.
+
+WWW: http://www.silcnet.org/
diff --git a/net/silc-client/pkg-plist b/net/silc-client/pkg-plist
new file mode 100644
index 000000000000..448155f606b5
--- /dev/null
+++ b/net/silc-client/pkg-plist
@@ -0,0 +1,104 @@
+bin/silc
+etc/silc/config
+etc/silc/default.theme
+etc/silc/silc.conf
+%%PORTDOCS%%share/doc/silc/CHANGES
+%%PORTDOCS%%share/doc/silc/COPYING
+%%PORTDOCS%%share/doc/silc/CREDITS
+%%PORTDOCS%%share/doc/silc/CodingStyle
+%%PORTDOCS%%share/doc/silc/FAQ
+%%PORTDOCS%%share/doc/silc/INSTALL
+%%PORTDOCS%%share/doc/silc/README
+%%PORTDOCS%%share/doc/silc/TODO
+%%PORTDOCS%%share/doc/silc/draft-riikonen-silc-commands-02.txt
+%%PORTDOCS%%share/doc/silc/draft-riikonen-silc-ke-auth-04.txt
+%%PORTDOCS%%share/doc/silc/draft-riikonen-silc-pp-04.txt
+%%PORTDOCS%%share/doc/silc/draft-riikonen-silc-spec-04.txt
+%%PORTDOCS%%share/doc/silc/example_silc.conf
+%%PORTDOCS%%share/doc/silc/example_silcd.conf
+share/silc/help/action
+share/silc/help/admin
+share/silc/help/alias
+share/silc/help/away
+share/silc/help/ban
+share/silc/help/beep
+share/silc/help/bind
+share/silc/help/cat
+share/silc/help/cd
+share/silc/help/channel
+share/silc/help/clear
+share/silc/help/close
+share/silc/help/cmode
+share/silc/help/connect
+share/silc/help/cumode
+share/silc/help/cycle
+share/silc/help/date
+share/silc/help/dehilight
+share/silc/help/disconnect
+share/silc/help/echo
+share/silc/help/eval
+share/silc/help/exec
+share/silc/help/file
+share/silc/help/format
+share/silc/help/getkey
+share/silc/help/help
+share/silc/help/hilight
+share/silc/help/ignore
+share/silc/help/info
+share/silc/help/invite
+share/silc/help/join
+share/silc/help/key
+share/silc/help/kick
+share/silc/help/kickban
+share/silc/help/kill
+share/silc/help/knockout
+share/silc/help/lastlog
+share/silc/help/layout
+share/silc/help/levels
+share/silc/help/list
+share/silc/help/load
+share/silc/help/log
+share/silc/help/me
+share/silc/help/motd
+share/silc/help/msg
+share/silc/help/names
+share/silc/help/nick
+share/silc/help/notice
+share/silc/help/oper
+share/silc/help/part
+share/silc/help/ping
+share/silc/help/query
+share/silc/help/quit
+share/silc/help/reconnect
+share/silc/help/reload
+share/silc/help/rmreconns
+share/silc/help/rmrejoins
+share/silc/help/save
+share/silc/help/sconnect
+share/silc/help/scrollback
+share/silc/help/server
+share/silc/help/set
+share/silc/help/shutdown
+share/silc/help/silcoper
+share/silc/help/toggle
+share/silc/help/topic
+share/silc/help/umode
+share/silc/help/unalias
+share/silc/help/unignore
+share/silc/help/unload
+share/silc/help/unquery
+share/silc/help/users
+share/silc/help/version
+share/silc/help/whois
+share/silc/help/whowas
+share/silc/help/window
+@dirrm silc/logs
+@dirrm silc
+@dirrm share/silc/help
+@dirrm share/silc
+%%PORTDOCS%%@dirrm share/doc/silc
+@dirrm libexec/silc/modules
+@dirrm libexec/silc
+@dirrm etc/silc
+@exec %%INSTALL_DIR%% %D/libexec/silc/modules
+@exec %%INSTALL_DIR%% %D/silc/logs