aboutsummaryrefslogtreecommitdiff
path: root/net/silc-server
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2007-10-03 23:53:46 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2007-10-03 23:53:46 +0000
commit260b2edafd358f77c49249acb5545764315d5ce9 (patch)
tree660f33f450bbab88db3f425d963bac094e937569 /net/silc-server
parentd2d7ba91aa03c042adab70b43cf10d6692977b07 (diff)
downloadports-260b2edafd358f77c49249acb5545764315d5ce9.tar.gz
ports-260b2edafd358f77c49249acb5545764315d5ce9.zip
Notes
Diffstat (limited to 'net/silc-server')
-rw-r--r--net/silc-server/Makefile27
1 files changed, 12 insertions, 15 deletions
diff --git a/net/silc-server/Makefile b/net/silc-server/Makefile
index dd8047e7d2cf..bef547ca03e5 100644
--- a/net/silc-server/Makefile
+++ b/net/silc-server/Makefile
@@ -34,7 +34,8 @@ CONFIGURE_ARGS= --with-silcd-config-file=${PREFIX}/etc/${PORTNAME}/silcd.conf \
--with-etcdir=${PREFIX}/etc/${PORTNAME} \
--with-helpdir=share/${PORTNAME}/help \
--with-logsdir=/var/log/${PORTNAME} \
- --with-silcd-pid-file=/var/run/silcd.pid
+ --with-silcd-pid-file=/var/run/silcd.pid \
+ --enable-ipv6
PLIST_SUB= INSTALL_DIR="${INSTALL_DIR}"
PKGDEINSTALL= ${PKGINSTALL}
@@ -44,6 +45,16 @@ INSTALL_DIR?= ${INSTALL} -d -o ${BINOWN} -g ${BINGRP} -m 755
MAN5= silcd.conf.5
MAN8= silcd.8
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} != "i386"
+WITHOUT_OPTIMIZED_ASM= yes
+.endif
+
+.ifdef(WITHOUT_OPTIMIZED_ASM)
+CONFIGURE_ARGS+= --disable-asm
+.endif
+
.ifndef(WITH_PTHREADS)
CONFIGURE_ARGS+= --without-pthreads
.else
@@ -81,18 +92,4 @@ post-install:
${INSTALL_SCRIPT} ${WRKSRC}/silcd.sh ${PREFIX}/etc/rc.d/silcd.sh; \
fi
-.include <bsd.port.pre.mk>
-
-.if ${ARCH} != "i386"
-WITHOUT_OPTIMIZED_ASM= yes
-.endif
-
-.if ${OSVERSION} >= 400014
-CONFIGURE_ARGS+= --enable-ipv6
-.endif
-
-.ifdef(WITHOUT_OPTIMIZED_ASM)
-CONFIGURE_ARGS+= --disable-asm
-.endif
-
.include <bsd.port.post.mk>