aboutsummaryrefslogtreecommitdiff
path: root/net/silky
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-03-01 08:37:24 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-03-01 08:37:24 +0000
commit67750966d60f0885ab913ee399363446dd1146a3 (patch)
treec53000082e4a2fdd18f24ae17b95be20b4836ad0 /net/silky
parent515c350caefc5a2437a18701ac78625f34273b6b (diff)
downloadports-67750966d60f0885ab913ee399363446dd1146a3.tar.gz
ports-67750966d60f0885ab913ee399363446dd1146a3.zip
Notes
Diffstat (limited to 'net/silky')
-rw-r--r--net/silky/Makefile4
-rw-r--r--net/silky/files/patch-silccallbacks22
2 files changed, 24 insertions, 2 deletions
diff --git a/net/silky/Makefile b/net/silky/Makefile
index 439d77d60678..830036d8724e 100644
--- a/net/silky/Makefile
+++ b/net/silky/Makefile
@@ -7,7 +7,7 @@
PORTNAME= silky
PORTVERSION= 0.4.3
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net security
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
ftp://rusunix.org/pub/FreeBSD/distfiles/
@@ -16,7 +16,7 @@ MASTER_SITE_SUBDIR= silky
MAINTAINER= aquatique@rusunix.org
COMMENT= A simple and easy to use graphical, os-independent SILC client
-LIB_DEPENDS= silcclient-1.0.2:${PORTSDIR}/devel/silc-toolkit
+LIB_DEPENDS= silcclient-1.0.3:${PORTSDIR}/devel/silc-toolkit
GNU_CONFIGURE= yes
CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
diff --git a/net/silky/files/patch-silccallbacks b/net/silky/files/patch-silccallbacks
new file mode 100644
index 000000000000..2e672fdc38ea
--- /dev/null
+++ b/net/silky/files/patch-silccallbacks
@@ -0,0 +1,22 @@
+--- src/silccallbacks.c.orig Mon Mar 1 13:41:32 2004
++++ src/silccallbacks.c Mon Mar 1 13:41:44 2004
+@@ -569,7 +569,7 @@
+ static void
+ silc_channel_message(SilcClient client, SilcClientConnection conn,
+ SilcClientEntry sender, SilcChannelEntry channel,
+- SilcMessagePayload payload,
++ SilcMessagePayload payload, SilcChannelPrivateKey key,
+ SilcMessageFlags flags, const unsigned char *message,
+ SilcUInt32 message_len)
+ {
+--- src/silccallbacks.h.orig Mon Mar 1 13:41:15 2004
++++ src/silccallbacks.h Mon Mar 1 13:41:23 2004
+@@ -8,7 +8,7 @@
+ void
+ silc_channel_message(SilcClient client, SilcClientConnection conn,
+ SilcClientEntry sender, SilcChannelEntry channel,
+- SilcMessagePayload payload,
++ SilcMessagePayload payload, SilcChannelPrivateKey key,
+ SilcMessageFlags flags, const unsigned char *message,
+ SilcUInt32 message_len);
+