aboutsummaryrefslogtreecommitdiff
path: root/net/siproxd/Makefile
diff options
context:
space:
mode:
authorYen-Ming Lee <leeym@FreeBSD.org>2004-11-12 00:36:15 +0000
committerYen-Ming Lee <leeym@FreeBSD.org>2004-11-12 00:36:15 +0000
commit00e6b3ace352f9159856aa67235e47fa911d9b6c (patch)
treed7ff16682622135b2bb2d75c7c09ff53ca197962 /net/siproxd/Makefile
parent6ac9a59d8572c80ff38a618c816fa9329524d4c3 (diff)
downloadports-00e6b3ace352f9159856aa67235e47fa911d9b6c.tar.gz
ports-00e6b3ace352f9159856aa67235e47fa911d9b6c.zip
Notes
Diffstat (limited to 'net/siproxd/Makefile')
-rw-r--r--net/siproxd/Makefile23
1 files changed, 16 insertions, 7 deletions
diff --git a/net/siproxd/Makefile b/net/siproxd/Makefile
index 2008812257aa..b58a59d38c1c 100644
--- a/net/siproxd/Makefile
+++ b/net/siproxd/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= siproxd
-PORTVERSION= 0.5.8
+PORTVERSION= 0.5.9
CATEGORIES= net
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= siproxd
@@ -16,26 +16,35 @@ COMMENT= A proxy/masquerading daemon for the SIP protocol
LIB_DEPENDS= osip2.2:${PORTSDIR}/net/libosip2
+USE_REINPLACE= yes
USE_GETOPT_LONG=yes
USE_RC_SUBR= yes
-HAS_CONFIGURE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_TARGET= # empty
-PORTDOCS= AUTHORS ChangeLog README RELNOTES \
- doc/FAQ doc/KNOWN_BUGS doc/RFC3261_compliance.txt \
- doc/sample_cfg_budgetone.txt doc/sample_cfg_x-lite.txt
+PORTDOCS1= AUTHORS ChangeLog README RELNOTES
+PORTDOCS2= FAQ KNOWN_BUGS RFC3261_compliance.txt \
+ sample_cfg_budgetone.txt sample_cfg_x-lite.txt
+PORTDOCS= ${PORTDOCS1} ${PORTDOCS2}
+PLIST_FILES= etc/rc.d/siproxd.sh etc/siproxd.conf.example \
+ etc/siproxd_passwd.cfg sbin/siproxd
.include <bsd.port.pre.mk>
+post-patch:
.if ${OSVERSION} >= 500041
-LIB_DEPENDS+= gnugetopt.1:${PORTSDIR}/devel/libgnugetopt
+ @${REINPLACE_CMD} -e 's,-lgnugetopt,,g' ${WRKSRC}/${CONFIGURE_SCRIPT}
.endif
post-install:
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
-.for i in ${PORTDOCS}
+.for i in ${PORTDOCS1}
${INSTALL_MAN} ${WRKSRC}/${i} ${DOCSDIR}
.endfor
+.for i in ${PORTDOCS2}
+ ${INSTALL_MAN} ${WRKSRC}/doc/${i} ${DOCSDIR}
+.endfor
.endif
PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
@${SED} -e 's|%%PREFIX%%|${PREFIX}|g' \