aboutsummaryrefslogtreecommitdiff
path: root/net/siproxd/Makefile
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2014-03-27 14:37:43 +0000
committerRenato Botelho <garga@FreeBSD.org>2014-03-27 14:37:43 +0000
commit08f0ef487430d8f8eaa2b86b4020ddd28e7f1916 (patch)
treef2bbc811a3bf5162f3840967457f80b31f1cde33 /net/siproxd/Makefile
parent9e8604452543fb30359db3173e67c6076b7fefbb (diff)
downloadports-08f0ef487430d8f8eaa2b86b4020ddd28e7f1916.tar.gz
ports-08f0ef487430d8f8eaa2b86b4020ddd28e7f1916.zip
Notes
Diffstat (limited to 'net/siproxd/Makefile')
-rw-r--r--net/siproxd/Makefile21
1 files changed, 12 insertions, 9 deletions
diff --git a/net/siproxd/Makefile b/net/siproxd/Makefile
index bfece64c3cbb..39e527fb8754 100644
--- a/net/siproxd/Makefile
+++ b/net/siproxd/Makefile
@@ -10,7 +10,9 @@ MASTER_SITES= SF
MAINTAINER= frank@dynamical-systems.org
COMMENT= A proxy/masquerading daemon for the SIP protocol
-LIB_DEPENDS= osip2.9:${PORTSDIR}/net/libosip
+LICENSE= GPLv2
+
+LIB_DEPENDS= libosip2.so:${PORTSDIR}/net/libosip
USE_RC_SUBR= siproxd
GNU_CONFIGURE= yes
@@ -21,7 +23,6 @@ PORTDOCS2= FAQ KNOWN_BUGS RFC3261_compliance.txt \
sample_cfg_budgetone.txt sample_cfg_x-lite.txt
PORTDOCS= ${PORTDOCS1} ${PORTDOCS2}
-NO_STAGE= yes
.include <bsd.port.pre.mk>
post-patch:
@@ -37,14 +38,16 @@ post-extract:
.endfor
post-install:
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
.for docs in ${PORTDOCS}
- ${INSTALL_DATA} ${WRKSRC}/${docs} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${docs} ${STAGEDIR}${DOCSDIR}
.endfor
-.endif
- ${CP} ${WRKSRC}/doc/siproxd.conf.example ${PREFIX}/etc
- ${CP} ${WRKSRC}/doc/siproxd_passwd.cfg ${PREFIX}/etc
- PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
+ ${CP} ${WRKSRC}/doc/siproxd.conf.example ${STAGEDIR}${PREFIX}/etc
+ ${CP} ${WRKSRC}/doc/siproxd_passwd.cfg ${STAGEDIR}${PREFIX}/etc
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/siproxd/plugin_defaulttarget.so
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/siproxd/plugin_demo.so
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/siproxd/plugin_fix_bogus_via.so
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/siproxd/plugin_logcall.so
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/siproxd/plugin_shortdial.so
.include <bsd.port.post.mk>