aboutsummaryrefslogtreecommitdiff
path: root/net/siproxd
diff options
context:
space:
mode:
authorSylvio Cesar Teixeira <sylvio@FreeBSD.org>2010-02-21 01:14:35 +0000
committerSylvio Cesar Teixeira <sylvio@FreeBSD.org>2010-02-21 01:14:35 +0000
commit7c0f63b007fc41fde216db7ac69b91373f69af1d (patch)
treef94c3adfa9d537a11f240d8c5089593afcc81199 /net/siproxd
parent10349dfb5f3943408563474a18ad13d33b909988 (diff)
downloadports-7c0f63b007fc41fde216db7ac69b91373f69af1d.tar.gz
ports-7c0f63b007fc41fde216db7ac69b91373f69af1d.zip
Notes
Diffstat (limited to 'net/siproxd')
-rw-r--r--net/siproxd/Makefile25
-rw-r--r--net/siproxd/distinfo6
-rw-r--r--net/siproxd/files/patch-doc_siproxd.conf.example12
-rw-r--r--net/siproxd/pkg-plist5
4 files changed, 23 insertions, 25 deletions
diff --git a/net/siproxd/Makefile b/net/siproxd/Makefile
index d49f790d83ee..b9f852317c01 100644
--- a/net/siproxd/Makefile
+++ b/net/siproxd/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= siproxd
-PORTVERSION= 0.7.1
-PORTREVISION= 1
+PORTVERSION= 0.7.2
CATEGORIES= net
MASTER_SITES= SF
@@ -18,7 +17,7 @@ LIB_DEPENDS= osip2.6:${PORTSDIR}/net/libosip
USE_RC_SUBR= siproxd.sh
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-libosip-prefix=${PREFIX}
+CONFIGURE_ARGS= --disable-doc --with-libosip-prefix=${PREFIX}
PORTDOCS1= AUTHORS ChangeLog README RELNOTES
PORTDOCS2= FAQ KNOWN_BUGS RFC3261_compliance.txt \
@@ -28,22 +27,26 @@ PORTDOCS= ${PORTDOCS1} ${PORTDOCS2}
.include <bsd.port.pre.mk>
post-patch:
- @${REINPLACE_CMD} -e 's,-lgnugetopt,,g' ${WRKSRC}/${CONFIGURE_SCRIPT}
-.if !defined(NOPORTDOCS)
+ @${REINPLACE_CMD} -e 's,-lgnugetopt,,g ; 24600d ; 23998s,doc/Makefile ,,g' ${WRKSRC}/${CONFIGURE_SCRIPT}
@${REINPLACE_CMD} -e 's,%%PREFIX%%,${PREFIX},g' \
${WRKSRC}/doc/siproxd.conf.example
-.endif
+ ${REINPLACE_CMD} -e '22s,doc ,,' ${WRKSRC}/Makefile.am
+ ${REINPLACE_CMD} -e '212s,doc ,,' ${WRKSRC}/Makefile.in
+
+post-extract:
+.for docs in ${PORTDOCS2}
+ ${CP} ${WRKSRC}/doc/${docs} ${WRKSRC}
+.endfor
post-install:
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
-.for i in ${PORTDOCS1}
- ${INSTALL_MAN} ${WRKSRC}/${i} ${DOCSDIR}
-.endfor
-.for i in ${PORTDOCS2}
- ${INSTALL_MAN} ${WRKSRC}/doc/${i} ${DOCSDIR}
+.for docs in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${docs} ${DOCSDIR}
.endfor
.endif
+ ${CP} ${WRKSRC}/doc/siproxd.conf.example ${PREFIX}/etc
+ ${CP} ${WRKSRC}/doc/siproxd_passwd.cfg ${PREFIX}/etc
PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
.include <bsd.port.post.mk>
diff --git a/net/siproxd/distinfo b/net/siproxd/distinfo
index 191fb4736021..91de666d3010 100644
--- a/net/siproxd/distinfo
+++ b/net/siproxd/distinfo
@@ -1,3 +1,3 @@
-MD5 (siproxd-0.7.1.tar.gz) = 45e5a44803181e2bf3361d562060c904
-SHA256 (siproxd-0.7.1.tar.gz) = 5eef70f4e0a8f0f4628550807da3036f8b3086864bf4bcf5ab6d22ac3a6efd81
-SIZE (siproxd-0.7.1.tar.gz) = 816613
+MD5 (siproxd-0.7.2.tar.gz) = ad2e0ba599adf3b5267a39dad28af973
+SHA256 (siproxd-0.7.2.tar.gz) = c586d0f8e66841189e1e236eb18a1b0c8126d6e28aa6d0a28b591b016ccebbcb
+SIZE (siproxd-0.7.2.tar.gz) = 821009
diff --git a/net/siproxd/files/patch-doc_siproxd.conf.example b/net/siproxd/files/patch-doc_siproxd.conf.example
index 11df80171f7b..484c8240cb21 100644
--- a/net/siproxd/files/patch-doc_siproxd.conf.example
+++ b/net/siproxd/files/patch-doc_siproxd.conf.example
@@ -1,5 +1,5 @@
---- doc/siproxd.conf.example.orig 2008-05-17 17:56:11.000000000 +0200
-+++ doc/siproxd.conf.example 2008-09-23 12:03:33.000000000 +0200
+--- doc/siproxd.conf.example.orig 2010-01-24 17:18:04.000000000 +0100
++++ doc/siproxd.conf.example 2010-01-24 17:21:34.000000000 +0100
@@ -17,8 +17,8 @@
# or a hostname that resolves to that address (use a dyndns address for
# example).
@@ -38,12 +38,12 @@
######################################################################
# global switch to control the RTP proxy behaviour
-@@ -286,7 +286,7 @@
+@@ -292,7 +292,7 @@
# the processing order is given by the load order.
#
# plugin_dir: MUST be terminated with '/'
--plugindir=/home/hb9xar/src/siproxd/src/.libs/
+-plugindir=/usr/lib/siproxd/
+plugindir=%%PREFIX%%/lib/siproxd/
#
- # List of plugins to load:
- #load_plugin=plugin_demo.so
+ # List of plugins to load. MUST use the .la file extension!
+ #load_plugin=plugin_demo.la
diff --git a/net/siproxd/pkg-plist b/net/siproxd/pkg-plist
index a538c63fc75b..009185de2695 100644
--- a/net/siproxd/pkg-plist
+++ b/net/siproxd/pkg-plist
@@ -3,22 +3,17 @@ etc/siproxd_passwd.cfg
lib/siproxd/plugin_defaulttarget.a
lib/siproxd/plugin_defaulttarget.la
lib/siproxd/plugin_defaulttarget.so
-lib/siproxd/plugin_defaulttarget.so.0
lib/siproxd/plugin_demo.a
lib/siproxd/plugin_demo.la
lib/siproxd/plugin_demo.so
-lib/siproxd/plugin_demo.so.0
lib/siproxd/plugin_fix_bogus_via.a
lib/siproxd/plugin_fix_bogus_via.la
lib/siproxd/plugin_fix_bogus_via.so
-lib/siproxd/plugin_fix_bogus_via.so.0
lib/siproxd/plugin_logcall.a
lib/siproxd/plugin_logcall.la
lib/siproxd/plugin_logcall.so
-lib/siproxd/plugin_logcall.so.0
lib/siproxd/plugin_shortdial.a
lib/siproxd/plugin_shortdial.la
lib/siproxd/plugin_shortdial.so
-lib/siproxd/plugin_shortdial.so.0
sbin/siproxd
@dirrm lib/siproxd