aboutsummaryrefslogtreecommitdiff
path: root/net/siproxd
diff options
context:
space:
mode:
authorIon-Mihai Tetcu <itetcu@FreeBSD.org>2006-05-18 06:15:39 +0000
committerIon-Mihai Tetcu <itetcu@FreeBSD.org>2006-05-18 06:15:39 +0000
commit4171b2a4482bf178a2eb4d5e3d78327f30f0ee1c (patch)
treee59364a4ef12c591b69fcc34debb4079b1748ac1 /net/siproxd
parent4d013727b745846b856c01fea186d8791c40a3a7 (diff)
downloadports-4171b2a4482bf178a2eb4d5e3d78327f30f0ee1c.tar.gz
ports-4171b2a4482bf178a2eb4d5e3d78327f30f0ee1c.zip
Notes
Diffstat (limited to 'net/siproxd')
-rw-r--r--net/siproxd/Makefile12
-rw-r--r--net/siproxd/distinfo6
-rw-r--r--net/siproxd/files/patch-doc_siproxd.conf.example4
-rw-r--r--net/siproxd/files/patch-src__plugin_shortdial.c11
-rw-r--r--net/siproxd/files/patch-src__siproxd.c29
-rw-r--r--net/siproxd/files/siproxd.sh.in (renamed from net/siproxd/files/siproxd.sh)17
6 files changed, 52 insertions, 27 deletions
diff --git a/net/siproxd/Makefile b/net/siproxd/Makefile
index 760ea7928453..0222d493bfba 100644
--- a/net/siproxd/Makefile
+++ b/net/siproxd/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= siproxd
-PORTVERSION= 0.5.11
-PORTREVISION= 1
+PORTVERSION= 0.5.12
CATEGORIES= net
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= siproxd
@@ -18,7 +17,7 @@ COMMENT= A proxy/masquerading daemon for the SIP protocol
LIB_DEPENDS= osip2.3:${PORTSDIR}/net/libosip2
USE_GETOPT_LONG=yes
-USE_RC_SUBR= yes
+USE_RC_SUBR= siproxd.sh
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --with-libosip-prefix=${PREFIX}
@@ -26,8 +25,7 @@ PORTDOCS1= AUTHORS ChangeLog README RELNOTES
PORTDOCS2= FAQ KNOWN_BUGS RFC3261_compliance.txt \
sample_cfg_budgetone.txt sample_cfg_x-lite.txt
PORTDOCS= ${PORTDOCS1} ${PORTDOCS2}
-PLIST_FILES= etc/rc.d/siproxd.sh etc/siproxd.conf.example \
- etc/siproxd_passwd.cfg sbin/siproxd
+PLIST_FILES= etc/siproxd.conf.example etc/siproxd_passwd.cfg sbin/siproxd
.include <bsd.port.pre.mk>
@@ -47,9 +45,5 @@ post-install:
.endfor
.endif
PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
- @${SED} -e 's|%%PREFIX%%|${PREFIX}|g' \
- -e 's|%%RC_SUBR%%|${RC_SUBR}|g' \
- ${FILESDIR}/siproxd.sh > ${PREFIX}/etc/rc.d/siproxd.sh
- @${CHMOD} 755 ${PREFIX}/etc/rc.d/siproxd.sh
.include <bsd.port.post.mk>
diff --git a/net/siproxd/distinfo b/net/siproxd/distinfo
index 8ca7fce5fb32..1613da06c806 100644
--- a/net/siproxd/distinfo
+++ b/net/siproxd/distinfo
@@ -1,3 +1,3 @@
-MD5 (siproxd-0.5.11.tar.gz) = a614f60683f9ea9423573bc5d646c525
-SHA256 (siproxd-0.5.11.tar.gz) = 0f08a8840bc1d7324898583ecd9b29d12d9ba29194804d3104bb0347b75c000b
-SIZE (siproxd-0.5.11.tar.gz) = 216684
+MD5 (siproxd-0.5.12.tar.gz) = 2fa02bd6f83070593bfc2d383ce614fa
+SHA256 (siproxd-0.5.12.tar.gz) = af49ee4b2956dbbc837087f8fd3355bae04e64afb40fb5d1e9a07d39deb7345e
+SIZE (siproxd-0.5.12.tar.gz) = 222772
diff --git a/net/siproxd/files/patch-doc_siproxd.conf.example b/net/siproxd/files/patch-doc_siproxd.conf.example
index 82c2094eb5fe..9cc4e025a437 100644
--- a/net/siproxd/files/patch-doc_siproxd.conf.example
+++ b/net/siproxd/files/patch-doc_siproxd.conf.example
@@ -1,5 +1,5 @@
---- doc/siproxd.conf.example.orig Tue Apr 19 21:00:20 2005
-+++ doc/siproxd.conf.example Thu May 5 17:35:35 2005
+--- doc/siproxd.conf.example.orig Sun Jan 1 21:09:42 2006
++++ doc/siproxd.conf.example Wed Apr 19 16:41:31 2006
@@ -17,8 +17,8 @@
# or a hostname that resolves to that address (use a dyndns address for
# example).
diff --git a/net/siproxd/files/patch-src__plugin_shortdial.c b/net/siproxd/files/patch-src__plugin_shortdial.c
new file mode 100644
index 000000000000..b9b8c4ad1128
--- /dev/null
+++ b/net/siproxd/files/patch-src__plugin_shortdial.c
@@ -0,0 +1,11 @@
+--- src/plugin_shortdial.c.orig Sun Jan 1 21:31:31 2006
++++ src/plugin_shortdial.c Mon May 15 11:50:12 2006
+@@ -24,7 +24,7 @@
+ //#include <errno.h>
+ #include <string.h>
+ //#include <stdlib.h>
+-//#include <unistd.h>
++#include <unistd.h>
+ //#include <signal.h>
+ #include <netinet/in.h>
+ //#include <arpa/inet.h>
diff --git a/net/siproxd/files/patch-src__siproxd.c b/net/siproxd/files/patch-src__siproxd.c
new file mode 100644
index 000000000000..541b68be06a2
--- /dev/null
+++ b/net/siproxd/files/patch-src__siproxd.c
@@ -0,0 +1,29 @@
+--- src/siproxd.c.orig Sun Jan 1 21:31:32 2006
++++ src/siproxd.c Tue May 16 11:39:17 2006
+@@ -177,11 +177,16 @@
+ /*
+ * Init stuff
+ */
+- INFO(PACKAGE"-"VERSION"-"BUILDSTR" "UNAME" starting up");
+-
+ /* read the config file */
+ if (read_config(configfile, config_search) == STS_FAILURE) exit(1);
+
++ /* Don't log to stderr if daemonizing is intended. */
++ if (configuration.daemonize) {
++ log_set_stderr(0);
++ }
++
++ INFO(PACKAGE"-"VERSION"-"BUILDSTR" "UNAME" starting up");
++
+ /* if a debug level > 0 has been given on the commandline use its
+ value and not what is in the config file */
+ if (cmdline_debuglevel != 0) {
+@@ -212,7 +217,6 @@
+ setsid();
+ if (fork()!=0) exit(0);
+
+- log_set_stderr(0);
+ INFO("daemonized, pid=%i", getpid());
+ }
+
diff --git a/net/siproxd/files/siproxd.sh b/net/siproxd/files/siproxd.sh.in
index f14d7616dd48..6c31e25d6bea 100644
--- a/net/siproxd/files/siproxd.sh
+++ b/net/siproxd/files/siproxd.sh.in
@@ -9,9 +9,6 @@
# NOTE for FreeBSD 5.0+:
# If you want this script to start with the base rc scripts
# move siproxd.sh to /etc/rc.d/siproxd
-
-prefix=%%PREFIX%%
-
# Define these siproxd_* variables in one of these files:
# /etc/rc.conf
# /etc/rc.conf.local
@@ -19,23 +16,17 @@ prefix=%%PREFIX%%
#
# DO NOT CHANGE THESE DEFAULT VALUES HERE
#
+
siproxd_enable=${siproxd_enable:-"NO"} # Enable siproxd
siproxd_flags=${siproxd_flags:-""} # Flags to siproxd program
-#siproxd_program="${prefix}/sbin/siproxd" # Location of siproxd
+#siproxd_program="%%PREFIX%%/sbin/siproxd" # Location of siproxd
. %%RC_SUBR%%
name="siproxd"
rcvar=`set_rcvar`
-command="${prefix}/sbin/${name}"
+command="%%PREFIX%%/sbin/${name}"
load_rc_config $name
-case $1 in
- start)
- run_rc_command "$1" 2> /dev/null
- ;;
- *)
- run_rc_command "$1"
- ;;
-esac
+run_rc_command "$1"