aboutsummaryrefslogtreecommitdiff
path: root/net/sipxconfig
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-03-27 08:29:44 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-03-27 08:29:44 +0000
commit4ebaaa831de174bbdf65fb1289a46c2905392d26 (patch)
tree3f95b0385dcf47d038166794cf871587168a851f /net/sipxconfig
parent9398f47fcc359862b553e9cea2f0f097e4ee4ac6 (diff)
downloadports-4ebaaa831de174bbdf65fb1289a46c2905392d26.tar.gz
ports-4ebaaa831de174bbdf65fb1289a46c2905392d26.zip
Notes
Diffstat (limited to 'net/sipxconfig')
-rw-r--r--net/sipxconfig/Makefile14
-rw-r--r--net/sipxconfig/files/pkg-install.in36
2 files changed, 48 insertions, 2 deletions
diff --git a/net/sipxconfig/Makefile b/net/sipxconfig/Makefile
index 43f1264bf10f..f8af21ddf8c9 100644
--- a/net/sipxconfig/Makefile
+++ b/net/sipxconfig/Makefile
@@ -7,6 +7,7 @@
PORTNAME= sipxconfig
PORTVERSION= 3.6.0
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= http://www.sipfoundry.org/pub/sipX/3.6/SRC/
@@ -41,11 +42,20 @@ CONFIGURE_ARGS+= --enable-sip-tls \
--prefix=${PREFIX} \
--localstatedir=${LOCALSTATEDIR} \
--enable-ruby-bindings
-SUB_LIST= LOCALSTATEDIR=${LOCALSTATEDIR}
-SUB_FILES= pkg-deinstall
+SUB_LIST= LOCALSTATEDIR=${LOCALSTATEDIR} \
+ PREFIX=${PREFIX}
+SUB_FILES= pkg-install pkg-deinstall
+
+PKGINSTALL= ${WRKDIR}/pkg-install
post-patch:
@${REINPLACE_CMD} -e "s,/bin/bash,${PREFIX}/bin/bash," ${WRKSRC}/web/bin/sipxconfig.sh.in
@${REINPLACE_CMD} -e "s,@PREFIX@,${PREFIX}," ${WRKSRC}/web/bin/sipxconfig.sh.in
+pre-install:
+ @${SH} ${PKGINSTALL} ${PORTNAME} PRE-INSTALL
+
+post-install:
+ @${SH} ${PKGINSTALL} ${PORTNAME} POST-INSTALL
+
.include <bsd.port.mk>
diff --git a/net/sipxconfig/files/pkg-install.in b/net/sipxconfig/files/pkg-install.in
new file mode 100644
index 000000000000..8ac6d67cf34b
--- /dev/null
+++ b/net/sipxconfig/files/pkg-install.in
@@ -0,0 +1,36 @@
+#!/bin/sh
+
+PATH=/bin:/usr/sbin
+
+USER=sipx
+GROUP=sipx
+
+case $2 in
+PRE-INSTALL)
+ if pw group show "${GROUP}" 2> /dev/null ; then
+ echo "You already have a group \"${GROUP}\", so I will use it."
+ else
+ if pw groupadd ${GROUP} ; then
+ echo "Added group \"${GROUP}\"."
+ else
+ echo "Add of group \"${GROUP}\" failed."
+ exit 1
+ fi
+ fi
+
+ if pw user show "${USER}" 2> /dev/null ; then
+ echo "You already have a user \"${USER}\", so I will use it."
+ else
+ if pw useradd ${USER} -g ${GROUP} -h - \
+ -d %%LOCALSTATEDIR%%/sipxdata/configserver/phone/profile/tftproot -s %%PREFIX%%/bin/bash -c "sipX" ; then
+ echo "Added user \"${USER}\"."
+ else
+ echo "Add of user \"${USER}\" failed."
+ exit 1
+ fi
+ fi
+ ;;
+POST-INSTALL)
+ chown ${USER}:${GROUP} %%PREFIX%%/etc/sipxpbx
+ ;;
+esac