aboutsummaryrefslogtreecommitdiff
path: root/net/sipxportlib
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-02-01 22:25:32 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-02-01 22:25:32 +0000
commit69c26a938c2cee6849486c18ec5fe96bc8626eb3 (patch)
treec83d015284cd79b58e93b11cb565142d972b791a /net/sipxportlib
parent686fe0d87e942fda01ff16eb25766153286d3997 (diff)
Notes
Diffstat (limited to 'net/sipxportlib')
-rw-r--r--net/sipxportlib/Makefile38
-rw-r--r--net/sipxportlib/distinfo3
-rw-r--r--net/sipxportlib/files/patch-bin_sipx-config32
-rw-r--r--net/sipxportlib/files/patch-configure20
-rw-r--r--net/sipxportlib/files/patch-doc_Makefile.am11
-rw-r--r--net/sipxportlib/files/patch-doc_Makefile.in11
-rw-r--r--net/sipxportlib/files/patch-include_os_OsUtil.h12
-rw-r--r--net/sipxportlib/files/patch-src_Makefile.am13
-rw-r--r--net/sipxportlib/files/patch-src_Makefile.in13
-rw-r--r--net/sipxportlib/files/patch-src_os_OsServerSocket.cpp12
-rw-r--r--net/sipxportlib/files/patch-src_os_OsSocket.cpp29
-rw-r--r--net/sipxportlib/files/patch-src_os_OsUtil.cpp11
-rw-r--r--net/sipxportlib/files/patch-src_os_linux_AdapterInfo.cpp11
-rw-r--r--net/sipxportlib/files/patch-src_os_linux_OsDateTimeLinux.cpp11
-rw-r--r--net/sipxportlib/files/patch-src_os_linux_OsProcessIteratorLinux.cpp71
-rw-r--r--net/sipxportlib/files/patch-src_test_testplugin_Makefile.am10
-rw-r--r--net/sipxportlib/files/patch-src_test_testplugin_Makefile.in11
-rw-r--r--net/sipxportlib/pkg-descr4
-rw-r--r--net/sipxportlib/pkg-plist146
19 files changed, 469 insertions, 0 deletions
diff --git a/net/sipxportlib/Makefile b/net/sipxportlib/Makefile
new file mode 100644
index 000000000000..04c707add298
--- /dev/null
+++ b/net/sipxportlib/Makefile
@@ -0,0 +1,38 @@
+# Ports collection makefile for: sipxportlib
+# Date created: Jan 8, 2007
+# Whom: Michael Durian <durian@shadetreesoftware.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= sipxportlib
+PORTVERSION= 3.6.0
+CATEGORIES= net
+MASTER_SITES= http://www.sipfoundry.org/pub/sipX/3.6/SRC/
+
+MAINTAINER= durian@shadetreesoftware.com
+COMMENT= sipX library of general purpose utils and OS abstration APIs.
+
+LIB_DEPENDS= pcre.0:${PORTSDIR}/devel/pcre
+BUILD_DEPENDS= cppunit-config:${PORTSDIR}/devel/cppunit \
+ ginstall:${PORTSDIR}/sysutils/coreutils
+RUN_DEPENDS= bash:${PORTSDIR}/shells/bash
+
+USE_BZIP2= yes
+USE_GMAKE= yes
+USE_AUTOTOOLS= autoconf:259:env automake:19:env
+GNU_CONFIGURE= yes
+USE_LDCONFIG= yes
+USE_PERL5_RUN= yes
+LOCALSTATEDIR=${DESTDIR}/var
+CONFIGURE_ENV+= wwwdir=${PREFIX}/www/sipX \
+ INSTALL=`which ginstall`
+CONFIGURE_ARGS+= --enable-sip-tls \
+ --prefix=${PREFIX} \
+ --localstatedir=${LOCALSTATEDIR}
+
+post-patch:
+ @${REINPLACE_CMD} -e "s,/bin/bash,${PREFIX}/bin/bash," ${WRKSRC}/bin/sipx-upgrade-testsuite.in
+ @${REINPLACE_CMD} -e "s,/bin/bash,${PREFIX}/bin/bash," ${WRKSRC}/bin/sipx-upgrade.in
+
+.include <bsd.port.mk>
diff --git a/net/sipxportlib/distinfo b/net/sipxportlib/distinfo
new file mode 100644
index 000000000000..381518d7f25a
--- /dev/null
+++ b/net/sipxportlib/distinfo
@@ -0,0 +1,3 @@
+MD5 (sipxportlib-3.6.0.tar.bz2) = 9782d5d28083e57ec2eb8999d4eb3430
+SHA256 (sipxportlib-3.6.0.tar.bz2) = 0b56dfa25ec2e479929253121f3a0cae92ad76af0974f561e78e10bad5152e2a
+SIZE (sipxportlib-3.6.0.tar.bz2) = 793742
diff --git a/net/sipxportlib/files/patch-bin_sipx-config b/net/sipxportlib/files/patch-bin_sipx-config
new file mode 100644
index 000000000000..1405f2206ca8
--- /dev/null
+++ b/net/sipxportlib/files/patch-bin_sipx-config
@@ -0,0 +1,32 @@
+--- ./bin/sipx-config.orig Mon Jan 1 15:54:41 2007
++++ ./bin/sipx-config Mon Jan 1 16:05:31 2007
+@@ -68,14 +68,14 @@
+ findJava()
+ {
+ # Gentoo
+- JavaConfig=`java-config --jdk 2>/dev/null`
+- if [ -n "${JavaConfig}" ]
+- then
+-
+- testJava $JavaConfig
++# JavaConfig=`java-config --jdk 2>/dev/null`
++# if [ -n "${JavaConfig}" ]
++# then
++#
++# testJava $JavaConfig
+
+ # If explict setting of location of java does not work, die
+- elif [ -n "${JAVA_HOME}" ]
++ if [ -n "${JAVA_HOME}" ]
+ then
+
+ testJava ${JAVA_HOME}
+@@ -87,7 +87,7 @@
+ # sipXportLib/config/general.m4. Plans to import general.m4
+ # file were scrapped because of carrying all of autoconf
+ TRY_JAVA_HOME=`ls -dr /usr/lib/jvm/java-1.* /usr/java/* 2> /dev/null | head -n 1`
+- for dir in /usr/lib/jvm/jre-ibm $TRY_JAVA_HOME /usr /usr/local/jdk /usr/local/java
++ for dir in /usr/lib/jvm/jre-ibm $TRY_JAVA_HOME /usr /usr/local/jdk /usr/local/java /usr/local/jdk1.5* /usr/local/diablo-jdk1.5.0
+ do
+ if testJava ${dir}
+ then
diff --git a/net/sipxportlib/files/patch-configure b/net/sipxportlib/files/patch-configure
new file mode 100644
index 000000000000..e4b6812c10a9
--- /dev/null
+++ b/net/sipxportlib/files/patch-configure
@@ -0,0 +1,20 @@
+--- ./configure.orig Mon Jan 8 10:53:10 2007
++++ ./configure Mon Jan 8 10:53:31 2007
+@@ -2254,7 +2254,7 @@
+
+ echo "$as_me:$LINENO: checking for automake version >= 1.6" >&5
+ echo $ECHO_N "checking for automake version >= 1.6... $ECHO_C" >&6
+- sf_am_version=`automake --version | head -n 1 | awk '/^automake/ {print $NF}'`
++ sf_am_version=`automake19 --version | head -n 1 | awk '/^automake/ {print $NF}'`
+
+ # Used to indicate true or false condition
+ ax_compare_version=false
+@@ -2333,7 +2333,7 @@
+ echo "${ECHO_T}no" >&6
+ fi
+
+- if test `autoconf --version | grep "2.58" | wc -c` -ne 0 ; then
++ if test `autoconf259 --version | grep "2.58" | wc -c` -ne 0 ; then
+ { echo "$as_me:$LINENO: WARNING: \"Autoconf 2.58 was found on system. If you are a maintainer of this library it has known incompatilities. If you are not a maintainer, 2.58 has serious bugs and you should consider upgrading autoconf\"" >&5
+ echo "$as_me: WARNING: \"Autoconf 2.58 was found on system. If you are a maintainer of this library it has known incompatilities. If you are not a maintainer, 2.58 has serious bugs and you should consider upgrading autoconf\"" >&2;};
+ fi
diff --git a/net/sipxportlib/files/patch-doc_Makefile.am b/net/sipxportlib/files/patch-doc_Makefile.am
new file mode 100644
index 000000000000..931323d9344a
--- /dev/null
+++ b/net/sipxportlib/files/patch-doc_Makefile.am
@@ -0,0 +1,11 @@
+--- doc/Makefile.am.orig Sun Jan 28 16:30:42 2007
++++ doc/Makefile.am Sun Jan 28 16:31:00 2007
+@@ -28,7 +28,7 @@
+ rm -rf $(DESTDIR)@SIPX_DOCDIR@/@PACKAGE@
+ @INSTALL@ -d $(DESTDIR)@SIPX_DOCDIR@/@PACKAGE@
+ find @PACKAGE@ -type f -print \
+- | xargs -i% @INSTALL@ -m u=rw,go=r % $(DESTDIR)@SIPX_DOCDIR@/%
++ | xargs -I % @INSTALL@ -m u=rw,go=r % $(DESTDIR)@SIPX_DOCDIR@/%
+
+ clean: clean-doc
+
diff --git a/net/sipxportlib/files/patch-doc_Makefile.in b/net/sipxportlib/files/patch-doc_Makefile.in
new file mode 100644
index 000000000000..09929e0f2718
--- /dev/null
+++ b/net/sipxportlib/files/patch-doc_Makefile.in
@@ -0,0 +1,11 @@
+--- doc/Makefile.in.orig Sun Jan 28 16:30:47 2007
++++ doc/Makefile.in Sun Jan 28 16:31:08 2007
+@@ -469,7 +469,7 @@
+ rm -rf $(DESTDIR)@SIPX_DOCDIR@/@PACKAGE@
+ @INSTALL@ -d $(DESTDIR)@SIPX_DOCDIR@/@PACKAGE@
+ find @PACKAGE@ -type f -print \
+- | xargs -i% @INSTALL@ -m u=rw,go=r % $(DESTDIR)@SIPX_DOCDIR@/%
++ | xargs -I % @INSTALL@ -m u=rw,go=r % $(DESTDIR)@SIPX_DOCDIR@/%
+
+ clean: clean-doc
+
diff --git a/net/sipxportlib/files/patch-include_os_OsUtil.h b/net/sipxportlib/files/patch-include_os_OsUtil.h
new file mode 100644
index 000000000000..3daafb8af85e
--- /dev/null
+++ b/net/sipxportlib/files/patch-include_os_OsUtil.h
@@ -0,0 +1,12 @@
+--- ./include/os/OsUtil.h.orig Wed Aug 17 13:30:25 2005
++++ ./include/os/OsUtil.h Thu Dec 28 16:14:44 2006
+@@ -47,7 +47,8 @@
+ PLATFORM_MACOSX=97,
+ PLATFORM_SOLARIS=98,
+ PLATFORM_LINUX=99,
+- PLATFORM_WIN32=100
++ PLATFORM_WIN32=100,
++ PLATFORM_FREEBSD=101
+ };
+
+ enum OsProductType
diff --git a/net/sipxportlib/files/patch-src_Makefile.am b/net/sipxportlib/files/patch-src_Makefile.am
new file mode 100644
index 000000000000..652ba9e57535
--- /dev/null
+++ b/net/sipxportlib/files/patch-src_Makefile.am
@@ -0,0 +1,13 @@
+--- ./src/Makefile.am.orig Thu Dec 28 16:20:02 2006
++++ ./src/Makefile.am Wed Jan 3 20:40:10 2007
+@@ -26,8 +26,8 @@
+ @PCRE_LIBS@ \
+ @SSL_LIBS@ \
+ @RT_LIBS@ \
+- -ldl \
+- -lpthread
++ -lpthread \
++ -lkvm
+
+ if ISGCC
+ libsipXport_la_LIBADD += -lstdc++
diff --git a/net/sipxportlib/files/patch-src_Makefile.in b/net/sipxportlib/files/patch-src_Makefile.in
new file mode 100644
index 000000000000..f8dd1cce4224
--- /dev/null
+++ b/net/sipxportlib/files/patch-src_Makefile.in
@@ -0,0 +1,13 @@
+--- ./src/Makefile.in.orig Thu Dec 28 16:19:58 2006
++++ ./src/Makefile.in Wed Jan 3 20:40:21 2007
+@@ -404,8 +404,8 @@
+ @PCRE_LDFLAGS@ \
+ @SSL_LDFLAGS@
+
+-libsipXport_la_LIBADD = @PCRE_LIBS@ @SSL_LIBS@ @RT_LIBS@ -ldl \
+- -lpthread $(am__append_1)
++libsipXport_la_LIBADD = @PCRE_LIBS@ @SSL_LIBS@ @RT_LIBS@ \
++ -lpthread -lkvm $(am__append_1)
+
+ # this is helpful if you're debugging something with lots of inlines (like the UtlLink code)
+ # -fno-gcse -O0 -fno-implement-inlines -fno-default-inline
diff --git a/net/sipxportlib/files/patch-src_os_OsServerSocket.cpp b/net/sipxportlib/files/patch-src_os_OsServerSocket.cpp
new file mode 100644
index 000000000000..8effe4c0c876
--- /dev/null
+++ b/net/sipxportlib/files/patch-src_os_OsServerSocket.cpp
@@ -0,0 +1,12 @@
+--- ./src/os/OsServerSocket.cpp.orig Tue Jan 2 17:41:00 2007
++++ ./src/os/OsServerSocket.cpp Tue Jan 2 18:00:22 2007
+@@ -142,7 +142,8 @@
+ {
+ error = OsSocketGetERRNO();
+ OsSysLog::add(FAC_KERNEL, PRI_ERR,
+- "OsServerSocket: bind to port %d failed with error: %d = 0x%x",
++ "OsServerSocket: bind to port %s:%d failed with error: %d = 0x%x",
++ inet_ntoa(localAddr.sin_addr),
+ ((PORT_DEFAULT == serverPort) ? 0 : serverPort), error, error);
+ socketDescriptor = OS_INVALID_SOCKET_DESCRIPTOR;
+ goto EXIT;
diff --git a/net/sipxportlib/files/patch-src_os_OsSocket.cpp b/net/sipxportlib/files/patch-src_os_OsSocket.cpp
new file mode 100644
index 000000000000..cb9b9600b50c
--- /dev/null
+++ b/net/sipxportlib/files/patch-src_os_OsSocket.cpp
@@ -0,0 +1,29 @@
+--- ./src/os/OsSocket.cpp.orig Tue Jan 2 17:37:30 2007
++++ ./src/os/OsSocket.cpp Sat Jan 6 22:41:02 2007
+@@ -165,7 +165,7 @@
+
+ int flags = 0;
+
+-#if defined(__linux__) || defined(sun)
++#if defined(__linux__) || defined(sun) || defined(__FreeBSD__)
+ // We do not want send to throw signals if there is a
+ // problem with the socket as this results in the process
+ // getting aborted. We just want it to return an error.
+@@ -224,7 +224,7 @@
+
+ int flags = 0;
+
+-#if defined(__linux__) || defined(sun)
++#if defined(__linux__) || defined(sun) || defined(__FreeBSD__)
+ // We do not want send to throw signals if there is a
+ // problem with the socket as this results in the process
+ // getting aborted. We just want it to return an error.
+@@ -275,7 +275,7 @@
+
+ int flags = 0;
+
+-#if defined(__linux__) || defined(sun)
++#if defined(__linux__) || defined(sun) || defined(__FreeBSD__)
+ // We do not want send to throw signals if there is a
+ // problem with the socket as this results in the process
+ // getting aborted. We just want it to return an error.
diff --git a/net/sipxportlib/files/patch-src_os_OsUtil.cpp b/net/sipxportlib/files/patch-src_os_OsUtil.cpp
new file mode 100644
index 000000000000..a2496d1fea06
--- /dev/null
+++ b/net/sipxportlib/files/patch-src_os_OsUtil.cpp
@@ -0,0 +1,11 @@
+--- ./src/os/OsUtil.cpp.orig Tue Jul 25 17:05:55 2006
++++ ./src/os/OsUtil.cpp Thu Dec 28 16:14:44 2006
+@@ -426,6 +426,8 @@
+ platform = PLATFORM_LINUX;
+ #elif defined(sun) /* ] [ */
+ platform = PLATFORM_SOLARIS;
++#elif defined(__FreeBSD__)
++ platform = PLATFORM_FREEBSD;
+ #else /* ] [ */
+ #error Unexpected Platform/CPU type
+ #endif /* ] ]*/
diff --git a/net/sipxportlib/files/patch-src_os_linux_AdapterInfo.cpp b/net/sipxportlib/files/patch-src_os_linux_AdapterInfo.cpp
new file mode 100644
index 000000000000..8b6385adedab
--- /dev/null
+++ b/net/sipxportlib/files/patch-src_os_linux_AdapterInfo.cpp
@@ -0,0 +1,11 @@
+--- ./src/os/linux/AdapterInfo.cpp.orig Tue Jan 2 17:19:45 2007
++++ ./src/os/linux/AdapterInfo.cpp Tue Jan 2 17:20:04 2007
+@@ -68,7 +68,7 @@
+ else
+ {
+ rc = TRUE;
+-#ifndef __MACH__
++#if !defined(__MACH__) && !defined(__FreeBSD__)
+ // Get the number of returned addresses from ifc_len.
+ numAddresses = ifconf_structure.ifc_len / sizeof (struct ifreq);
+ int j = 0;
diff --git a/net/sipxportlib/files/patch-src_os_linux_OsDateTimeLinux.cpp b/net/sipxportlib/files/patch-src_os_linux_OsDateTimeLinux.cpp
new file mode 100644
index 000000000000..2d820fe7b6e9
--- /dev/null
+++ b/net/sipxportlib/files/patch-src_os_linux_OsDateTimeLinux.cpp
@@ -0,0 +1,11 @@
+--- ./src/os/linux/OsDateTimeLinux.cpp.orig Tue Aug 1 03:09:34 2006
++++ ./src/os/linux/OsDateTimeLinux.cpp Thu Dec 28 16:14:44 2006
+@@ -169,7 +169,7 @@
+ gettimeofday( &theTime, NULL );
+
+ struct tm curDateTime;
+- gmtime_r(&theTime.tv_sec, &curDateTime);
++ gmtime_r((time_t *)&theTime.tv_sec, &curDateTime);
+
+ rDateTime.mYear = 1900 + curDateTime.tm_year;
+ rDateTime.mMonth = (unsigned char) curDateTime.tm_mon;
diff --git a/net/sipxportlib/files/patch-src_os_linux_OsProcessIteratorLinux.cpp b/net/sipxportlib/files/patch-src_os_linux_OsProcessIteratorLinux.cpp
new file mode 100644
index 000000000000..7528009a8e97
--- /dev/null
+++ b/net/sipxportlib/files/patch-src_os_linux_OsProcessIteratorLinux.cpp
@@ -0,0 +1,71 @@
+--- ./src/os/linux/OsProcessIteratorLinux.cpp.orig Wed Jan 3 17:16:44 2007
++++ ./src/os/linux/OsProcessIteratorLinux.cpp Wed Jan 3 20:45:43 2007
+@@ -9,6 +9,16 @@
+ #include <assert.h>
+ #include <stdlib.h>
+
++#if defined(__FreeBSD__)
++#include <fcntl.h>
++#include <kvm.h>
++#include <sys/param.h>
++#include <sys/sysctl.h>
++#include <sys/user.h>
++#include <limits.h>
++#include <paths.h>
++#endif
++
+ // APPLICATION INCLUDES
+ #include "os/OsFS.h"
+ #include "os/linux/OsProcessIteratorLinux.h"
+@@ -100,6 +110,7 @@
+
+ /* //////////////////////////// PRIVATE /////////////////////////////////// */
+
++#if !defined(__FreeBSD__)
+ //reads the status file in the /proc/nnnn directory
+ OsStatus OsProcessIteratorLinux::readProcFile(OsPath &procDirname, OsProcess & rProcess)
+ {
+@@ -165,5 +176,43 @@
+
+ return retval;
+ }
++#else
++/*
++ * We need to do this differently under FreeBSD. We could open the
++ * appropriate /proc/nnnn/status file as shown above, but OsFile
++ * wants to call fcntl() to lock the file when it is opened. FreeBSD
++ * does not allow locking the procfs file and fails the fcntl() call.
++ * This in turn means we don't get to read the PID information and
++ * all sorts of bad things start happening.
++ *
++ * Rather than try to find a way to bypass the fcntl() call in some
++ * cases, let's just go ahead and use another method to get this PID
++ * information.
++ */
++OsStatus OsProcessIteratorLinux::readProcFile(OsPath &procDirname, OsProcess & rProcess)
++{
++ OsStatus retval = OS_FAILED;
++ kvm_t *kd;
++ struct kinfo_proc *kp;
++ int nentries, pid;
++ char errbuf[_POSIX2_LINE_MAX];
++
++ kd = kvm_openfiles(_PATH_DEVNULL, _PATH_DEVNULL, NULL, O_RDONLY, errbuf);
++ if (kd != NULL) {
++ nentries = -1;
++ pid = atoi(procDirname.data());
++ kp = kvm_getprocs(kd, KERN_PROC_PID, pid, &nentries);
++ if (kp != NULL && nentries > 0) {
++ rProcess.mProcessName = kp->ki_comm;
++ rProcess.mPID = kp->ki_pid;
++ rProcess.mParentPID = kp->ki_ppid;
++ retval = OS_SUCCESS;
++ }
++ kvm_close(kd);
++ }
++
++ return retval;
++}
++#endif
+
+ /* ============================ FUNCTIONS ================================= */
diff --git a/net/sipxportlib/files/patch-src_test_testplugin_Makefile.am b/net/sipxportlib/files/patch-src_test_testplugin_Makefile.am
new file mode 100644
index 000000000000..7e26f2a8d08a
--- /dev/null
+++ b/net/sipxportlib/files/patch-src_test_testplugin_Makefile.am
@@ -0,0 +1,10 @@
+--- ./src/test/testplugin/Makefile.am.orig Thu Dec 28 16:20:59 2006
++++ ./src/test/testplugin/Makefile.am Thu Dec 28 16:21:18 2006
+@@ -32,7 +32,6 @@
+
+ libtestpluginA_la_LIBADD = \
+ @RT_LIBS@ \
+- -ldl \
+ -lpthread
+
+ if ISGCC
diff --git a/net/sipxportlib/files/patch-src_test_testplugin_Makefile.in b/net/sipxportlib/files/patch-src_test_testplugin_Makefile.in
new file mode 100644
index 000000000000..abb018791d02
--- /dev/null
+++ b/net/sipxportlib/files/patch-src_test_testplugin_Makefile.in
@@ -0,0 +1,11 @@
+--- ./src/test/testplugin/Makefile.in.orig Thu Dec 28 16:21:05 2006
++++ ./src/test/testplugin/Makefile.in Thu Dec 28 16:22:57 2006
+@@ -319,7 +319,7 @@
+ # Age - set to 0 of any interfaces have been removed
+ # increment if any interfaces have been added
+ version_Age = 0
+-libtestpluginA_la_LIBADD = @RT_LIBS@ -ldl -lpthread $(am__append_1)
++libtestpluginA_la_LIBADD = @RT_LIBS@ -lpthread $(am__append_1)
+ libtestpluginB_la_LIBADD = $(libtestpluginA_la_LIBADD)
+ libtestpluginA_la_CXXFLAGS = \
+ -DLIBRARY_NAME=\"TestPluginA\" \
diff --git a/net/sipxportlib/pkg-descr b/net/sipxportlib/pkg-descr
new file mode 100644
index 000000000000..8e054c091d26
--- /dev/null
+++ b/net/sipxportlib/pkg-descr
@@ -0,0 +1,4 @@
+sipXportLib is a library of general purpose utilities and OS
+abstraction APIs. It is a necessary dependancy of the sipX project.
+
+WWW: http://sipx-wiki.calivia.com/index.php/Main_Page
diff --git a/net/sipxportlib/pkg-plist b/net/sipxportlib/pkg-plist
new file mode 100644
index 000000000000..e62ff9b724ab
--- /dev/null
+++ b/net/sipxportlib/pkg-plist
@@ -0,0 +1,146 @@
+bin/sipx-config
+bin/sipx-upgrade
+bin/sipxportlib-config
+bin/syslogviewer
+include/os/HostAdapterAddress.h
+include/os/OsAssert.h
+include/os/OsBSem.h
+include/os/OsCSem.h
+include/os/OsCallback.h
+include/os/OsConfigDb.h
+include/os/OsConfigEncryption.h
+include/os/OsConnectionSocket.h
+include/os/OsDatagramSocket.h
+include/os/OsDateTime.h
+include/os/OsDefs.h
+include/os/OsDirBase.h
+include/os/OsEncryption.h
+include/os/OsEvent.h
+include/os/OsEventMsg.h
+include/os/OsExcept.h
+include/os/OsFS.h
+include/os/OsFileBase.h
+include/os/OsFileInfoBase.h
+include/os/OsFileIteratorBase.h
+include/os/OsFileSystem.h
+include/os/OsLock.h
+include/os/OsLockingList.h
+include/os/OsMsg.h
+include/os/OsMsgPool.h
+include/os/OsMsgQ.h
+include/os/OsMulticastSocket.h
+include/os/OsMutex.h
+include/os/OsNameDb.h
+include/os/OsNotification.h
+include/os/OsPathBase.h
+include/os/OsProcess.h
+include/os/OsProcessIterator.h
+include/os/OsProcessMgr.h
+include/os/OsProtectEvent.h
+include/os/OsProtectEventMgr.h
+include/os/OsPtrMsg.h
+include/os/OsQueuedEvent.h
+include/os/OsRWMutex.h
+include/os/OsReadLock.h
+include/os/OsRpcMsg.h
+include/os/OsSSL.h
+include/os/OsSSLConnectionSocket.h
+include/os/OsSSLServerSocket.h
+include/os/OsServerSocket.h
+include/os/OsServerTask.h
+include/os/OsSharedLibMgr.h
+include/os/OsSocket.h
+include/os/OsStatus.h
+include/os/OsStunAgentTask.h
+include/os/OsStunDatagramSocket.h
+include/os/OsStunQueryAgent.h
+include/os/OsSyncBase.h
+include/os/OsSysLog.h
+include/os/OsSysLogFacilities.h
+include/os/OsSysLogMsg.h
+include/os/OsSysLogTask.h
+include/os/OsTask.h
+include/os/OsTime.h
+include/os/OsTimeLog.h
+include/os/OsTimer.h
+include/os/OsTimerMsg.h
+include/os/OsTimerTask.h
+include/os/OsTokenizer.h
+include/os/OsUtil.h
+include/os/OsWriteLock.h
+include/os/fstream
+include/os/iostream
+include/os/istream
+include/os/linux/AdapterInfo.h
+include/os/linux/OsBSemLinux.h
+include/os/linux/OsCSemLinux.h
+include/os/linux/OsDateTimeLinux.h
+include/os/linux/OsDirLinux.h
+include/os/linux/OsFileInfoLinux.h
+include/os/linux/OsFileIteratorLinux.h
+include/os/linux/OsFileLinux.h
+include/os/linux/OsLinuxDefs.h
+include/os/linux/OsMutexLinux.h
+include/os/linux/OsPathLinux.h
+include/os/linux/OsProcessIteratorLinux.h
+include/os/linux/OsProcessLinux.h
+include/os/linux/OsSharedLibMgrLinux.h
+include/os/linux/OsTaskLinux.h
+include/os/linux/OsUtilLinux.h
+include/os/linux/host_address.h
+include/os/linux/pt_csem.h
+include/os/linux/pt_mutex.h
+include/os/ostream
+include/os/qsTypes.h
+include/os/shared/OsMsgQShared.h
+include/os/shared/OsTimerMessage.h
+include/sipxunit/TestUtilities.h
+include/utl/Plugin.h
+include/utl/PluginHooks.h
+include/utl/UtlBool.h
+include/utl/UtlContainable.h
+include/utl/UtlContainableAtomic.h
+include/utl/UtlContainer.h
+include/utl/UtlDList.h
+include/utl/UtlDListIterator.h
+include/utl/UtlDateTime.h
+include/utl/UtlDefs.h
+include/utl/UtlHashBag.h
+include/utl/UtlHashBagIterator.h
+include/utl/UtlHashMap.h
+include/utl/UtlHashMapIterator.h
+include/utl/UtlHistogram.h
+include/utl/UtlInt.h
+include/utl/UtlIterator.h
+include/utl/UtlLink.h
+include/utl/UtlList.h
+include/utl/UtlListIterator.h
+include/utl/UtlLongLongInt.h
+include/utl/UtlRandom.h
+include/utl/UtlRegex.h
+include/utl/UtlRscStore.h
+include/utl/UtlRscTrace.h
+include/utl/UtlSList.h
+include/utl/UtlSListIterator.h
+include/utl/UtlSortedList.h
+include/utl/UtlSortedListIterator.h
+include/utl/UtlString.h
+include/utl/UtlTokenizer.h
+include/utl/UtlVoidPtr.h
+include/utl/XmlContent.h
+include/xmlparser/ExtractContent.h
+include/xmlparser/TiXmlIterator.h
+include/xmlparser/tinystr.h
+include/xmlparser/tinyxml.h
+lib/libsipXport.a
+lib/libsipXport.la
+lib/libsipXport.so
+lib/libsipXport.so.2
+lib/libsipXunit.a
+lib/libsipXunit.la
+@dirrm include/xmlparser
+@dirrm include/utl
+@dirrm include/sipxunit
+@dirrm include/os/shared
+@dirrm include/os/linux
+@dirrm include/os