aboutsummaryrefslogtreecommitdiff
path: root/net/sipxproxy
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-02-01 22:42:19 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-02-01 22:42:19 +0000
commita1ee2deb538d9cfbda104f5bf011a3d29c057331 (patch)
tree13576a8a6f8221f97d44a0560a25a20cf20e175a /net/sipxproxy
parent895afe747c2bd806c93ea26d35e03be295ecca44 (diff)
downloadports-a1ee2deb538d9cfbda104f5bf011a3d29c057331.tar.gz
ports-a1ee2deb538d9cfbda104f5bf011a3d29c057331.zip
Notes
Diffstat (limited to 'net/sipxproxy')
-rw-r--r--net/sipxproxy/Makefile48
-rw-r--r--net/sipxproxy/distinfo3
-rw-r--r--net/sipxproxy/files/patch-bin_sipproxy.sh.in11
-rw-r--r--net/sipxproxy/files/patch-bin_sipxcallresolver.sh.in56
-rw-r--r--net/sipxproxy/files/patch-doc-Makefile.am11
-rw-r--r--net/sipxproxy/files/patch-doc-Makefile.in11
-rw-r--r--net/sipxproxy/files/pkg-deinstall.in19
-rw-r--r--net/sipxproxy/pkg-descr4
-rw-r--r--net/sipxproxy/pkg-plist20
9 files changed, 183 insertions, 0 deletions
diff --git a/net/sipxproxy/Makefile b/net/sipxproxy/Makefile
new file mode 100644
index 000000000000..e18cded9fac0
--- /dev/null
+++ b/net/sipxproxy/Makefile
@@ -0,0 +1,48 @@
+# Ports collection makefile for: sipxproxy
+# Date created: Jan 8, 2007
+# Whom: Michael Durian <durian@shadetreesoftware.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= sipxproxy
+PORTVERSION= 3.6.0
+CATEGORIES= net
+MASTER_SITES= http://www.sipfoundry.org/pub/sipX/3.6/SRC/
+
+MAINTAINER= durian@shadetreesoftware.com
+COMMENT= sipX server for handling SIP authorization and call records
+
+LIB_DEPENDS= sipXport:${PORTSDIR}/net/sipxportlib \
+ sipXtack:${PORTSDIR}/net/sipxtacklib \
+ sipXcommserver:${PORTSDIR}/net/sipxcommserverlib \
+ pcre.0:${PORTSDIR}/devel/pcre
+RUN_DEPENDS= bash:${PORTSDIR}/shells/bash \
+ psql:${PORTSDIR}/databases/postgresql81-client
+BUILD_DEPENDS= zip:${PORTSDIR}/archivers/zip \
+ gem:${PORTSDIR}/devel/ruby-gems \
+ rake:${PORTSDIR}/devel/rubygem-rake \
+ ginstall:${PORTSDIR}/sysutils/coreutils \
+ cppunit-config:${PORTSDIR}/devel/cppunit
+
+USE_BZIP2= yes
+USE_GMAKE= yes
+USE_RUBY= yes
+USE_AUTOTOOLS= autoconf:259:env automake:19:env
+GNU_CONFIGURE= yes
+LOCALSTATEDIR=${DESTDIR}/var
+CONFIGURE_ENV+= wwwdir=${PREFIX}/www/sipX \
+ INSTALL=`which ginstall`
+CONFIGURE_ARGS+= --enable-sip-tls \
+ --prefix=${PREFIX} \
+ --localstatedir=${LOCALSTATEDIR}
+SUB_LIST= LOCALSTATEDIR=${LOCALSTATEDIR}
+SUB_FILES= pkg-deinstall
+
+post-patch:
+ @${REINPLACE_CMD} -e "s,/bin/bash,${PREFIX}/bin/bash," ${WRKSRC}/bin/sipxcallresolver.sh.in
+ @${REINPLACE_CMD} -e "s,/bin/bash,${PREFIX}/bin/bash," ${WRKSRC}/bin/sipproxy.sh.in
+ @${REINPLACE_CMD} -e "s,/bin/bash,${PREFIX}/bin/bash," ${WRKSRC}/bin/sipauthproxy.sh.in
+ @${REINPLACE_CMD} -e "s,/bin/bash,${PREFIX}/bin/bash," ${WRKSRC}/bin/sipxha-distrib.sh.in
+
+.include <bsd.port.mk>
diff --git a/net/sipxproxy/distinfo b/net/sipxproxy/distinfo
new file mode 100644
index 000000000000..5f7f6300ef5f
--- /dev/null
+++ b/net/sipxproxy/distinfo
@@ -0,0 +1,3 @@
+MD5 (sipxproxy-3.6.0.tar.bz2) = 8d35667fa4188316e9b6ac0ae94dd920
+SHA256 (sipxproxy-3.6.0.tar.bz2) = a6591579070c4c113852753593e4f152577da5e5e399ed50d78efc667a24334f
+SIZE (sipxproxy-3.6.0.tar.bz2) = 372514
diff --git a/net/sipxproxy/files/patch-bin_sipproxy.sh.in b/net/sipxproxy/files/patch-bin_sipproxy.sh.in
new file mode 100644
index 000000000000..96770ad0cc7a
--- /dev/null
+++ b/net/sipxproxy/files/patch-bin_sipproxy.sh.in
@@ -0,0 +1,11 @@
+--- ./bin/sipproxy.sh.in.orig Mon Jan 1 19:19:25 2007
++++ ./bin/sipproxy.sh.in Mon Jan 1 19:30:05 2007
+@@ -57,7 +57,7 @@
+ #@bindir@/sipx-validate-xml @SIPX_CONFDIR@/forwardingrules.xml
+ #Status=$?
+
+- myHostname=`hostname -f | tr A-Z a-z`
++ myHostname=`hostname | tr A-Z a-z`
+ status=$?
+ Status=$((${Status}+${status}))
+
diff --git a/net/sipxproxy/files/patch-bin_sipxcallresolver.sh.in b/net/sipxproxy/files/patch-bin_sipxcallresolver.sh.in
new file mode 100644
index 000000000000..de371481d4c6
--- /dev/null
+++ b/net/sipxproxy/files/patch-bin_sipxcallresolver.sh.in
@@ -0,0 +1,56 @@
+--- ./bin/sipxcallresolver.sh.in.orig Mon Jan 1 15:29:43 2007
++++ ./bin/sipxcallresolver.sh.in Mon Jan 1 16:28:32 2007
+@@ -30,7 +30,7 @@
+ : ${LogDir:=@SIPX_LOGDIR@}
+ : ${TmpDir:=@SIPX_TMPDIR@}
+ : ${RunningUser:=@SIPXPBXUSER@}
+-: ${PgUser:=postgres}
++: ${PgUser:=pgsql}
+ : ${PgSchema:=@SIPX_CONFDIR@/cdr/schema.sql}
+ : ${DbVersion:=2}
+ : ${DbPatchDir:=@SIPX_CONFDIR@/cdr}
+@@ -178,7 +178,7 @@
+ # 2. running but not setup to communicate w/java or ${Psql} command
+ # 3. Database is not created
+ databaseCheck() {
+- if ! ${Psql} -l -U postgres | grep "${Database}" >/dev/null 2>&1
++ if ! ${Psql} -l -U pgsql | grep "${Database}" >/dev/null 2>&1
+ then
+ procs=`ps -C postmaster`
+ if ! expr match "$procs" '.*postmaster.*' >/dev/null; then
+@@ -190,15 +190,9 @@
+ fi
+ else
+ # Check postgres configuration
+- Service=`postgresService`
++ Service=postgresql
+ if test -z $PGDATA; then
+- # Debian/Gentoo
+- if test -d /var/lib/postgresql/data; then
+- PGDATA=/var/lib/postgresql/data
+- else
+- # Redhat
+- PGDATA=/var/lib/pgsql/data
+- fi
++ PGDATA=/usr/local/pgsql/data
+ fi
+ # Check for conf file
+ if [ -f $PGDATA/pg_hba.conf ]; then
+@@ -213,7 +207,7 @@
+ fi
+ else
+ # Check if psql command works at all
+- if ${Psql} -l -U postgres >/dev/null 2>&1; then
++ if ${Psql} -l -U pgsql >/dev/null 2>&1; then
+ if [ "$1" != "Silent" ]; then
+ echo
+ echo " Error: The SIPXCDR database does not exist. Run the sipxcallresolver.sh"
+@@ -415,7 +409,7 @@
+ # Check the database version. If it is wrong, then exit, because it's dangerous to
+ # run call resolver on top of the wrong database version.
+ databaseVersionCheck() {
+- dbver=`${Psql} -c "select max(vh.version) from version_history vh;" ${Database} postgres | sed -n 's/^\s*\([0-9][0-9]*\)\s*$/\1/p'`
++ dbver=`${Psql} -c "select max(vh.version) from version_history vh;" ${Database} pgsql | sed -n 's/^\s*\([0-9][0-9]*\)\s*$/\1/p'`
+ if [ "$dbver" = "" ]
+ then
+ echo " Error: could not get the database version."
diff --git a/net/sipxproxy/files/patch-doc-Makefile.am b/net/sipxproxy/files/patch-doc-Makefile.am
new file mode 100644
index 000000000000..c69f243adf86
--- /dev/null
+++ b/net/sipxproxy/files/patch-doc-Makefile.am
@@ -0,0 +1,11 @@
+--- doc/Makefile.am.orig Mon Jan 29 14:35:49 2007
++++ doc/Makefile.am Mon Jan 29 14:36:06 2007
+@@ -28,7 +28,7 @@
+ rm -rf $(DESTDIR)@SIPX_DOCDIR@/@PACKAGE@
+ @INSTALL@ -d $(DESTDIR)@SIPX_DOCDIR@/@PACKAGE@
+ find @PACKAGE@ -type f -print \
+- | xargs -i% @INSTALL@ -m u=rw,go=r % $(DESTDIR)@SIPX_DOCDIR@/%
++ | xargs -I% @INSTALL@ -m u=rw,go=r % $(DESTDIR)@SIPX_DOCDIR@/%
+
+ clean: clean-doc
+
diff --git a/net/sipxproxy/files/patch-doc-Makefile.in b/net/sipxproxy/files/patch-doc-Makefile.in
new file mode 100644
index 000000000000..cc7935d720e6
--- /dev/null
+++ b/net/sipxproxy/files/patch-doc-Makefile.in
@@ -0,0 +1,11 @@
+--- doc/Makefile.in.orig Mon Jan 29 14:35:56 2007
++++ doc/Makefile.in Mon Jan 29 14:36:17 2007
+@@ -481,7 +481,7 @@
+ rm -rf $(DESTDIR)@SIPX_DOCDIR@/@PACKAGE@
+ @INSTALL@ -d $(DESTDIR)@SIPX_DOCDIR@/@PACKAGE@
+ find @PACKAGE@ -type f -print \
+- | xargs -i% @INSTALL@ -m u=rw,go=r % $(DESTDIR)@SIPX_DOCDIR@/%
++ | xargs -I% @INSTALL@ -m u=rw,go=r % $(DESTDIR)@SIPX_DOCDIR@/%
+
+ clean: clean-doc
+
diff --git a/net/sipxproxy/files/pkg-deinstall.in b/net/sipxproxy/files/pkg-deinstall.in
new file mode 100644
index 000000000000..44586360bbaa
--- /dev/null
+++ b/net/sipxproxy/files/pkg-deinstall.in
@@ -0,0 +1,19 @@
+#!/bin/sh
+
+PATH=/bin:/usr/sbin:/usr/bin:/usr/sbin
+
+LOCALSTATEDIR="%%LOCALSTATEDIR%%"
+
+post-deinstall() {
+ echo "WARNING: If you will *NOT* use this package anymore, please remove
+ the"
+ echo " following file manually:"
+ echo " ${LOCALSTATEDIR}/sipxdata/upgrade/sipxproxy-previous.tgz"
+ echo
+}
+
+case $2 in
+ POST-DEINSTALL)
+ post-deinstall
+ ;;
+esac
diff --git a/net/sipxproxy/pkg-descr b/net/sipxproxy/pkg-descr
new file mode 100644
index 000000000000..d3e7f1251e2a
--- /dev/null
+++ b/net/sipxproxy/pkg-descr
@@ -0,0 +1,4 @@
+sipXproxy is the authorization and call record server component of the
+sipX family.
+
+WWW: http://sipx-wiki.calivia.com/index.php/Main_Page
diff --git a/net/sipxproxy/pkg-plist b/net/sipxproxy/pkg-plist
new file mode 100644
index 000000000000..2e47ba2d2552
--- /dev/null
+++ b/net/sipxproxy/pkg-plist
@@ -0,0 +1,20 @@
+bin/sipauthproxy
+bin/sipauthproxy.sh
+bin/sipproxy
+bin/sipproxy.sh
+bin/sipxcallresolver.sh
+bin/sipxha-distrib.sh
+bin/sipxproxy-config
+etc/sipxpbx/authproxy-config.in
+etc/sipxpbx/authrules.xml.in
+etc/sipxpbx/callresolver-config.in
+etc/sipxpbx/cdr/refer_uri.sql
+etc/sipxpbx/cdr/schema.sql
+etc/sipxpbx/cdr/view_cdrs.sql
+etc/sipxpbx/forwardingrules.xml.in
+etc/sipxpbx/process.d/sipauthproxy.process.xml
+etc/sipxpbx/process.d/sipproxy.process.xml
+etc/sipxpbx/proxy-config.in
+@dirrm etc/sipxpbx/process.d
+@dirrm etc/sipxpbx/cdr
+@dirrm etc/sipxpbx