aboutsummaryrefslogtreecommitdiff
path: root/net/sipxvxml/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-03-27 08:29:17 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-03-27 08:29:17 +0000
commit7e299665cefe4bf05db8a257dd544d2ec9bee33e (patch)
tree91baf0fcc1228ec1d478f1d650c2513549d2a4df /net/sipxvxml/Makefile
parentb1d1e9601978d09e4bf6964dfb7936519aff037c (diff)
downloadports-7e299665cefe4bf05db8a257dd544d2ec9bee33e.tar.gz
ports-7e299665cefe4bf05db8a257dd544d2ec9bee33e.zip
Notes
Diffstat (limited to 'net/sipxvxml/Makefile')
-rw-r--r--net/sipxvxml/Makefile13
1 files changed, 11 insertions, 2 deletions
diff --git a/net/sipxvxml/Makefile b/net/sipxvxml/Makefile
index 779225817b42..0c146444d5f5 100644
--- a/net/sipxvxml/Makefile
+++ b/net/sipxvxml/Makefile
@@ -7,6 +7,7 @@
PORTNAME= sipxvxml
PORTVERSION= 3.6.0
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= http://www.sipfoundry.org/pub/sipX/3.6/SRC/
@@ -34,10 +35,18 @@ CONFIGURE_ENV+= wwwdir=${PREFIX}/www/sipX \
CONFIGURE_ARGS+= --enable-sip-tls \
--prefix=${PREFIX} \
--localstatedir=${LOCALSTATEDIR}
-SUB_LIST= LOCALSTATEDIR=${LOCALSTATEDIR}
-SUB_FILES= pkg-deinstall
+SUB_LIST= LOCALSTATEDIR=${LOCALSTATEDIR} \
+ PREFIX=${PREFIX}
+SUB_FILES= pkg-install pkg-deinstall
+PKGINSTALL= ${WRKDIR}/pkg-install
post-patch:
@${REINPLACE_CMD} -e "s,/bin/bash,${PREFIX}/bin/bash," ${WRKSRC}/bin/sipXvxml.sh.in
+pre-install:
+ @${SH} ${PKGINSTALL} ${PORTNAME} PRE-INSTALL
+
+post-install:
+ @${SH} ${PKGINSTALL} ${PORTNAME} POST-INSTALL
+
.include <bsd.port.mk>