aboutsummaryrefslogtreecommitdiff
path: root/net/sixxs-aiccu
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2006-12-30 20:00:45 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2006-12-30 20:00:45 +0000
commitdc9668fffec3fea93eb7fa3ca29a8e4a2ffda90d (patch)
tree3f4571e0bc7f35dfde28ed47d50622736c8e15f0 /net/sixxs-aiccu
parent708184d2bfc627832dfe61c3e6aa6e033e79d1ee (diff)
downloadports-dc9668fffec3fea93eb7fa3ca29a8e4a2ffda90d.tar.gz
ports-dc9668fffec3fea93eb7fa3ca29a8e4a2ffda90d.zip
Notes
Diffstat (limited to 'net/sixxs-aiccu')
-rw-r--r--net/sixxs-aiccu/Makefile33
-rw-r--r--net/sixxs-aiccu/distinfo6
-rw-r--r--net/sixxs-aiccu/files/patch-common_tun.c21
-rw-r--r--net/sixxs-aiccu/files/patch-unix-console::Makefile45
-rw-r--r--net/sixxs-aiccu/files/sixxs-aiccu.in (renamed from net/sixxs-aiccu/files/sixxs-aiccu.sh)0
-rw-r--r--net/sixxs-aiccu/pkg-plist5
6 files changed, 66 insertions, 44 deletions
diff --git a/net/sixxs-aiccu/Makefile b/net/sixxs-aiccu/Makefile
index e8112541d34e..67f2fdeb1e50 100644
--- a/net/sixxs-aiccu/Makefile
+++ b/net/sixxs-aiccu/Makefile
@@ -5,45 +5,44 @@
# $FreeBSD$
#
-PORTNAME= sixxs-aiccu
-PORTVERSION= 20050131
+PORTNAME= aiccu
+PORTVERSION= 20060725
CATEGORIES= net ipv6
MASTER_SITES= http://www.sixxs.net/archive/sixxs/aiccu/unix/
-DISTNAME= aiccu_2005.01.31
+PKGNAMEPREFIX= sixxs-
+DISTNAME= aiccu_2006.07.25
MAINTAINER= meno.abels@adviser.com
COMMENT= SixXS IPv6 TIC+ tunnel broker heartbeat client
-USE_RC_SUBR= yes
+USE_RC_SUBR= sixxs-aiccu
USE_GMAKE= yes
-CFLAGS+= ${PTHREAD_CFLAGS}
+
+CFLAGS+= ${PTHREAD_CFLAGS} -D_REENTRANT
LDFLAGS+= ${PTHREAD_LIBS}
-MAKE_ARGS= CC="${CC}"
-MAKE_ENV= CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
+MAKE_ARGS+= CC="${CC}" LDFLAGS="${LDFLAGS}"
WRKSRC= ${WRKDIR}/aiccu
BUILD_WRKSRC= ${WRKDIR}/aiccu/unix-console
PORTDOCS= README
-pre-build:
- @${SED} -e 's:%%PREFIX%%:${PREFIX}:g' \
- -e 's:%%RC_SUBR%%:${RC_SUBR}:g' \
- ${FILESDIR}/sixxs-aiccu.sh >${WRKDIR}/sixxs-aiccu.sh
- @${SED} \
+post-patch:
+ @${REINPLACE_CMD} \
-e 's:verbose true:verbose false:' \
-e 's:daemonize false:daemonize true:' \
-e 's:automatic false:automatic true:' \
-e 's:tunnel_id T2995:#tunnel_id TXXXX:' \
-e 's:ipv4_interface eth0:ipv4_interface sis0:' \
-e 's:ipv6_interface sixxs:ipv6_interface gif0:' \
- ${WRKSRC}/doc/aiccu.conf > ${WRKDIR}/aiccu.conf
+ ${WRKSRC}/doc/aiccu.conf
do-install:
- @${MKDIR} ${DOCSDIR} ${EXAMPLESDIR}
+ ${MKDIR} ${DOCSDIR}
${INSTALL_PROGRAM} ${WRKSRC}/unix-console/aiccu ${PREFIX}/sbin/sixxs-aiccu
${INSTALL_DATA} ${WRKSRC}/doc/README ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/doc/aiccu.conf ${EXAMPLESDIR}
- ${INSTALL_DATA} ${WRKDIR}/aiccu.conf ${PREFIX}/etc/aiccu.conf.sample
- ${INSTALL_SCRIPT} ${WRKDIR}/sixxs-aiccu.sh ${PREFIX}/etc/rc.d
+ ${INSTALL_DATA} ${WRKSRC}/doc/aiccu.conf ${PREFIX}/etc/aiccu.conf.sample
+.if !exists(${PREFIX}/etc/aiccu.conf)
+ ${INSTALL_DATA} ${WRKSRC}/doc/aiccu.conf ${PREFIX}/etc/aiccu.conf
+.endif
.include <bsd.port.mk>
diff --git a/net/sixxs-aiccu/distinfo b/net/sixxs-aiccu/distinfo
index 61d1ccc06969..18bddeb90c56 100644
--- a/net/sixxs-aiccu/distinfo
+++ b/net/sixxs-aiccu/distinfo
@@ -1,3 +1,3 @@
-MD5 (aiccu_2005.01.31.tar.gz) = 7c3da5feab3d59fb5a99a45203e0ca56
-SHA256 (aiccu_2005.01.31.tar.gz) = 1baac8fb62490e480efa8b5b6b3b4d3d9c19876316456e4b6ada2cec0c36bc88
-SIZE (aiccu_2005.01.31.tar.gz) = 45672
+MD5 (aiccu_2006.07.25.tar.gz) = 0df76e92eb34f4ce8aa3cfcf6896f271
+SHA256 (aiccu_2006.07.25.tar.gz) = ce735aced6d18594a726c9b027ddc80ca1ff658f6e436c530b60779f2dc5d4df
+SIZE (aiccu_2006.07.25.tar.gz) = 64161
diff --git a/net/sixxs-aiccu/files/patch-common_tun.c b/net/sixxs-aiccu/files/patch-common_tun.c
new file mode 100644
index 000000000000..50dbc717e8fe
--- /dev/null
+++ b/net/sixxs-aiccu/files/patch-common_tun.c
@@ -0,0 +1,21 @@
+--- common/tun.c.orig Tue Jul 25 02:20:46 2006
++++ common/tun.c Thu Nov 30 02:02:05 2006
+@@ -703,9 +703,7 @@
+
+ char buf[128];
+ unsigned int i;
+-#ifndef _FREEBSD
+ int mode = IFF_MULTICAST | IFF_POINTOPOINT;
+-#endif
+
+ /* Try the configured interface */
+ tun_log(LOG_DEBUG, "start", "Trying Configured TUN/TAP interface %s...\n", g_aiccu->ipv6_interface);
+@@ -752,7 +750,7 @@
+ #endif
+ #endif
+
+-#ifdef _DFBSD
++#ifdef NEED_IFHEAD
+ tun_log(LOG_DEBUG, "start", "Setting TUNSIFHEAD for %s\n", g_aiccu->ipv6_interface);
+ mode = 1;
+ if (ioctl(tun_fd, TUNSIFHEAD, &mode, sizeof(mode)) == -1)
diff --git a/net/sixxs-aiccu/files/patch-unix-console::Makefile b/net/sixxs-aiccu/files/patch-unix-console::Makefile
index cde772c959e2..db3697d0fd06 100644
--- a/net/sixxs-aiccu/files/patch-unix-console::Makefile
+++ b/net/sixxs-aiccu/files/patch-unix-console::Makefile
@@ -1,32 +1,35 @@
---- unix-console/Makefile.orig Mon Jan 31 19:59:30 2005
-+++ unix-console/Makefile Sun Mar 13 16:42:00 2005
-@@ -37,7 +37,7 @@
- CFLAGS += -D AICCU_TYPE="\"freebsd4\""
+--- unix-console/Makefile.orig Tue Jul 25 11:20:48 2006
++++ unix-console/Makefile Sat Dec 30 20:19:04 2006
+@@ -21,7 +21,7 @@
+ #INCS += ../common/tsp.h ../common/teepee.h
+
+ # Our very *bliep* set of options to make sure that these things can't cause any issues
+-CWARNS += -W -Wall -Wshadow -Wpointer-arith -Wcast-align -Wwrite-strings -Waggregate-return -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations -Wredundant-decls -Wnested-externs -Winline -Wbad-function-cast -fshort-enums -fstrict-aliasing -fno-common -Wpadded -pedantic -pthread -D_REENTRANT
++#CWARNS += -W -Wall -Wshadow -Wpointer-arith -Wcast-align -Wwrite-strings -Waggregate-return -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations -Wredundant-decls -Wnested-externs -Winline -Wbad-function-cast -fshort-enums -fstrict-aliasing -fno-common -Wpadded -pedantic -pthread -D_REENTRANT
+ # CWARNS += -Wpacked
+
+ #CFLAGS += $(CWARNS) -D_GNU_SOURCE -D_DEBUG -g3 -O0
+@@ -62,19 +62,19 @@
+ CFLAGS += -D AICCU_TYPE="\"freebsd4\""
SRCS += ../common/aiccu_freebsd4.c
OBJS += ../common/aiccu_freebsd4.o
-CFLAGS += -pthread
+#CFLAGS += -pthread
- endif
-
- # FreeBSD 5.x
-@@ -45,7 +45,19 @@
- CFLAGS += -D AICCU_TYPE="\"kame\""
+ else
+ # FreeBSD 5.x/6.x/7.x
+-CFLAGS += -D AICCU_TYPE="\"kame\""
++CFLAGS += -D NEED_IFHEAD -D AICCU_TYPE="\"kame\""
SRCS += ../common/aiccu_kame.c
OBJS += ../common/aiccu_kame.o
-CFLAGS += -pthread
+#CFLAGS += -pthread
-+endif
-+# FreeBSD 6.x
-+ifeq ($(shell uname -r | cut -c 1),6)
-+CFLAGS += -D AICCU_TYPE="\"kame\""
-+SRCS += ../common/aiccu_kame.c
-+OBJS += ../common/aiccu_kame.o
-+endif
-+# FreeBSD 7.x
-+ifeq ($(shell uname -r | cut -c 1),7)
-+CFLAGS += -D AICCU_TYPE="\"kame\""
-+SRCS += ../common/aiccu_kame.c
-+OBJS += ../common/aiccu_kame.o
endif
endif
+ # DragonFlyBSD
+ ifeq ($(shell uname | grep -c "DragonFly"),1)
+-CFLAGS += -D _DFBSD -D AICCU_TYPE="\"dragonfly\""
++CFLAGS += -D _DFBSD -D NEED_IFHEAD -D AICCU_TYPE="\"dragonfly\""
+ SRCS += ../common/aiccu_freebsd4.c
+ OBJS += ../common/aiccu_freebsd4.o
+ CFLAGS += -pthread
diff --git a/net/sixxs-aiccu/files/sixxs-aiccu.sh b/net/sixxs-aiccu/files/sixxs-aiccu.in
index b4eb89dc4a26..b4eb89dc4a26 100644
--- a/net/sixxs-aiccu/files/sixxs-aiccu.sh
+++ b/net/sixxs-aiccu/files/sixxs-aiccu.in
diff --git a/net/sixxs-aiccu/pkg-plist b/net/sixxs-aiccu/pkg-plist
index 3e6e31bb1b7b..1bf27351aad3 100644
--- a/net/sixxs-aiccu/pkg-plist
+++ b/net/sixxs-aiccu/pkg-plist
@@ -1,5 +1,4 @@
+@unexec if cmp -s %D/etc/aiccu.conf %D/etc/aiccu.conf.sample; then rm -f %D/etc/aiccu.conf; fi
etc/aiccu.conf.sample
-etc/rc.d/sixxs-aiccu.sh
+@exec [ -f %B/aiccu.conf ] || cp %B/%f %B/aiccu.conf
sbin/sixxs-aiccu
-%%EXAMPLESDIR%%/aiccu.conf
-@dirrm %%EXAMPLESDIR%%