aboutsummaryrefslogtreecommitdiff
path: root/net/sixxs-aiccu
diff options
context:
space:
mode:
authorVolker Stolz <vs@FreeBSD.org>2005-03-14 17:47:08 +0000
committerVolker Stolz <vs@FreeBSD.org>2005-03-14 17:47:08 +0000
commiteca0d38d13e7aa54bbd5793ab66f0db767e83fa7 (patch)
tree1e2c7c509c1bab27a4c4bd0657785fe7bd52a5d2 /net/sixxs-aiccu
parent88363abf0a3780ff88acce2e5fb3716ea3bdd0de (diff)
downloadports-eca0d38d13e7aa54bbd5793ab66f0db767e83fa7.tar.gz
ports-eca0d38d13e7aa54bbd5793ab66f0db767e83fa7.zip
Notes
Diffstat (limited to 'net/sixxs-aiccu')
-rw-r--r--net/sixxs-aiccu/Makefile49
-rw-r--r--net/sixxs-aiccu/distinfo2
-rw-r--r--net/sixxs-aiccu/files/patch-unix-console::Makefile26
-rw-r--r--net/sixxs-aiccu/files/sixxs-aiccu.sh30
-rw-r--r--net/sixxs-aiccu/pkg-descr4
-rw-r--r--net/sixxs-aiccu/pkg-plist5
6 files changed, 116 insertions, 0 deletions
diff --git a/net/sixxs-aiccu/Makefile b/net/sixxs-aiccu/Makefile
new file mode 100644
index 000000000000..e8112541d34e
--- /dev/null
+++ b/net/sixxs-aiccu/Makefile
@@ -0,0 +1,49 @@
+# New ports collection makefile for: sixxs-aiccu
+# Date created: 2004-09-07
+# Whom: Meno Abels <meno.abels@adviser.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= sixxs-aiccu
+PORTVERSION= 20050131
+CATEGORIES= net ipv6
+MASTER_SITES= http://www.sixxs.net/archive/sixxs/aiccu/unix/
+DISTNAME= aiccu_2005.01.31
+
+MAINTAINER= meno.abels@adviser.com
+COMMENT= SixXS IPv6 TIC+ tunnel broker heartbeat client
+
+USE_RC_SUBR= yes
+USE_GMAKE= yes
+CFLAGS+= ${PTHREAD_CFLAGS}
+LDFLAGS+= ${PTHREAD_LIBS}
+MAKE_ARGS= CC="${CC}"
+MAKE_ENV= CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
+WRKSRC= ${WRKDIR}/aiccu
+BUILD_WRKSRC= ${WRKDIR}/aiccu/unix-console
+
+PORTDOCS= README
+
+pre-build:
+ @${SED} -e 's:%%PREFIX%%:${PREFIX}:g' \
+ -e 's:%%RC_SUBR%%:${RC_SUBR}:g' \
+ ${FILESDIR}/sixxs-aiccu.sh >${WRKDIR}/sixxs-aiccu.sh
+ @${SED} \
+ -e 's:verbose true:verbose false:' \
+ -e 's:daemonize false:daemonize true:' \
+ -e 's:automatic false:automatic true:' \
+ -e 's:tunnel_id T2995:#tunnel_id TXXXX:' \
+ -e 's:ipv4_interface eth0:ipv4_interface sis0:' \
+ -e 's:ipv6_interface sixxs:ipv6_interface gif0:' \
+ ${WRKSRC}/doc/aiccu.conf > ${WRKDIR}/aiccu.conf
+
+do-install:
+ @${MKDIR} ${DOCSDIR} ${EXAMPLESDIR}
+ ${INSTALL_PROGRAM} ${WRKSRC}/unix-console/aiccu ${PREFIX}/sbin/sixxs-aiccu
+ ${INSTALL_DATA} ${WRKSRC}/doc/README ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/doc/aiccu.conf ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKDIR}/aiccu.conf ${PREFIX}/etc/aiccu.conf.sample
+ ${INSTALL_SCRIPT} ${WRKDIR}/sixxs-aiccu.sh ${PREFIX}/etc/rc.d
+
+.include <bsd.port.mk>
diff --git a/net/sixxs-aiccu/distinfo b/net/sixxs-aiccu/distinfo
new file mode 100644
index 000000000000..98ed3bca776a
--- /dev/null
+++ b/net/sixxs-aiccu/distinfo
@@ -0,0 +1,2 @@
+MD5 (aiccu_2005.01.31.tar.gz) = 7c3da5feab3d59fb5a99a45203e0ca56
+SIZE (aiccu_2005.01.31.tar.gz) = 45672
diff --git a/net/sixxs-aiccu/files/patch-unix-console::Makefile b/net/sixxs-aiccu/files/patch-unix-console::Makefile
new file mode 100644
index 000000000000..823dbc78d203
--- /dev/null
+++ b/net/sixxs-aiccu/files/patch-unix-console::Makefile
@@ -0,0 +1,26 @@
+--- unix-console/Makefile.orig Mon Jan 31 19:59:30 2005
++++ unix-console/Makefile Sun Mar 13 16:42:00 2005
+@@ -37,7 +37,7 @@
+ CFLAGS += -D AICCU_TYPE="\"freebsd4\""
+ SRCS += ../common/aiccu_freebsd4.c
+ OBJS += ../common/aiccu_freebsd4.o
+-CFLAGS += -pthread
++#CFLAGS += -pthread
+ endif
+
+ # FreeBSD 5.x
+@@ -45,7 +45,13 @@
+ CFLAGS += -D AICCU_TYPE="\"kame\""
+ SRCS += ../common/aiccu_kame.c
+ OBJS += ../common/aiccu_kame.o
+-CFLAGS += -pthread
++#CFLAGS += -pthread
++endif
++# FreeBSD 6.x
++ifeq ($(shell uname -r | cut -c 1),6)
++CFLAGS += -D AICCU_TYPE="\"kame\""
++SRCS += ../common/aiccu_kame.c
++OBJS += ../common/aiccu_kame.o
+ endif
+ endif
+
diff --git a/net/sixxs-aiccu/files/sixxs-aiccu.sh b/net/sixxs-aiccu/files/sixxs-aiccu.sh
new file mode 100644
index 000000000000..b7ddbac22c08
--- /dev/null
+++ b/net/sixxs-aiccu/files/sixxs-aiccu.sh
@@ -0,0 +1,30 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+
+# PROVIDE: sixxs-aiccu
+# REQUIRE: NETWORKING
+# KEYWORD: FreeBSD
+
+#
+# Add the following lines to /etc/rc.conf to enable sixxs-aiccu:
+#
+#sixxs_aiccu_enable="YES"
+#
+
+. %%RC_SUBR%%
+
+name=sixxs_aiccu
+rcvar=`set_rcvar`
+
+command="%%PREFIX%%/sbin/sixxs-aiccu start"
+command_args=%%PREFIX%%/etc/aiccu.conf
+stop_cmd="%%PREFIX%%/sbin/sixxs-aiccu stop"
+required_files=%%PREFIX%%/etc/aiccu.conf
+
+# set default
+sixxs_aiccu_enable=${sixxs_aiccu_enable:-"NO"}
+
+load_rc_config ${name}
+run_rc_command "$1"
diff --git a/net/sixxs-aiccu/pkg-descr b/net/sixxs-aiccu/pkg-descr
new file mode 100644
index 000000000000..1cd61d4f13c4
--- /dev/null
+++ b/net/sixxs-aiccu/pkg-descr
@@ -0,0 +1,4 @@
+This is the TIC+ heartbeart client for the public dynamic-IPv4
+IPv6 tunnel beta test from the SixXS tunnel service provider.
+
+WWW: http://www.sixxs.net/tools/aiccu/
diff --git a/net/sixxs-aiccu/pkg-plist b/net/sixxs-aiccu/pkg-plist
new file mode 100644
index 000000000000..3e6e31bb1b7b
--- /dev/null
+++ b/net/sixxs-aiccu/pkg-plist
@@ -0,0 +1,5 @@
+etc/aiccu.conf.sample
+etc/rc.d/sixxs-aiccu.sh
+sbin/sixxs-aiccu
+%%EXAMPLESDIR%%/aiccu.conf
+@dirrm %%EXAMPLESDIR%%