aboutsummaryrefslogtreecommitdiff
path: root/net/slbd/Makefile
diff options
context:
space:
mode:
authorIon-Mihai Tetcu <itetcu@FreeBSD.org>2006-11-10 21:07:55 +0000
committerIon-Mihai Tetcu <itetcu@FreeBSD.org>2006-11-10 21:07:55 +0000
commit9b90b3ca6e3bcc4eb73a4ad9e770745eae9000dd (patch)
tree0fbce9088a9aa0761d995474bde80943b6c0c44c /net/slbd/Makefile
parentfac5fb047a6ec890b37dc5723ae533a2012da7ec (diff)
Notes
Diffstat (limited to 'net/slbd/Makefile')
-rw-r--r--net/slbd/Makefile36
1 files changed, 36 insertions, 0 deletions
diff --git a/net/slbd/Makefile b/net/slbd/Makefile
new file mode 100644
index 000000000000..b1f0d53e4822
--- /dev/null
+++ b/net/slbd/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: slbd
+# Date created: 30 October 2006
+# Whom: Janos Mohacsi <janos.mohacsi@bsd.hu>
+#
+# $FreeBSD$
+#
+
+PORTNAME= slbd
+PORTVERSION= 1.3
+CATEGORIES= net sysutils
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= janos.mohacsi@bsd.hu
+COMMENT= Server load balancing daemon for *BSD pf
+
+PLIST_FILES= sbin/slbd etc/slbdcap-sample
+PORTDOCS= configfile.txt
+
+post-patch:
+ @${REINPLACE_CMD} -e "s;%%PREFIX%%;${PREFIX};g" \
+ ${WRKSRC}/Makefile
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ cd ${WRKSRC}/doc && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}
+.endif
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 502106
+IGNORE= is of no use for you because your system is too old and doesn't have pf
+.endif
+
+.include <bsd.port.post.mk>