aboutsummaryrefslogtreecommitdiff
path: root/net/smbldap-tools
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-05-25 21:19:26 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-05-25 21:19:26 +0000
commit248f0aeb93c0a1d5a3ef8c73349b40115c880b53 (patch)
tree26b98616af807a65f7224b79c478af8bceaaff59 /net/smbldap-tools
parentffc37a5aefde3cbaf995bae9ff182d3976223325 (diff)
downloadports-248f0aeb93c0a1d5a3ef8c73349b40115c880b53.tar.gz
ports-248f0aeb93c0a1d5a3ef8c73349b40115c880b53.zip
Notes
Diffstat (limited to 'net/smbldap-tools')
-rw-r--r--net/smbldap-tools/Makefile44
-rw-r--r--net/smbldap-tools/distinfo2
-rw-r--r--net/smbldap-tools/pkg-descr12
-rw-r--r--net/smbldap-tools/pkg-plist19
4 files changed, 77 insertions, 0 deletions
diff --git a/net/smbldap-tools/Makefile b/net/smbldap-tools/Makefile
new file mode 100644
index 000000000000..409c63f4231b
--- /dev/null
+++ b/net/smbldap-tools/Makefile
@@ -0,0 +1,44 @@
+# New ports collection makefile for: smbldap-tools
+# Date created: May 8 2004
+# Whom: Florent Thoumie <flz@xbsd.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= smbldap-tools
+PORTVERSION= 0.8.4
+CATEGORIES= net
+MASTER_SITES= http://www.idealx.org/prj/samba/dist/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= flz@xbsd.org
+COMMENT= Useful package for managing users and groups in a LDAP directory
+
+BUILD_DEPENDS= ${SITE_PERL}/Net/LDAP.pm:${PORTSDIR}/net/p5-perl-ldap
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+USE_PERL5= yes
+NO_BUILD= yes
+USE_REINPLACE= yes
+
+post-patch:
+ ${REINPLACE_CMD} -e 's#/etc/samba#${PREFIX}/etc/samba#' ${WRKSRC}/configure.pl \
+ ${WRKSRC}/smb.conf
+ ${REINPLACE_CMD} -e 's#/etc/smb#${PREFIX}/etc/smb#' ${WRKSRC}/configure.pl \
+ ${WRKSRC}/smbldap.conf \
+ ${WRKSRC}/smbldap_tools.pm
+
+do-install:
+ ${MKDIR} ${EXAMPLESDIR}
+ ${MKDIR} ${PREFIX}/etc/${PORTNAME}
+ ${INSTALL_SCRIPT} ${WRKSRC}/configure.pl ${PREFIX}/etc/${PORTNAME}/
+.for i in smbldap.conf smbldap_bind.conf
+ ${INSTALL_DATA} ${WRKSRC}/$i ${PREFIX}/etc/${PORTNAME}/$i.default
+.endfor
+.for i in smbldap-groupadd smbldap-groupdel smbldap-groupmod smbldap-groupshow smbldap-useradd smbldap-userdel smbldap-usermod smbldap-usershow smbldap-migrate-accounts smbldap-migrate-groups smbldap-passwd smbldap-populate
+ ${INSTALL_SCRIPT} ${WRKSRC}/$i ${PREFIX}/sbin
+.endfor
+ ${INSTALL_DATA} ${WRKSRC}/smbldap_tools.pm ${SITE_PERL}/
+ ${INSTALL_DATA} ${WRKSRC}/smb.conf ${EXAMPLESDIR}/
+
+.include <bsd.port.mk>
diff --git a/net/smbldap-tools/distinfo b/net/smbldap-tools/distinfo
new file mode 100644
index 000000000000..8c603e080531
--- /dev/null
+++ b/net/smbldap-tools/distinfo
@@ -0,0 +1,2 @@
+MD5 (smbldap-tools-0.8.4.tgz) = 34ef159fc49a2c30ff27b481dc8e1215
+SIZE (smbldap-tools-0.8.4.tgz) = 286290
diff --git a/net/smbldap-tools/pkg-descr b/net/smbldap-tools/pkg-descr
new file mode 100644
index 000000000000..34854b7bfc7e
--- /dev/null
+++ b/net/smbldap-tools/pkg-descr
@@ -0,0 +1,12 @@
+A collection of scripts, "over" user{add,del,mod} and group{add,del,mod}
+system tools to manipulate users and groups stored in LDAP directory,
+for DEN system like SAMBA-LDAP and pam/nss_ldap systems.
+
+Additionnaly, some scripts are designed to ease your migration from
+a Windows NT 4.0 PDC Server to a Samba-LDAP PDC Server (Killer?;-):
+smbldap-populate, smbldap-migrate-groups, smbldap-migrate-accounts.
+
+WWW: http://samba.idealx.org/
+
+- Florent Thoumie
+flz@xbsd.org
diff --git a/net/smbldap-tools/pkg-plist b/net/smbldap-tools/pkg-plist
new file mode 100644
index 000000000000..d4c93d0002ac
--- /dev/null
+++ b/net/smbldap-tools/pkg-plist
@@ -0,0 +1,19 @@
+etc/smbldap-tools/configure.pl
+etc/smbldap-tools/smbldap.conf.default
+etc/smbldap-tools/smbldap_bind.conf.default
+sbin/smbldap-groupadd
+sbin/smbldap-groupdel
+sbin/smbldap-groupmod
+sbin/smbldap-groupshow
+sbin/smbldap-migrate-accounts
+sbin/smbldap-migrate-groups
+sbin/smbldap-passwd
+sbin/smbldap-populate
+sbin/smbldap-useradd
+sbin/smbldap-userdel
+sbin/smbldap-usermod
+sbin/smbldap-usershow
+%%EXAMPLESDIR%%/smb.conf
+%%SITE_PERL%%/smbldap_tools.pm
+@dirrm etc/smbldap-tools
+@dirrm %%EXAMPLESDIR%%