aboutsummaryrefslogtreecommitdiff
path: root/net/smbldap-tools
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2006-07-19 07:55:41 +0000
committerMartin Wilke <miwi@FreeBSD.org>2006-07-19 07:55:41 +0000
commit80ae2644da64e187f6dbf47d5b85461142a0bf76 (patch)
treefce0ef3de05182bf023af9e607338795ce8cc159 /net/smbldap-tools
parent3547dddfb748542f3719135e650f7174c58abc27 (diff)
downloadports-80ae2644da64e187f6dbf47d5b85461142a0bf76.tar.gz
ports-80ae2644da64e187f6dbf47d5b85461142a0bf76.zip
Notes
Diffstat (limited to 'net/smbldap-tools')
-rw-r--r--net/smbldap-tools/Makefile11
-rw-r--r--net/smbldap-tools/distinfo6
-rw-r--r--net/smbldap-tools/files/patch-configure.pl35
3 files changed, 46 insertions, 6 deletions
diff --git a/net/smbldap-tools/Makefile b/net/smbldap-tools/Makefile
index 9bdcb133820b..f50a4faf6030 100644
--- a/net/smbldap-tools/Makefile
+++ b/net/smbldap-tools/Makefile
@@ -6,9 +6,10 @@
#
PORTNAME= smbldap-tools
-PORTVERSION= 0.9.2
+PORTVERSION= 0.9.2a
CATEGORIES= net
-MASTER_SITES= http://www.idealx.com/downloads/
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
EXTRACT_SUFX= .tgz
MAINTAINER= miwi@FreeBSD.org
@@ -17,9 +18,12 @@ COMMENT= Useful package for managing users and groups in a LDAP directory
BUILD_DEPENDS= ${SITE_PERL}/Net/LDAP.pm:${PORTSDIR}/net/p5-perl-ldap \
${SITE_PERL}/Crypt/SmbHash.pm:${PORTSDIR}/security/p5-Crypt-SmbHash \
${SITE_PERL}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5 \
- ${SITE_PERL}/${PERL_ARCH}/Digest/SHA1.pm:${PORTSDIR}/security/p5-Digest-SHA1
+ ${SITE_PERL}/${PERL_ARCH}/Digest/SHA1.pm:${PORTSDIR}/security/p5-Digest-SHA1 \
+ ${SITE_PERL}/${PERL_ARCH}/Unicode/Map8.pm:${PORTSDIR}/converters/p5-Unicode-MapUTF8
RUN_DEPENDS= ${BUILD_DEPENDS}
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION:C/a//}
+
USE_PERL5= yes
NO_BUILD= yes
@@ -32,6 +36,7 @@ DOC_HTML_LIST = contents_motif.gif index.html next_motif.gif \
smbldap-tools010.html
post-patch:
+ @${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|g' ${WRKSRC}/configure.pl
@${PERL} -pi -e 's#/etc/samba#${PREFIX}/etc#' ${WRKSRC}/configure.pl \
${WRKSRC}/smb.conf \
${WRKSRC}/smbldap_tools.pm
diff --git a/net/smbldap-tools/distinfo b/net/smbldap-tools/distinfo
index 9ac0b85d907a..5478a4dbcf36 100644
--- a/net/smbldap-tools/distinfo
+++ b/net/smbldap-tools/distinfo
@@ -1,3 +1,3 @@
-MD5 (smbldap-tools-0.9.2.tgz) = bb8eb44adb4e7946de5b486acf480c24
-SHA256 (smbldap-tools-0.9.2.tgz) = 2f85c86f6ad03be7f64308529f493a730be01e90a97bb8b75ece8608bcfea992
-SIZE (smbldap-tools-0.9.2.tgz) = 299341
+MD5 (smbldap-tools-0.9.2a.tgz) = bb8eb44adb4e7946de5b486acf480c24
+SHA256 (smbldap-tools-0.9.2a.tgz) = 2f85c86f6ad03be7f64308529f493a730be01e90a97bb8b75ece8608bcfea992
+SIZE (smbldap-tools-0.9.2a.tgz) = 299341
diff --git a/net/smbldap-tools/files/patch-configure.pl b/net/smbldap-tools/files/patch-configure.pl
new file mode 100644
index 000000000000..5962d3a1d698
--- /dev/null
+++ b/net/smbldap-tools/files/patch-configure.pl
@@ -0,0 +1,35 @@
+--- configure.pl.orgi Wed Jul 12 18:36:29 2006
++++ configure.pl Wed Jul 12 18:40:30 2006
+@@ -49,7 +49,7 @@
+ print "-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-\n";
+
+ # we first check if Samba is up and running
+-my $test_smb=`pidof smbd`;
++my $test_smb=`pgrep -x smbd`;
+ chomp($test_smb);
+ die "\nSamba need to be started first !\n" if ($test_smb eq "" || not defined $test_smb);
+
+@@ -304,7 +304,7 @@
+
+ my $default_computer_gidnumber=read_entry(". default computer gidNumber","","515",0);
+
+-my $userLoginShell=read_entry(". default login shell","","/bin/bash",0);
++my $userLoginShell=read_entry(". default login shell","","/bin/sh",0);
+
+ my $skeletonDir=read_entry(". default skeleton directory","","/etc/skel",0);
+
+@@ -528,12 +528,12 @@
+ # Allows not to use smbpasswd (if with_smbpasswd == 0 in smbldap_conf.pm) but
+ # prefer Crypt::SmbHash library
+ with_smbpasswd=\"0\"
+-smbpasswd=\"/usr/bin/smbpasswd\"
++smbpasswd=\"%%LOCALBASE%%/bin/smbpasswd\"
+
+ # Allows not to use slappasswd (if with_slappasswd == 0 in smbldap_conf.pm)
+ # but prefer Crypt:: libraries
+ with_slappasswd=\"0\"
+-slappasswd=\"/usr/sbin/slappasswd\"
++slappasswd=\"%%LOCALBASE%%/sbin/slappasswd\"
+
+ # comment out the following line to get rid of the default banner
+ # no_banner=\"1\"