aboutsummaryrefslogtreecommitdiff
path: root/net/smm++/files
diff options
context:
space:
mode:
authorKevin Lo <kevlo@FreeBSD.org>2001-07-15 15:24:10 +0000
committerKevin Lo <kevlo@FreeBSD.org>2001-07-15 15:24:10 +0000
commit4ea7dd38ba026e4fbb006edcbcb8ad12e2dad9fe (patch)
tree2fffc9191325084f5cd7c56014fe9603cd111299 /net/smm++/files
parent65e9bc8d84654c95b8e1bfd9e563507e674135f0 (diff)
Notes
Diffstat (limited to 'net/smm++/files')
-rw-r--r--net/smm++/files/patch-Makefile44
-rw-r--r--net/smm++/files/patch-a68
-rw-r--r--net/smm++/files/patch-b29
-rw-r--r--net/smm++/files/patch-c17
-rw-r--r--net/smm++/files/patch-d8
-rw-r--r--net/smm++/files/patch-itk.sh46
6 files changed, 90 insertions, 122 deletions
diff --git a/net/smm++/files/patch-Makefile b/net/smm++/files/patch-Makefile
new file mode 100644
index 000000000000..288644e9fdb0
--- /dev/null
+++ b/net/smm++/files/patch-Makefile
@@ -0,0 +1,44 @@
+--- /home/edwin/smm5r0/Install.unix/Makefile Fri Jun 15 07:05:56 2001
++++ Makefile Sun Jul 15 19:20:06 2001
+@@ -12,7 +12,7 @@
+ # usual unix environment (if you have root access).
+ BIN=/usr/local/bin
+ SRC=/usr/local/lib/smm
+-DOC=/usr/local/doc/smm
++DOC=/usr/local/share/doc/smm
+
+ # --- If you don't have root access, you could choose to install
+ # SMM++ locally in your home directory. Therefore use the
+@@ -60,6 +60,8 @@
+ # this Makefile. If you can read Makefiles, feel free
+ # to do whatever you like.
+
++all: smm
++
+ smm: Makefile
+ @echo "--- Building startup file."
+ @if [ -z ${ITKWISH} ] ; then \
+@@ -89,9 +91,9 @@
+ install-src:
+ @echo "--- Installing libraries to ${SRC}."
+ @install -d ${SRC}
+- @cp -au ../sources/ ${SRC}
+- @cp -au ../images/ ${SRC}
+- @cp -au ../config/ ${SRC}
++ @cp -Rp ../sources ${SRC}
++ @cp -Rp ../images ${SRC}
++ @cp -Rp ../config ${SRC}
+ uninstall-src:
+ @echo "--- Uninstalling libraries from ${SRC}."
+ @rm -rf ${SRC}
+@@ -100,8 +102,8 @@
+ @echo " Documentation is installed in ${DOC}."
+ @echo " The html manual starts at file:${DOC}/man/index.html."
+ @install -d ${DOC}
+- @cp -au ../docu/* ${DOC}
+- @cp -au ../man/ ${DOC}
++ @cp -Rp ../docu/* ${DOC}
++ @cp -Rp ../man/ ${DOC}
+ uninstall-doc:
+ @echo "--- Uninstalling documentation from ${DOC}."
+ @rm -rf ${DOC}
diff --git a/net/smm++/files/patch-a b/net/smm++/files/patch-a
deleted file mode 100644
index c5980f421ed1..000000000000
--- a/net/smm++/files/patch-a
+++ /dev/null
@@ -1,68 +0,0 @@
---- /usr/ports/games/smm++/work/smm4r4/bin/ia.tcl Fri Jan 28 08:28:57 2000
-+++ bin/ia.tcl Thu Nov 16 19:06:25 2000
-@@ -1,4 +1,4 @@
--#!/usr/bin/itkwish
-+#!/usr/local/bin/itkwish
-
- proc a {} {
- set c1 [clock seconds]
---- /usr/ports/games/smm++/work/smm4r4/bin/install.tcl Sun Dec 19 12:45:38 1999
-+++ bin/install.tcl Thu Nov 16 19:06:05 2000
-@@ -29,9 +29,9 @@
-
- }
-
--set itkwish "/usr/bin/itkwish"
-+set itkwish "/usr/local/bin/itkwish"
- set userdir "\$env(HOME)/.smm"
--set srcdir "/usr/local/smm3r3"
-+set srcdir "/usr/local/smm++"
-
- iwidgets::entryfield .itkwish -labeltext "itkwish executable:" \
- -labelpos nw -textvariable itkwish \
---- /usr/ports/games/smm++/work/smm4r4/bin/istest.tcl Fri Jan 28 06:51:26 2000
-+++ bin/istest.tcl Thu Nov 16 19:06:28 2000
-@@ -1,4 +1,4 @@
--#!/usr/bin/itkwish
-+#!/usr/local/bin/itkwish
-
- proc a {} {
- set CImagePath images
---- /usr/ports/games/smm++/work/smm4r4/bin/o.tcl Sat Dec 25 05:01:32 1999
-+++ bin/o.tcl Thu Nov 16 19:06:15 2000
-@@ -1,4 +1,4 @@
--#!/usr/bin/itkwish
-+#!/usr/local/bin/itkwish
-
- package require Iwidgets 3.0
-
-@@ -41,4 +41,4 @@
- }
- set en [clock seconds]
-
--puts "[expr $en-$st] seconds -> [expr ($en.0-$st.0)/1000.0] turns/sec"
-+puts "[expr $en-$st] seconds -> [expr ($en.0-$st.0)/1000.0] turns/sec"
---- /usr/ports/games/smm++/work/smm4r4/bin/ssmm Thu May 4 19:40:23 2000
-+++ bin/ssmm Thu Nov 16 19:06:12 2000
-@@ -1,4 +1,4 @@
--#!/usr/bin/itkwish
-+#!/usr/local/bin/itkwish
- # ### THIS IS MY PERSONAL STARTUPFILE, ##################
- # ### SO DONT BOTHER ABOUT IT #########################
- # !!! and dont use it !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
---- /usr/ports/games/smm++/work/smm4r4/bin/sssm Thu May 4 19:40:29 2000
-+++ bin/sssm Thu Nov 16 19:06:19 2000
-@@ -1,4 +1,4 @@
--#!/usr/bin/itkwish
-+#!/usr/local/bin/itkwish
- # ### THIS IS MY PERSONAL STARTUPFILE, ##################
- # ### SO DONT BOTHER ABOUT IT #########################
- # !!! and dont use it !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
---- /usr/ports/games/smm++/work/smm4r4/bin/tester.tcl Fri Dec 31 23:52:07 1999
-+++ bin/tester.tcl Thu Nov 16 19:06:21 2000
-@@ -1,4 +1,4 @@
--#!/usr/bin/itkwish
-+#!/usr/local/bin/itkwish
-
- set SMMSRCPATH /home/issever/HOME/privat/programming/smm4r3
- lappend auto_path [file join $SMMSRCPATH sources]
diff --git a/net/smm++/files/patch-b b/net/smm++/files/patch-b
deleted file mode 100644
index cfce53fb69d5..000000000000
--- a/net/smm++/files/patch-b
+++ /dev/null
@@ -1,29 +0,0 @@
---- /usr/ports/games/smm++/work/smm4r4/docu/INSTALL.unix Sun Dec 19 13:45:24 1999
-+++ docu/INSTALL.unix Thu Nov 16 19:07:29 2000
-@@ -99,7 +99,7 @@
- 'which itkwish' typed in in the shell gives you the answer, if
- you dont know it already. Sometimes 'locate itkwish' may help,
- if itkwish isnt along $PATH.
-- e.g. /usr/bin/itkwish (default)
-+ e.g. /usr/local/bin/itkwish (default)
-
-
- From now on I'll explain the installation taking the default values
-@@ -114,7 +114,7 @@
- to save diskspace.
- 5. cd smmxxx
- 6. now edit the file 'smm'
-- a) first line: #!/usr/bin/itkwish
-+ a) first line: #!/usr/local/bin/itkwish
- put in here the right path to itkwish
- b) line: set SMMPATH $env(HOME)/.smm
- put in here the path, where the user data should be stored.
-@@ -162,7 +162,7 @@
- everything should work OK.
-
- The first line in 'smm' should look like:
--#!/usr/bin/itkwish
-+#!/usr/local/bin/itkwish
-
- here the path /usr/bin may be wrong.
-
diff --git a/net/smm++/files/patch-c b/net/smm++/files/patch-c
deleted file mode 100644
index f552662bab01..000000000000
--- a/net/smm++/files/patch-c
+++ /dev/null
@@ -1,17 +0,0 @@
---- /usr/ports/games/smm++/work/smm4r4/smm Thu Nov 16 20:57:31 2000
-+++ smm Thu Nov 16 21:12:38 2000
-@@ -1,4 +1,4 @@
--#!/usr/bin/itkwish
-+#!/usr/local/bin/itkwish
- # --> you may have to edit the line above of this line
- # !!! you may edit the path, BUT DO NOT remove the '#!'
- # !!! the '#!' must be the FIRST CHARACTERS on
-@@ -13,7 +13,7 @@
- set SMMPATH $env(HOME)/.smm
- #
- # The path to the smm sources
--set SMMSRCPATH /usr/local/smm4r4
-+set SMMSRCPATH /usr/local/smm++
- #
- # set SMMMAPWINDOW to 1, if you want the mapper in a separate window
- # set SMMMAPWINDOW to 0, if you want the mapper to be integrated
diff --git a/net/smm++/files/patch-d b/net/smm++/files/patch-d
deleted file mode 100644
index b1e09d7b77dd..000000000000
--- a/net/smm++/files/patch-d
+++ /dev/null
@@ -1,8 +0,0 @@
---- Makefile Thu Nov 16 21:16:06 2000
-+++ /usr/ports/games/smm++/work/smm4r4/Makefile Thu Nov 16 21:09:02 2000
-@@ -0,0 +1,5 @@
-+install:
-+ mkdir /usr/local/smm++
-+ cp -r * /usr/local/smm++
-+ ln -fs /usr/local/smm++/smm /usr/local/bin/smm
-+
diff --git a/net/smm++/files/patch-itk.sh b/net/smm++/files/patch-itk.sh
new file mode 100644
index 000000000000..a946433884fb
--- /dev/null
+++ b/net/smm++/files/patch-itk.sh
@@ -0,0 +1,46 @@
+--- ../../smm5r0/Install.unix/itk.sh Mon Mar 19 08:46:07 2001
++++ itk.sh Sun Jul 15 17:01:08 2001
+@@ -1,32 +1,16 @@
+ #!/bin/sh
+
+ # all possible itkwish executables
+-itkarray=(itkwish3.1 itkwish3 itkwish30 itkwish)
++itkarray="itkwish3.1 itkwish3 itkwish30 itkwish3.0 itkwish"
+
+-# $PATH exploded as an array
+-explode=(`echo $PATH | sed 's/:/ /g'`)
+-
+-element_count=${#explode[@]}
+-i=0
+-found=0
+-while [ $i -lt ${element_count} ]
+-do
+- second_count=${#itkarray[@]}
+- x=0
+- while [ $x -lt ${second_count} ]
+- do
+- if [ -x ${explode[$i]}/${itkarray[$x]} ]; then
+- smm=${explode[$i]}/${itkarray[$x]}
+- found=1
+- break
+- fi
+- let "x=$x + 1"
+- done
+- let "i = $i + 1"
++set $itkarray
++while [ ! -z "$1" ]; do
++ smm=`which $1`
++ if [ $? -eq 0 ]; then
++ echo ${smm}
++ exit 0
++ fi
++ shift
+ done
+-if [ ${found} -eq 1 ] ; then
+- echo ${smm}
+- exit 0
+-else
+- exit 1
+-fi
++
++exit 1