aboutsummaryrefslogtreecommitdiff
path: root/net/sntop
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2014-06-09 16:21:35 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2014-06-09 16:21:35 +0000
commit4744048656e9bffa5317edb36479f388ee9ca2b8 (patch)
treee3ad59300fadfde334d3cb99748a207aa6fe5bf9 /net/sntop
parente02b236f9d6b5da2961c42325d81960d13a06360 (diff)
downloadports-4744048656e9bffa5317edb36479f388ee9ca2b8.tar.gz
ports-4744048656e9bffa5317edb36479f388ee9ca2b8.zip
Notes
Diffstat (limited to 'net/sntop')
-rw-r--r--net/sntop/Makefile15
-rw-r--r--net/sntop/files/patch-aa44
-rw-r--r--net/sntop/pkg-plist3
3 files changed, 41 insertions, 21 deletions
diff --git a/net/sntop/Makefile b/net/sntop/Makefile
index 6844712b36eb..68357e82eded 100644
--- a/net/sntop/Makefile
+++ b/net/sntop/Makefile
@@ -3,6 +3,7 @@
PORTNAME= sntop
PORTVERSION= 1.4.3
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= SF
@@ -16,21 +17,17 @@ PORTDOCS= COPYING CREDITS ChangeLog INSTALL README TODO
EXAMPLES= alarm.sh sntoprc.EXAMPLE
SUB_FILES= pkg-message
-MAN1= sntop.1
-
-NO_STAGE= yes
post-install:
- @${STRIP_CMD} ${PREFIX}/bin/sntop
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/sntop
.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
.for doc in ${PORTDOCS}
- ${INSTALL_DATA} ${WRKSRC}/${doc} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${doc} ${STAGEDIR}${DOCSDIR}
.endfor
.endif
- @${MKDIR} ${EXAMPLESDIR}
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
.for example in ${EXAMPLES}
- ${INSTALL_DATA} ${WRKSRC}/${example} ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${example} ${STAGEDIR}${EXAMPLESDIR}
.endfor
- @${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>
diff --git a/net/sntop/files/patch-aa b/net/sntop/files/patch-aa
index 115c1d12cafd..de724dd518f8 100644
--- a/net/sntop/files/patch-aa
+++ b/net/sntop/files/patch-aa
@@ -1,6 +1,6 @@
---- Makefile.in.orig Sun Nov 11 22:54:15 2001
-+++ Makefile.in Sat Apr 6 23:49:08 2002
-@@ -36,7 +36,7 @@
+--- Makefile.in.orig 2001-11-12 05:54:15.000000000 +0800
++++ Makefile.in 2014-06-10 00:19:16.894102010 +0800
+@@ -36,7 +36,7 @@ DOWENEEDGETOPT = @LIBOBJS@
MANDIR = @mandir@/man1
SNTOPRC = $(ETCDIR)/sntoprc
CC = @CC@
@@ -9,28 +9,50 @@
proper: clean sntop
-@@ -65,12 +65,12 @@
+@@ -56,34 +56,33 @@ clean:
+ -rm getopt_long.o
+
+ install: sntop
+- @if [ -d $(INSTDIR) ]; \
++ @if [ -d $(DESTDIR)$(INSTDIR) ]; \
+ then \
+- cp sntop $(INSTDIR); \
+- chmod 755 $(INSTDIR)/sntop; \
++ cp sntop $(DESTDIR)$(INSTDIR); \
++ chmod 755 $(DESTDIR)$(INSTDIR)/sntop; \
+ else \
+ echo "sntop: $(INSTDIR) does not exist"; false; \
fi
- @if [ -d $(ETCDIR) ]; \
+- @if [ -d $(ETCDIR) ]; \
++ @if [ -d $(DESTDIR)$(ETCDIR) ]; \
then \
- if [ ! -f $(ETCDIR)/sntoprc ]; \
-+ if [ ! -f $(ETCDIR)/sntoprc.sample ]; \
++ if [ ! -f $(DESTDIR)$(ETCDIR)/sntoprc.sample ]; \
then \
- cp sntoprc.EXAMPLE $(ETCDIR)/sntoprc; \
- chmod 644 $(ETCDIR)/sntoprc; \
-+ cp sntoprc.EXAMPLE $(ETCDIR)/sntoprc.sample; \
-+ chmod 644 $(ETCDIR)/sntoprc.sample; \
++ cp sntoprc.EXAMPLE $(DESTDIR)$(ETCDIR)/sntoprc.sample; \
++ chmod 644 $(DESTDIR)$(ETCDIR)/sntoprc.sample; \
fi; \
- echo "sntop: Sample config exists at $(ETCDIR)/sntoprc"; \
+ echo "sntop: Sample config exists at $(ETCDIR)/sntoprc.sample"; \
else \
echo "sntop: $(ETCDIR) does not exist"; false; \
fi
-@@ -78,7 +78,6 @@
+- @if [ -d $(MANDIR) ]; \
++ @if [ -d $(DESTDIR)$(MANDIR) ]; \
then \
- cp sntop.1 $(MANDIR); \
- chmod 644 $(MANDIR)/sntop.1; \
+- cp sntop.1 $(MANDIR); \
+- chmod 644 $(MANDIR)/sntop.1; \
- gzip -9 $(MANDIR)/sntop.1; \
++ cp sntop.1 $(DESTDIR)$(MANDIR); \
++ chmod 644 $(DESTDIR)$(MANDIR)/sntop.1; \
echo "sntop: Man file installed in $(MANDIR)"; \
else \
echo "sntop: $(MANDIR) does not exist, not installing man file"; \
+ fi
+- @if [ -f $(INSTDIR)/sntop ]; \
++ @if [ -f $(DESTDIR)$(INSTDIR)/sntop ]; \
+ then \
+ echo "sntop: Executable installed in $(INSTDIR)"; \
+ else \
diff --git a/net/sntop/pkg-plist b/net/sntop/pkg-plist
index d30c6cf40f19..a4a93a7c4ae4 100644
--- a/net/sntop/pkg-plist
+++ b/net/sntop/pkg-plist
@@ -1,5 +1,6 @@
bin/sntop
-etc/sntoprc.sample
+@sample etc/sntoprc.sample
+man/man1/sntop.1.gz
%%EXAMPLESDIR%%/alarm.sh
%%EXAMPLESDIR%%/sntoprc.EXAMPLE
@dirrm %%EXAMPLESDIR%%