aboutsummaryrefslogtreecommitdiff
path: root/net/sobby
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2014-01-14 19:50:57 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2014-01-14 19:50:57 +0000
commit2ed1a544000e745144b2928f7e30bd3e77c1f335 (patch)
treebe189a1879a7e7409619d3181270422bfcbfddc4 /net/sobby
parent32cbafd1a114344347c6e6dcd6ee974538f83436 (diff)
downloadports-2ed1a544000e745144b2928f7e30bd3e77c1f335.tar.gz
ports-2ed1a544000e745144b2928f7e30bd3e77c1f335.zip
Notes
Diffstat (limited to 'net/sobby')
-rw-r--r--net/sobby/Makefile21
-rw-r--r--net/sobby/files/patch-inc__config.hpp62
2 files changed, 69 insertions, 14 deletions
diff --git a/net/sobby/Makefile b/net/sobby/Makefile
index fb0a14e99e85..179d5c06f1b5 100644
--- a/net/sobby/Makefile
+++ b/net/sobby/Makefile
@@ -7,30 +7,23 @@ CATEGORIES= net
MASTER_SITES= http://releases.0x539.de/sobby/
MAINTAINER= ports@FreeBSD.org
-COMMENT= A standalone obby server
+COMMENT= Standalone obby server
LICENSE= GPLv2
-LICENSE_FILE= ${WRKSRC}/COPYING
-LIB_DEPENDS= sigc-2.0.0:${PORTSDIR}/devel/libsigc++20 \
- obby-0.4.1:${PORTSDIR}/devel/obby \
- net6-1.3.0:${PORTSDIR}/net/net6 \
- xml++-2.6.2:${PORTSDIR}/textproc/libxml++26 \
- glibmm-2.4.1:${PORTSDIR}/devel/glibmm
+LIB_DEPENDS= libsigc-2.0.so:${PORTSDIR}/devel/libsigc++20 \
+ libobby-0.4.so:${PORTSDIR}/devel/obby \
+ libnet6-1.3.so:${PORTSDIR}/net/net6 \
+ libxml++-2.6.so:${PORTSDIR}/textproc/libxml++26
USES= pkgconfig
+USE_GNOME= glibmm
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-zeroconf
-MAN1= ${PORTNAME}.1
-PLIST_FILES= bin/${PORTNAME}
-
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-NO_STAGE= yes
-do-install:
- ${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
- ${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.1 ${MANPREFIX}/man/man1
+PLIST_FILES= bin/${PORTNAME} man/man1/${PORTNAME}.1.gz
.include <bsd.port.mk>
diff --git a/net/sobby/files/patch-inc__config.hpp b/net/sobby/files/patch-inc__config.hpp
new file mode 100644
index 000000000000..ff2468cfd118
--- /dev/null
+++ b/net/sobby/files/patch-inc__config.hpp
@@ -0,0 +1,62 @@
+--- inc/config.hpp.orig
++++ inc/config.hpp
+@@ -30,6 +30,30 @@
+ #include <libxml++/nodes/element.h>
+ #include <libxml++/nodes/textnode.h>
+
++namespace serialise
++{
++
++template<>
++class default_context_to<Glib::ustring>: public context_base_to<Glib::ustring>
++{
++public:
++ typedef Glib::ustring data_type;
++
++ virtual std::string to_string(const data_type& from) const;
++};
++
++template<>
++class default_context_from<Glib::ustring>:
++ public context_base_from<Glib::ustring>
++{
++public:
++ typedef Glib::ustring data_type;
++
++ virtual data_type from_string(const std::string& from) const;
++};
++
++} // namespace serialise
++
+ namespace Sobby
+ {
+
+@@ -434,28 +458,4 @@
+
+ } // namespace Sobby
+
+-namespace serialise
+-{
+-
+-template<>
+-class default_context_to<Glib::ustring>: public context_base_to<Glib::ustring>
+-{
+-public:
+- typedef Glib::ustring data_type;
+-
+- virtual std::string to_string(const data_type& from) const;
+-};
+-
+-template<>
+-class default_context_from<Glib::ustring>:
+- public context_base_from<Glib::ustring>
+-{
+-public:
+- typedef Glib::ustring data_type;
+-
+- virtual data_type from_string(const std::string& from) const;
+-};
+-
+-} // namespace serialise
+-
+ #endif // _SOBBY_CONFIG_HPP_