aboutsummaryrefslogtreecommitdiff
path: root/net/socat/Makefile
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-06-30 07:25:42 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-06-30 07:25:42 +0000
commitb84e72c19f1157eedb5721264b285cdd506512c7 (patch)
treea149c89d08e74aec87aaa39770558b9b2e0bf3f0 /net/socat/Makefile
parent18814521879ceca458b93d516a490a59e071849e (diff)
downloadports-b84e72c19f1157eedb5721264b285cdd506512c7.tar.gz
ports-b84e72c19f1157eedb5721264b285cdd506512c7.zip
Notes
Diffstat (limited to 'net/socat/Makefile')
-rw-r--r--net/socat/Makefile13
1 files changed, 10 insertions, 3 deletions
diff --git a/net/socat/Makefile b/net/socat/Makefile
index 9a709fe70951..b747f6c8e318 100644
--- a/net/socat/Makefile
+++ b/net/socat/Makefile
@@ -7,7 +7,7 @@
#
PORTNAME= socat
-PORTVERSION= 1.3.2.2
+PORTVERSION= 1.4.0.0
CATEGORIES= net
MASTER_SITES= http://www.dest-unreach.org/socat/download/
@@ -21,13 +21,20 @@ GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
MAKE_ARGS= CCOPT="${CFLAGS}"
+.if defined(WITHOUT_SSL)
+CONFIGURE_ARGS+= --disable-openssl
+.else
+USE_OPENSSL= yes
+.endif
+
MAN1= socat.1
-DOCS= EXAMPLES README SECURITY
+PORTDOCS= EXAMPLES README SECURITY FAQ
+PLIST_FILES= bin/filan bin/procan bin/socat
.if !defined(NOPORTDOCS)
post-install:
@${MKDIR} ${DOCSDIR}
- cd ${WRKSRC} && ${INSTALL_DATA} ${DOCS} ${DOCSDIR}
+ cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}
.endif
.include <bsd.port.mk>