aboutsummaryrefslogtreecommitdiff
path: root/net/socat
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2013-08-03 20:33:45 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2013-08-03 20:33:45 +0000
commit75e127f59572355d6488295e538ef2c8f3b15eee (patch)
tree9d3dfdece47235bf079f6cfb368550ea0cbb6c77 /net/socat
parentcc287112a0758ee449eca27fee9572dd493f36d9 (diff)
downloadports-75e127f59572355d6488295e538ef2c8f3b15eee.tar.gz
ports-75e127f59572355d6488295e538ef2c8f3b15eee.zip
Fix logic in clang detection.
Notified by: crees
Notes
Notes: svn path=/head/; revision=324202
Diffstat (limited to 'net/socat')
-rw-r--r--net/socat/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/net/socat/Makefile b/net/socat/Makefile
index 10f845e36176..81cc7f7f9d51 100644
--- a/net/socat/Makefile
+++ b/net/socat/Makefile
@@ -37,7 +37,7 @@ LDFLAGS+= -L${LOCALBASE}/lib
CCISCLANG!= ${CC} --version | ${HEAD} -1 | ${GREP} 'clang'
.endif
-.if ${CC} == clang || defined(CCISCLANG)
+.if ${CC} == clang || !empty(CCISCLANG)
CFLAGS+= -Wno-unused-comparison
.endif