aboutsummaryrefslogtreecommitdiff
path: root/net/socat
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2019-04-07 17:17:24 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2019-04-07 17:17:24 +0000
commitbc0ceb2206100cac06031fb38c6fa1bed876f998 (patch)
tree3e2577cb6ead3934b4aaa75ceadf85ff4fc92c24 /net/socat
parent99c1fc726a47fab82a73ef93f0bdbdf760561b91 (diff)
downloadports-bc0ceb2206100cac06031fb38c6fa1bed876f998.tar.gz
ports-bc0ceb2206100cac06031fb38c6fa1bed876f998.zip
- Update to 1.7.3.3
- Pacify portlint
Notes
Notes: svn path=/head/; revision=498299
Diffstat (limited to 'net/socat')
-rw-r--r--net/socat/Makefile6
-rw-r--r--net/socat/distinfo6
-rw-r--r--net/socat/files/patch-Makefile.in14
-rw-r--r--net/socat/files/patch-xioopts.c73
4 files changed, 6 insertions, 93 deletions
diff --git a/net/socat/Makefile b/net/socat/Makefile
index 27768dbdca5b..4238a4cfae49 100644
--- a/net/socat/Makefile
+++ b/net/socat/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= socat
-PORTVERSION= 1.7.3.2
-PORTREVISION= 4
+PORTVERSION= 1.7.3.3
CATEGORIES= net ipv6
MASTER_SITES= http://www.dest-unreach.org/socat/download/ \
LOCAL/ehaupt
@@ -15,9 +14,10 @@ LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
USES= compiler cpe ssl tar:bzip2
-GNU_CONFIGURE= yes
USE_RC_SUBR= socat
+GNU_CONFIGURE= yes
+
CPE_VENDOR= dest-unreach
PORTSCOUT= skipv:2.0.0-b2
diff --git a/net/socat/distinfo b/net/socat/distinfo
index 0778660aa0d9..df0698517235 100644
--- a/net/socat/distinfo
+++ b/net/socat/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1485420160
-SHA256 (socat-1.7.3.2.tar.bz2) = e3561f808739383eb10fada1e5d4f26883f0311b34fd0af7837d0c95ef379251
-SIZE (socat-1.7.3.2.tar.bz2) = 493324
+TIMESTAMP = 1554656689
+SHA256 (socat-1.7.3.3.tar.bz2) = 0dd63ffe498168a4aac41d307594c5076ff307aa0ac04b141f8f1cec6594d04a
+SIZE (socat-1.7.3.3.tar.bz2) = 489901
diff --git a/net/socat/files/patch-Makefile.in b/net/socat/files/patch-Makefile.in
deleted file mode 100644
index 1c8df27086fb..000000000000
--- a/net/socat/files/patch-Makefile.in
+++ /dev/null
@@ -1,14 +0,0 @@
---- Makefile.in.orig 2017-01-06 20:58:40 UTC
-+++ Makefile.in
-@@ -118,8 +118,9 @@ PROCAN_OBJS=procan_main.o procan.o proca
- procan: $(PROCAN_OBJS)
- $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $(PROCAN_OBJS) $(CLIBS)
-
--filan: filan_main.o filan.o fdname.o error.o sycls.o sysutils.o utils.o
-- $(CC) $(CFLAGS) $(LDFLAGS) -o $@ filan_main.o filan.o fdname.o error.o sycls.o sysutils.o utils.o vsnprintf_r.o snprinterr.o $(CLIBS)
-+FILAN_OBJS=filan_main.o filan.o fdname.o error.o sycls.o sysutils.o utils.o vsnprintf_r.o snprinterr.o
-+filan: $(FILAN_OBJS)
-+ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $(FILAN_OBJS) $(CLIBS)
-
- libxio.a: $(XIOOBJS) $(UTLOBJS)
- $(AR) r $@ $(XIOOBJS) $(UTLOBJS)
diff --git a/net/socat/files/patch-xioopts.c b/net/socat/files/patch-xioopts.c
deleted file mode 100644
index 1a257fc36a31..000000000000
--- a/net/socat/files/patch-xioopts.c
+++ /dev/null
@@ -1,73 +0,0 @@
---- xioopts.c.orig 2015-01-24 10:15:22 UTC
-+++ xioopts.c
-@@ -2971,6 +2971,25 @@ int retropt_bind(struct opt *opts,
- OFUNC_TERMIOS_FLAG, OFUNC_TERMIOS_PATTERN, and some OFUNC_SPEC */
- int applyopts(int fd, struct opt *opts, enum e_phase phase) {
- struct opt *opt;
-+#ifdef HAVE_TERMIOS_ISPEED
-+ int ispeed_major = -1, ospeed_major = -1;
-+ unsigned int ispeed_value, ospeed_value;
-+ bool speed_done = false;
-+
-+ opt = opts; while (opt && opt->desc != ODESC_END) {
-+ if (opt->desc == ODESC_DONE ||
-+ (phase != PH_ALL && opt->desc->phase != phase)) {
-+ ++opt; continue; }
-+ if (opt->desc->optcode == OPT_ISPEED) {
-+ ispeed_major = opt->desc->major;
-+ ispeed_value = opt->value.u_uint; }
-+ if (opt->desc->optcode == OPT_OSPEED) {
-+ ospeed_major = opt->desc->major;
-+ ospeed_value = opt->value.u_uint; }
-+ ++opt;
-+ continue;
-+ }
-+#endif /* HAVE_TERMIOS_ISPEED */
-
- opt = opts; while (opt && opt->desc != ODESC_END) {
- if (opt->desc == ODESC_DONE ||
-@@ -3605,21 +3624,29 @@ int applyopts(int fd, struct opt *opts,
-
- #ifdef HAVE_TERMIOS_ISPEED
- } else if (opt->desc->func == OFUNC_TERMIOS_SPEED) {
-- union {
-- struct termios termarg;
-- speed_t speeds[sizeof(struct termios)/sizeof(speed_t)];
-- } tdata;
-- if (Tcgetattr(fd, &tdata.termarg) < 0) {
-- Error3("tcgetattr(%d, %p): %s",
-- fd, &tdata.termarg, strerror(errno));
-- opt->desc = ODESC_ERROR; ++opt; continue;
-- }
-- tdata.speeds[opt->desc->major] = opt->value.u_uint;
-- if (Tcsetattr(fd, TCSADRAIN, &tdata.termarg) < 0) {
-- Error3("tcsetattr(%d, TCSADRAIN, %p): %s",
-- fd, &tdata.termarg, strerror(errno));
-- opt->desc = ODESC_ERROR; ++opt; continue;
-- }
-+ if (speed_done == false) {
-+ union {
-+ struct termios termarg;
-+ speed_t speeds[sizeof(struct termios)/sizeof(speed_t)];
-+ } tdata;
-+ if (Tcgetattr(fd, &tdata.termarg) < 0) {
-+ Error3("tcgetattr(%d, %p): %s",
-+ fd, &tdata.termarg, strerror(errno));
-+ opt->desc = ODESC_ERROR; ++opt; continue;
-+ }
-+ if (ispeed_major < 0 || ospeed_major < 0)
-+ tdata.speeds[opt->desc->major] = opt->value.u_uint;
-+ else{
-+ tdata.speeds[ispeed_major] = ispeed_value;
-+ tdata.speeds[ospeed_major] = ospeed_value;
-+ speed_done = true;
-+ }
-+ if (Tcsetattr(fd, TCSADRAIN, &tdata.termarg) < 0) {
-+ Error3("tcsetattr(%d, TCSADRAIN, %p): %s",
-+ fd, &tdata.termarg, strerror(errno));
-+ opt->desc = ODESC_ERROR; ++opt; continue;
-+ }
-+ }
- #endif /* HAVE_TERMIOS_ISPEED */
-
- } else if (opt->desc->func == OFUNC_TERMIOS_SPEC) {