aboutsummaryrefslogtreecommitdiff
path: root/net/socat
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2013-10-23 13:50:35 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2013-10-23 13:50:35 +0000
commitf38b64d9e639771b0291e52b3192f7438ca80f43 (patch)
treed00a4589f831b32dfa61287bef7cac285ec794ea /net/socat
parent3095946235187ecda15db0856efbadb1467cbe93 (diff)
downloadports-f38b64d9e639771b0291e52b3192f7438ca80f43.tar.gz
ports-f38b64d9e639771b0291e52b3192f7438ca80f43.zip
Notes
Diffstat (limited to 'net/socat')
-rw-r--r--net/socat/Makefile12
1 files changed, 5 insertions, 7 deletions
diff --git a/net/socat/Makefile b/net/socat/Makefile
index dd08e707627e..098fb6ddff16 100644
--- a/net/socat/Makefile
+++ b/net/socat/Makefile
@@ -20,13 +20,11 @@ USE_OPENSSL= yes
PORTSCOUT= skipv:2.0.0-b2
-MAN1= socat.1
-PLIST_FILES= bin/filan bin/procan bin/socat
+PLIST_FILES= bin/filan bin/procan bin/socat man/man1/socat.1.gz
PORTDOCS= EXAMPLES README SECURITY FAQ
OPTIONS_DEFINE= DOCS
-NO_STAGE= yes
.include <bsd.port.options.mk>
.if defined(WITH_OPENSSL_PORT)
@@ -42,12 +40,12 @@ CFLAGS+= -Wno-unused-comparison
do-install:
.for f in filan procan socat
- ${INSTALL_PROGRAM} ${WRKSRC}/${f} ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/${f} ${STAGEDIR}${PREFIX}/bin
.endfor
- ${INSTALL_MAN} ${WRKSRC}/doc/${MAN1} ${MAN1PREFIX}/man/man1
+ ${INSTALL_MAN} ${WRKSRC}/doc/${PORTNAME}.1 ${STAGEDIR}${MAN1PREFIX}/man/man1
.if ${PORT_OPTIONS:MDOCS}
- ${MKDIR} ${DOCSDIR}
- cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${STAGEDIR}${DOCSDIR}
.endif
.if ${ARCH} == "arm"