aboutsummaryrefslogtreecommitdiff
path: root/net/socat
diff options
context:
space:
mode:
authorMarcus Alves Grando <mnag@FreeBSD.org>2006-04-29 18:41:39 +0000
committerMarcus Alves Grando <mnag@FreeBSD.org>2006-04-29 18:41:39 +0000
commitfab105ff9b7d1504fcb4e6b019a8ffb4a4f545c1 (patch)
treec4cf3e51ef69d30eee3c659b41beea181b7d93d7 /net/socat
parent86a6a64828ebcf2e0d89a38fae48dcf4256f70e8 (diff)
downloadports-fab105ff9b7d1504fcb4e6b019a8ffb4a4f545c1.tar.gz
ports-fab105ff9b7d1504fcb4e6b019a8ffb4a4f545c1.zip
Notes
Diffstat (limited to 'net/socat')
-rw-r--r--net/socat/Makefile7
-rw-r--r--net/socat/files/patch-xio-listen.c10
-rw-r--r--net/socat/files/patch-xio-udp.c10
3 files changed, 25 insertions, 2 deletions
diff --git a/net/socat/Makefile b/net/socat/Makefile
index 7b99a6805eae..3c6866b0e3ae 100644
--- a/net/socat/Makefile
+++ b/net/socat/Makefile
@@ -8,6 +8,7 @@
PORTNAME= socat
PORTVERSION= 1.4.3.1
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= http://www.dest-unreach.org/socat/download/
@@ -20,9 +21,11 @@ USE_BZIP2= yes
GNU_CONFIGURE= yes
MAN1= socat.1
+
.if !defined(NOPORTDOCS)
PORTDOCS= EXAMPLES README SECURITY FAQ
.endif
+
PLIST_FILES= bin/filan bin/procan bin/socat
OPTIONS= SSL "OpenSSL support" on
@@ -36,9 +39,9 @@ OPTIONS= SSL "OpenSSL support" on
CONFIGURE_ARGS+= --disable-openssl
.endif
-.if !defined(NOPORTDOCS)
post-install:
- ${MKDIR} ${DOCSDIR}
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}
.endif
diff --git a/net/socat/files/patch-xio-listen.c b/net/socat/files/patch-xio-listen.c
new file mode 100644
index 000000000000..d9801d4c8842
--- /dev/null
+++ b/net/socat/files/patch-xio-listen.c
@@ -0,0 +1,10 @@
+--- ./xio-listen.c.orig Sun Jan 29 14:33:07 2006
++++ ./xio-listen.c Sat Apr 29 15:33:10 2006
+@@ -311,6 +311,7 @@
+ &ri, xfd->fd, &la->soa, pa, libwrapname);
+ request_init(&ri, RQ_FILE, xfd->fd, RQ_CLIENT_SIN, &la->soa,
+ RQ_SERVER_SIN, pa, RQ_DAEMON, libwrapname, 0);
++ sock_methods(&ri);
+ Debug("request_init() ->");
+
+ Debug1("hosts_access(%p)", &ri);
diff --git a/net/socat/files/patch-xio-udp.c b/net/socat/files/patch-xio-udp.c
new file mode 100644
index 000000000000..8740ba4b128a
--- /dev/null
+++ b/net/socat/files/patch-xio-udp.c
@@ -0,0 +1,10 @@
+--- ./xio-udp.c.orig Sat Apr 29 15:34:17 2006
++++ ./xio-udp.c Sat Apr 29 15:34:32 2006
+@@ -226,6 +226,7 @@
+ &ri, fd->stream.fd, &la->soa, them, libwrapname);
+ request_init(&ri, RQ_FILE, fd->stream.fd, RQ_CLIENT_SIN, &la->soa,
+ RQ_SERVER_SIN, them, RQ_DAEMON, libwrapname, 0);
++ sock_methods(&ri);
+ Debug("request_init() ->");
+
+ Debug1("hosts_access(%p)", &ri);