aboutsummaryrefslogtreecommitdiff
path: root/net/ssltunnel-client/Makefile
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2003-10-31 10:38:11 +0000
committerMathieu Arnold <mat@FreeBSD.org>2003-10-31 10:38:11 +0000
commit445f6a1bdd862a4d6d02d21b8fa77d1cdcdb64c4 (patch)
tree518c911eed0aa3ee2eb54f412c446e3487b60ade /net/ssltunnel-client/Makefile
parentf8c4b713a9155e96affbe6c285a96dff8d8e13a1 (diff)
downloadports-445f6a1bdd862a4d6d02d21b8fa77d1cdcdb64c4.tar.gz
ports-445f6a1bdd862a4d6d02d21b8fa77d1cdcdb64c4.zip
Notes
Diffstat (limited to 'net/ssltunnel-client/Makefile')
-rw-r--r--net/ssltunnel-client/Makefile57
1 files changed, 57 insertions, 0 deletions
diff --git a/net/ssltunnel-client/Makefile b/net/ssltunnel-client/Makefile
new file mode 100644
index 000000000000..b14634d68dd6
--- /dev/null
+++ b/net/ssltunnel-client/Makefile
@@ -0,0 +1,57 @@
+# ex:ts=8
+# Ports collection makefile for: ssltunnel-client
+# Date created: June 10, 2003
+# Whom: at@rominet.net
+#
+# $Id: Makefile,v 1.3 2003/09/21 16:20:44 thivillon Exp $
+#
+# $FreeBSD$
+#
+
+PORTNAME= ssltunnel
+PORTVERSION= 1.13
+PORTREVISION= 0
+CATEGORIES= net
+MASTER_SITES= http://www.hsc.fr/ressources/outils/ssltunnel/download/
+PKGNAMESUFFIX= -client
+
+MAINTAINER= at@rominet.net
+COMMENT= PPP over SSL virtual private networking (client part)
+
+LIB_DEPENDS+= iconv.3:${PORTSDIR}/converters/libiconv
+
+MAN1= pppclient.1
+MAN5= ssltunnelrc.5
+
+WANT_GNOME= yes
+
+.if defined(PACKAGE_BUILDING)
+WITHOUT_GNOME= yes
+.endif
+
+.include <bsd.port.pre.mk>
+
+.if ${HAVE_GNOME:Mgtk12}!=""
+USE_GNOME=gtk12
+USE_PERL5=yes
+RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Gtk.pm:${PORTSDIR}/x11-toolkits/p5-Gtk
+MAN1+= gpppclient.1
+BUILD_PERLGTK=yes
+.endif
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS+= --disable-server --with-iconv=${LOCALBASE}
+
+post-install:
+.if defined(BUILD_PERLGTK)
+ ${ECHO_CMD} "bin/gpppclient" >> ${TMPPLIST};
+.endif
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_MAN} ${WRKSRC}/README ${DOCSDIR}
+ ${INSTALL_MAN} ${WRKSRC}/LISEZ-MOI ${DOCSDIR}
+.endif
+ @${MKDIR} ${PREFIX}/etc/ssltunnel/
+ ${INSTALL_DATA} ${WRKSRC}/client/tunnel.conf ${PREFIX}/etc/ssltunnel/client.conf.sample
+
+.include <bsd.port.post.mk>