aboutsummaryrefslogtreecommitdiff
path: root/net/ssltunnel-client
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2003-10-31 10:38:11 +0000
committerMathieu Arnold <mat@FreeBSD.org>2003-10-31 10:38:11 +0000
commit445f6a1bdd862a4d6d02d21b8fa77d1cdcdb64c4 (patch)
tree518c911eed0aa3ee2eb54f412c446e3487b60ade /net/ssltunnel-client
parentf8c4b713a9155e96affbe6c285a96dff8d8e13a1 (diff)
downloadports-445f6a1bdd862a4d6d02d21b8fa77d1cdcdb64c4.tar.gz
ports-445f6a1bdd862a4d6d02d21b8fa77d1cdcdb64c4.zip
Notes
Diffstat (limited to 'net/ssltunnel-client')
-rw-r--r--net/ssltunnel-client/Makefile57
-rw-r--r--net/ssltunnel-client/distinfo1
-rw-r--r--net/ssltunnel-client/pkg-descr12
-rw-r--r--net/ssltunnel-client/pkg-plist7
4 files changed, 77 insertions, 0 deletions
diff --git a/net/ssltunnel-client/Makefile b/net/ssltunnel-client/Makefile
new file mode 100644
index 000000000000..b14634d68dd6
--- /dev/null
+++ b/net/ssltunnel-client/Makefile
@@ -0,0 +1,57 @@
+# ex:ts=8
+# Ports collection makefile for: ssltunnel-client
+# Date created: June 10, 2003
+# Whom: at@rominet.net
+#
+# $Id: Makefile,v 1.3 2003/09/21 16:20:44 thivillon Exp $
+#
+# $FreeBSD$
+#
+
+PORTNAME= ssltunnel
+PORTVERSION= 1.13
+PORTREVISION= 0
+CATEGORIES= net
+MASTER_SITES= http://www.hsc.fr/ressources/outils/ssltunnel/download/
+PKGNAMESUFFIX= -client
+
+MAINTAINER= at@rominet.net
+COMMENT= PPP over SSL virtual private networking (client part)
+
+LIB_DEPENDS+= iconv.3:${PORTSDIR}/converters/libiconv
+
+MAN1= pppclient.1
+MAN5= ssltunnelrc.5
+
+WANT_GNOME= yes
+
+.if defined(PACKAGE_BUILDING)
+WITHOUT_GNOME= yes
+.endif
+
+.include <bsd.port.pre.mk>
+
+.if ${HAVE_GNOME:Mgtk12}!=""
+USE_GNOME=gtk12
+USE_PERL5=yes
+RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Gtk.pm:${PORTSDIR}/x11-toolkits/p5-Gtk
+MAN1+= gpppclient.1
+BUILD_PERLGTK=yes
+.endif
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS+= --disable-server --with-iconv=${LOCALBASE}
+
+post-install:
+.if defined(BUILD_PERLGTK)
+ ${ECHO_CMD} "bin/gpppclient" >> ${TMPPLIST};
+.endif
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_MAN} ${WRKSRC}/README ${DOCSDIR}
+ ${INSTALL_MAN} ${WRKSRC}/LISEZ-MOI ${DOCSDIR}
+.endif
+ @${MKDIR} ${PREFIX}/etc/ssltunnel/
+ ${INSTALL_DATA} ${WRKSRC}/client/tunnel.conf ${PREFIX}/etc/ssltunnel/client.conf.sample
+
+.include <bsd.port.post.mk>
diff --git a/net/ssltunnel-client/distinfo b/net/ssltunnel-client/distinfo
new file mode 100644
index 000000000000..e1361a7a7f5e
--- /dev/null
+++ b/net/ssltunnel-client/distinfo
@@ -0,0 +1 @@
+MD5 (ssltunnel-1.13.tar.gz) = 18f993daed771e04039586488141e21d
diff --git a/net/ssltunnel-client/pkg-descr b/net/ssltunnel-client/pkg-descr
new file mode 100644
index 000000000000..8866660f76ad
--- /dev/null
+++ b/net/ssltunnel-client/pkg-descr
@@ -0,0 +1,12 @@
+ssltunnel is a client/server software to establish PPP links over
+SSL/TLS sessions. Client and server are mutually authenticated using
+X509 certificates, PPP packets are encrypted/decrypted realtime on
+each side. The client has the ability to initiate the connection
+through an HTTP/HTTPS relay, even if an authentification is needed.
+
+This is the client part.
+
+WWW: http://www.hsc.fr/ressources/outils/ssltunnel/
+
+- HSC (Herver Schauer Consultants) http://www.hsc.fr/
+ Alain Thivillon (at@rominet.net)
diff --git a/net/ssltunnel-client/pkg-plist b/net/ssltunnel-client/pkg-plist
new file mode 100644
index 000000000000..b6b31712b259
--- /dev/null
+++ b/net/ssltunnel-client/pkg-plist
@@ -0,0 +1,7 @@
+bin/pppclient
+@unexec if cmp -s %D/etc/ssltunnel/client.conf %D/etc/ssltunnel/client.conf.sample; then rm -f %D/etc/ssltunnel/client.conf; fi
+etc/ssltunnel/client.conf.sample
+%%PORTDOCS%%%%DOCSDIR%%/LISEZ-MOI
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+@unexec rmdir %D/etc/ssltunnel 2>/dev/null || true