aboutsummaryrefslogtreecommitdiff
path: root/net/ssltunnel-client
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2019-01-05 14:00:38 +0000
committerRene Ladan <rene@FreeBSD.org>2019-01-05 14:00:38 +0000
commit02c5ac36ee1b73e7b2e83f98e34b0e64e565a6da (patch)
tree0dbe5abf1f5735383717106804bd9cac331c3da8 /net/ssltunnel-client
parentd391416181f7b87d6c58241343f82e00e3a302f8 (diff)
This is the commit message, please edit it.
2019-01-04 net/ssltunnel-server: Does not build, upstream disappeared 2019-01-04 lang/cilkplus: Cilk Plus is on its way out (both in GCC and the Intel compilers) net/ssltunnel-client: client part of expired net/ssltunnel-server
Notes
Notes: svn path=/head/; revision=489339
Diffstat (limited to 'net/ssltunnel-client')
-rw-r--r--net/ssltunnel-client/Makefile48
-rw-r--r--net/ssltunnel-client/distinfo2
-rw-r--r--net/ssltunnel-client/files/patch-client_ntlmauth.c43
-rw-r--r--net/ssltunnel-client/pkg-descr9
-rw-r--r--net/ssltunnel-client/pkg-plist7
5 files changed, 0 insertions, 109 deletions
diff --git a/net/ssltunnel-client/Makefile b/net/ssltunnel-client/Makefile
deleted file mode 100644
index 81e9241cadba..000000000000
--- a/net/ssltunnel-client/Makefile
+++ /dev/null
@@ -1,48 +0,0 @@
-# Created by: at@rominet.net
-# $FreeBSD$
-
-PORTNAME= ssltunnel
-PORTVERSION= 1.18
-PORTREVISION= 2
-CATEGORIES= net
-MASTER_SITES= http://www.hsc.fr/ressources/outils/ssltunnel/download/
-PKGNAMESUFFIX= -client
-
-MAINTAINER= crees@FreeBSD.org
-COMMENT= PPP over SSL virtual private networking (client part)
-
-LICENSE= BSD3CLAUSE
-
-OPTIONS_DEFINE= GUI DOCS
-GUI_DESC= GTK 1.2 graphical interface
-
-CONFIGURE_ARGS= --disable-server \
- --with-iconv=${ICONV_PREFIX} \
- --with-openssl=${OPENSSLBASE}
-GNU_CONFIGURE= yes
-USES= iconv ssl
-
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MGUI}
-USE_GNOME= gtk12
-USES+= perl5
-RUN_DEPENDS= p5-Gtk>=0:x11-toolkits/p5-Gtk
-PLIST_SUB+= PERLGTK=""
-.else
-PLIST_SUB+= PERLGTK="@comment "
-.endif
-
-post-patch:
- ${REINPLACE_CMD} -e 's|with_iconv|with-iconv|g' ${WRKSRC}/configure
-
-post-install:
- ${MKDIR} ${STAGEDIR}${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/LISEZ-MOI \
- ${STAGEDIR}${DOCSDIR}/client.LISEZ-MOI
- ${INSTALL_DATA} ${WRKSRC}/README ${STAGEDIR}${DOCSDIR}/client.README
- ${MKDIR} ${STAGEDIR}${ETCDIR}/
- ${INSTALL_DATA} ${WRKSRC}/client/tunnel.conf \
- ${STAGEDIR}${ETCDIR}/client.conf.sample
-
-.include <bsd.port.mk>
diff --git a/net/ssltunnel-client/distinfo b/net/ssltunnel-client/distinfo
deleted file mode 100644
index 225f6e000193..000000000000
--- a/net/ssltunnel-client/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-SHA256 (ssltunnel-1.18.tar.gz) = 1d2e4bbc935341775e7cc26dae980d6bdd5e8351f5a0cbf4d85363ac5d71081f
-SIZE (ssltunnel-1.18.tar.gz) = 132302
diff --git a/net/ssltunnel-client/files/patch-client_ntlmauth.c b/net/ssltunnel-client/files/patch-client_ntlmauth.c
deleted file mode 100644
index 1a6742699a97..000000000000
--- a/net/ssltunnel-client/files/patch-client_ntlmauth.c
+++ /dev/null
@@ -1,43 +0,0 @@
---- client/ntlmauth.c.orig 2009-02-05 15:32:12 UTC
-+++ client/ntlmauth.c
-@@ -56,7 +56,7 @@ extern int write_timeout(int s, char *b
- extern int read_timeout(int s, char *buffer, int size, int tmo);
- extern void do_log( int prio, char *format , ...);
-
--static void setup_des_key(unsigned char *key56, des_key_schedule *ks);
-+static void setup_des_key(unsigned char *key56, DES_key_schedule *ks);
- static void calc_resp(unsigned char *keys, unsigned char *plaintext, unsigned char *results);
- static char *do_ntlm_auth_1(char *username, char *password);
- static char *do_ntlm_auth_2(iconv_t myiconv, char *username, char *password, char *challenge);
-@@ -156,8 +156,8 @@ static char *do_ntlm_auth_2(iconv_t myic
- unsigned char *nt_pw = NULL,*lm_resp,*nt_resp;
- const unsigned char magic[] = "KGS!@#$%";
- unsigned char lm_hpw[50];
-- des_key_schedule ks1;
-- des_key_schedule ks2;
-+ DES_key_schedule ks1;
-+ DES_key_schedule ks2;
- unsigned char nt_hpw[50];
- MD4_CTX context;
- unsigned short server_flags;
-@@ -558,9 +558,9 @@ catch:
- * turns a 56 bit key into the 64 bit, odd parity key and sets the key.
- * The key schedule ks is also set.
- */
--static void setup_des_key(unsigned char key_56[], des_key_schedule *ks)
-+static void setup_des_key(unsigned char key_56[], DES_key_schedule *ks)
- {
-- des_cblock key;
-+ DES_cblock key;
-
- key[0] = key_56[0];
- key[1] = ((key_56[0] << 7) & 0xFF) | (key_56[1] >> 1);
-@@ -582,7 +582,7 @@ static void setup_des_key(unsigned char
- */
- static void calc_resp(unsigned char *keys, unsigned char *plaintext, unsigned char *results)
- {
-- des_key_schedule ks;
-+ DES_key_schedule ks;
-
- setup_des_key(keys, &ks);
- DES_ecb_encrypt((const_DES_cblock *) plaintext, (const_DES_cblock *) results, &ks, DES_ENCRYPT);
diff --git a/net/ssltunnel-client/pkg-descr b/net/ssltunnel-client/pkg-descr
deleted file mode 100644
index 574b43791deb..000000000000
--- a/net/ssltunnel-client/pkg-descr
+++ /dev/null
@@ -1,9 +0,0 @@
-ssltunnel is a client/server software to establish PPP links over
-SSL/TLS sessions. Client and server are mutually authenticated using
-X509 certificates, PPP packets are encrypted/decrypted realtime on
-each side. The client has the ability to initiate the connection
-through an HTTP/HTTPS relay, even if an authentification is needed.
-
-This is the client part.
-
-WWW: http://www.hsc.fr/ressources/outils/ssltunnel/
diff --git a/net/ssltunnel-client/pkg-plist b/net/ssltunnel-client/pkg-plist
deleted file mode 100644
index 8104a335eca6..000000000000
--- a/net/ssltunnel-client/pkg-plist
+++ /dev/null
@@ -1,7 +0,0 @@
-bin/pppclient
-%%PERLGTK%%bin/gpppclient
-@sample %%ETCDIR%%/client.conf.sample
-man/man1/pppclient.1.gz
-man/man5/ssltunnelrc.5.gz
-%%PORTDOCS%%%%DOCSDIR%%/client.LISEZ-MOI
-%%PORTDOCS%%%%DOCSDIR%%/client.README