aboutsummaryrefslogtreecommitdiff
path: root/net/ssvnc
diff options
context:
space:
mode:
authorAlejandro Pulver <alepulver@FreeBSD.org>2007-04-26 01:16:41 +0000
committerAlejandro Pulver <alepulver@FreeBSD.org>2007-04-26 01:16:41 +0000
commit459208adeb460e0598824d5704e17984fc65ccc7 (patch)
tree56836b50c97a081f05759ce865cfbf9dc263b28b /net/ssvnc
parent18e155390a8a39fb93e1275bbc850d2588e50ba9 (diff)
downloadports-459208adeb460e0598824d5704e17984fc65ccc7.tar.gz
ports-459208adeb460e0598824d5704e17984fc65ccc7.zip
Notes
Diffstat (limited to 'net/ssvnc')
-rw-r--r--net/ssvnc/Makefile55
-rw-r--r--net/ssvnc/distinfo3
-rw-r--r--net/ssvnc/files/patch-build.unix47
-rw-r--r--net/ssvnc/pkg-descr15
-rw-r--r--net/ssvnc/pkg-message9
-rw-r--r--net/ssvnc/pkg-plist6
6 files changed, 135 insertions, 0 deletions
diff --git a/net/ssvnc/Makefile b/net/ssvnc/Makefile
new file mode 100644
index 000000000000..d723af91913b
--- /dev/null
+++ b/net/ssvnc/Makefile
@@ -0,0 +1,55 @@
+# New ports collection makefile for: ssvnc
+# Date created: 2007-04-22
+# Whom: alepulver
+#
+# $FreeBSD$
+#
+
+PORTNAME= ssvnc
+PORTVERSION= 1.0.15
+CATEGORIES= net security
+MASTER_SITES= http://www.karlrunge.com/x11vnc/etv/
+
+MAINTAINER= alepulver@FreeBSD.org
+COMMENT= Enhanced TightVNC Viewer (SSVNC: SSL/SSH VNC viewer)
+
+BUILD_DEPENDS= xmkmf:${X_IMAKE_PORT}
+LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg
+RUN_DEPENDS= stunnel:${PORTSDIR}/security/stunnel
+
+USE_XLIB= yes
+USE_TCL_RUN= 84
+USE_TK_RUN= 84
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+post-patch:
+ @${REINPLACE_CMD} -e \
+ 's|/usr/local|${LOCALBASE}|g; s|/usr/X11R6|${X11BASE}|g' \
+ ${WRKSRC}/build.unix
+ @${REINPLACE_CMD} -e \
+ 's|exec wish|exec ${WISH}|; \
+ 303,$$s|ss_vncviewer|ssvnc-stunnel|; \
+ s|ssvnc_cmd|ssvnc-stunnel|' \
+ ${WRKSRC}/bin/util/ssvnc.tcl
+ @${REINPLACE_CMD} -e \
+ 's|ss_vncviewer|ssvnc-stunnel|; \
+ s|-vncviewer|-ssvnc|; \
+ s|grep Linux|grep ${OPSYS}|' \
+ ${WRKSRC}/bin/util/ss_vncviewer
+
+do-build:
+ @cd ${WRKSRC} && ${SETENV} UNAME="${OPSYS}" ${SH} build.unix
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/bin/${OPSYS}/vncviewer ${PREFIX}/bin/ssvnc
+ ${INSTALL_SCRIPT} ${WRKSRC}/bin/util/ss_vncviewer \
+ ${PREFIX}/bin/ssvnc-stunnel
+ ${INSTALL_SCRIPT} ${WRKSRC}/bin/util/ssvnc.tcl ${PREFIX}/bin/ssvnc-gui
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ cd ${WRKSRC} && ${INSTALL_DATA} README bin/util/stunnel-server.conf \
+ ${DOCSDIR}
+.endif
+ @${ECHO_CMD}; ${CAT} ${PKGMESSAGE}; ${ECHO_CMD}
+
+.include <bsd.port.mk>
diff --git a/net/ssvnc/distinfo b/net/ssvnc/distinfo
new file mode 100644
index 000000000000..6c041e45dcfe
--- /dev/null
+++ b/net/ssvnc/distinfo
@@ -0,0 +1,3 @@
+MD5 (ssvnc-1.0.15.tar.gz) = 2df77310547106d7d15c44f30c75b8a3
+SHA256 (ssvnc-1.0.15.tar.gz) = e9a5a7b954febf45dfa4e60dd1e030eb41aefd532f22e140652cde5ce61a558a
+SIZE (ssvnc-1.0.15.tar.gz) = 11410482
diff --git a/net/ssvnc/files/patch-build.unix b/net/ssvnc/files/patch-build.unix
new file mode 100644
index 000000000000..de2ec9b9fdda
--- /dev/null
+++ b/net/ssvnc/files/patch-build.unix
@@ -0,0 +1,47 @@
+--- ./build.unix.orig Sat Apr 21 20:10:49 2007
++++ ./build.unix Mon Apr 23 21:43:58 2007
+@@ -77,12 +77,13 @@
+
+ # Create a tmp dir for this build:
+ #
+-tmp=./src/tmp/$name.$$
++tmp=./src/tmp/$name
+ if [ "X$TMPDIR" != "X" ]; then
+ tmp="$TMPDIR/$tmp"
+ fi
+ mkdir -p $tmp || exit 1
+
++if false; then
+ # Try to find some static archives of various libraries:
+ #
+ libs="$tmp/libs"
+@@ -108,6 +109,7 @@
+ ls -ld $libs
+ ls -l $libs
+ echo
++fi
+
+ have_gcc=""
+ if type gcc > /dev/null; then
+@@ -203,7 +205,7 @@
+ xmkmf
+ make Makefiles
+ mv vncviewer/Makefile vncviewer/Makefile.orig
+-sed -e "s,EXTRA_LDOPTIONS =,EXTRA_LDOPTIONS = -L$start/$libs $LDFLAGS_OS," \
++sed -e "s,EXTRA_LDOPTIONS =,EXTRA_LDOPTIONS = $LDFLAGS_OS," \
+ -e "s,CCOPTIONS =,CCOPTIONS = $CPPFLAGS_OS," \
+ vncviewer/Makefile.orig > vncviewer/Makefile
+
+@@ -245,6 +247,7 @@
+ $LDD $dest/vncviewer$suff
+ echo ""
+
++if false; then
+ # Do stunnel:
+ #
+ stunnel_src=`ls -td ./src/stunnel* | head -1`
+@@ -322,3 +325,4 @@
+
+ $dest/vncviewer$suff -h
+ $LDD $dest/vncviewer$suff
++fi
diff --git a/net/ssvnc/pkg-descr b/net/ssvnc/pkg-descr
new file mode 100644
index 000000000000..c65dc05027f9
--- /dev/null
+++ b/net/ssvnc/pkg-descr
@@ -0,0 +1,15 @@
+The Enhanced TightVNC Viewer package started as a project to add some patches
+to the long neglected Unix TightVNC Viewer. However, now the front-end GUI and
+wrapper scripts features dwarf the Unix TightVNC Viewer patches (see the lists
+below).
+
+It adds a GUI for Windows, Mac OS X, and Unix that automatically starts up
+STUNNEL SSL tunnel for SSL or SSH connections to x11vnc, and then launches the
+TightVNC Viewer to use the tunnel. It also enables SSL encrypted VNC
+connections to any other VNC Server running an SSL tunnel, such as STUNNEL, at
+their end. It can be used to perform SSH tunnelled connections to any VNC
+Server as well. The tool has many additional features (see below for a list).
+
+The short name for this project is "ssvnc" for SSL/SSH VNC Viewer.
+
+WWW: http://www.karlrunge.com/x11vnc/ssvnc.html
diff --git a/net/ssvnc/pkg-message b/net/ssvnc/pkg-message
new file mode 100644
index 000000000000..b7085d81a531
--- /dev/null
+++ b/net/ssvnc/pkg-message
@@ -0,0 +1,9 @@
+==============================================================================
+
+SSVNC has been installed, and the following commands are available:
+
+ssvnc - SSVNC viewer
+ssvnc-stunnel - Wrapper script for SSVNC + stunnel (SSH/SSL tunnels)
+ssvnc-gui - GUI for the previous commands
+
+==============================================================================
diff --git a/net/ssvnc/pkg-plist b/net/ssvnc/pkg-plist
new file mode 100644
index 000000000000..13b43c210e34
--- /dev/null
+++ b/net/ssvnc/pkg-plist
@@ -0,0 +1,6 @@
+bin/ssvnc
+bin/ssvnc-gui
+bin/ssvnc-stunnel
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/stunnel-server.conf
+%%PORTDOCS%%@dirrm %%DOCSDIR%%