aboutsummaryrefslogtreecommitdiff
path: root/net/stone
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-04-28 17:25:52 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-04-28 17:25:52 +0000
commit3bbf4decf244bd46c08ae2befb823a9a65fbd9da (patch)
treeec78dad8da830debed158accb862a23fd2aff6d0 /net/stone
parent92afdc5c6655631ce9705d3e554a3643f58aa290 (diff)
downloadports-3bbf4decf244bd46c08ae2befb823a9a65fbd9da.tar.gz
ports-3bbf4decf244bd46c08ae2befb823a9a65fbd9da.zip
Notes
Diffstat (limited to 'net/stone')
-rw-r--r--net/stone/Makefile5
-rw-r--r--net/stone/distinfo6
-rw-r--r--net/stone/files/patch-stone.c58
-rw-r--r--net/stone/files/stone.112
-rw-r--r--net/stone/files/stone.1.ja12
5 files changed, 20 insertions, 73 deletions
diff --git a/net/stone/Makefile b/net/stone/Makefile
index 721cf2d5cb6f..f68366158dd1 100644
--- a/net/stone/Makefile
+++ b/net/stone/Makefile
@@ -6,14 +6,15 @@
#
PORTNAME= stone
-PORTVERSION= 2.3d
-PORTREVISION= 1
+PORTVERSION= 2.3e
CATEGORIES= net ipv6
MASTER_SITES= http://www.gcd.org/sengoku/stone/
MAINTAINER= mistral@imasy.or.jp
COMMENT= Stone is a TCP/IP packet repeater in the application layer
+WRKSRC= ${WRKDIR}/${PORTNAME}-2.3d-2.3.2.7
+
MAN1= stone.1
MANLANG= "" ja
diff --git a/net/stone/distinfo b/net/stone/distinfo
index 607f413bcada..184ef519544b 100644
--- a/net/stone/distinfo
+++ b/net/stone/distinfo
@@ -1,3 +1,3 @@
-MD5 (stone-2.3d.tar.gz) = e4ea40fdc5249f81d854925dafb5fb1f
-SHA256 (stone-2.3d.tar.gz) = 9b27a339e04363f36832d9a4d749ff62c6e72b66e54fb542df53620a68c0528b
-SIZE (stone-2.3d.tar.gz) = 92665
+MD5 (stone-2.3e.tar.gz) = 3d1ac4e3fd1118ad1acad06f9209f7f4
+SHA256 (stone-2.3e.tar.gz) = b2b664ee6771847672e078e7870e56b886be70d9ff3d7b20d0b3d26ee950c670
+SIZE (stone-2.3e.tar.gz) = 92587
diff --git a/net/stone/files/patch-stone.c b/net/stone/files/patch-stone.c
deleted file mode 100644
index b3f71bc3efe6..000000000000
--- a/net/stone/files/patch-stone.c
+++ /dev/null
@@ -1,58 +0,0 @@
-===================================================================
-RCS file: /cvsroot/stone/stone/stone.c,v
-retrieving revision 2.3.2.1
-retrieving revision 2.3.2.2
-diff -u -r2.3.2.1 -r2.3.2.2
---- stone.c 2007/10/05 21:59:48 2.3.2.1
-+++ stone.c 2007/10/22 03:07:17 2.3.2.2
-@@ -93,7 +93,7 @@
- */
- #define VERSION "2.3d"
- static char *CVS_ID =
--"@(#) $Id: stone.c,v 2.3.2.1 2007/10/05 21:59:48 hiroaki_sengoku Exp $";
-+"@(#) $Id: stone.c,v 2.3.2.2 2007/10/22 03:07:17 hiroaki_sengoku Exp $";
-
- #include <stdio.h>
- #include <stdlib.h>
-@@ -3047,9 +3047,6 @@
- time(&pair->clock);
- if (p) p->clock = pair->clock;
- pair->tx += len;
-- if ((pair->xhost->mode & XHostsMode_Dump) > 0
-- || ((pair->proto & proto_first_w) && Debug > 3))
-- message_buf(pair, len, "UDP");
- return 0; /* success */
- }
-
-@@ -3143,9 +3140,15 @@
- if (ex != pair->b) ungetExBuf(ex);
- if (pos >= len) { /* complete the packet */
- complete:
-- if (!err) err = sendPairUDPbuf(stone, pair,
-- (char*)(buf+UDP_HEAD_LEN),
-- len-UDP_HEAD_LEN);
-+ if (!err) {
-+ err = sendPairUDPbuf(stone, pair, (char*)(buf+UDP_HEAD_LEN),
-+ len-UDP_HEAD_LEN);
-+ if (!err) {
-+ if ((pair->xhost->mode & XHostsMode_Dump) > 0
-+ || ((pair->proto & proto_first_w) && Debug > 3))
-+ message_buf(pair, len, "tu");
-+ }
-+ }
- if (cur != pair->b) ungetExBuf(cur);
- cur = NULL;
- }
-@@ -3810,7 +3813,11 @@
- message(LOG_DEBUG, "%d TCP %d: connecting to TCP %d %s",
- p1->stone->sd, p2->sd, p1->sd, addrport);
- }
-- ret = connect(p1->sd, dst, dstlen);
-+ if (p1->proto & proto_dgram) {
-+ ret = 0; /* do nothing */
-+ } else {
-+ ret = connect(p1->sd, dst, dstlen);
-+ }
- if (ret < 0) {
- #ifdef WINDOWS
- errno = WSAGetLastError();
diff --git a/net/stone/files/stone.1 b/net/stone/files/stone.1
index 619ba87641ea..ef8c4ca37fb8 100644
--- a/net/stone/files/stone.1
+++ b/net/stone/files/stone.1
@@ -1,5 +1,5 @@
.\" Roff format skeleton provided by Taketo Kabe <kabe@sra-tohoku.co.jp>
-.TH stone 1 "version 2.3d"
+.TH stone 1 "version 2.3e"
.
.SH NAME
stone \- Simple Repeater
@@ -9,7 +9,7 @@ stone \- Simple Repeater
.br
.B " [-u \fImax\fP] [-f \fIn\fP] [-l] [-L \fIfile\fP] [-a \fIfile\fP] [-i \fIfile\fP]"
.br
-.B " [-X \fIn\fP] [-T \fIn\fP] [-r]"
+.B " [-X \fIn\fP] [-T \fIn\fP] [-A <n>] [-r]"
.br
.B " [-x \fIport\fP[,\fIport\fP][-\fIport\fP]... \fIxhost\fP... --]"
.br
@@ -44,7 +44,7 @@ FreeBSD, BSD/OS, SunOS, Solaris, HP-UX and so on.
.
.TP
.B 2. Simple.
-\fBStone\fP's source code is only 9000 lines long (written in C
+\fBStone\fP's source code is only 10000 lines long (written in C
language), so you can minimize the risk of security
holes.
.
@@ -99,8 +99,10 @@ used, the program writes its process ID to the file.
The \fB-X\fP \fIn\fP flag alters the buffer size of the repeater.
The default value is 1000 bytes. If
the \fB-T\fP \fIn\fP is used, the timeout of TCP sessions can be
-specified to \fIn\fP sec. Default: 600 (10 min). The \fB-r\fP flag is
-used, SO_REUSEADDR is set on the socket of \fIst\fP .
+specified to \fIn\fP sec. Default: 600 (10 min).
+The \fB-A\fP flag specifies the maximum length the
+queue of pending connections may grow to. Default: 50.
+The \fB-r\fP flag is used, SO_REUSEADDR is set on the socket of \fIst\fP.
.P
Using the \fB-x\fP \fIport\fP[,\fIport\fP][-\fIport\fP]... \fIxhost\fP... \fB--\FP flag,
the http proxy (described later) can only connect to
diff --git a/net/stone/files/stone.1.ja b/net/stone/files/stone.1.ja
index 9e6abbea2be9..986fb64571ce 100644
--- a/net/stone/files/stone.1.ja
+++ b/net/stone/files/stone.1.ja
@@ -1,5 +1,5 @@
.\" Roff format skeleton provided by Taketo Kabe <kabe@sra-tohoku.co.jp>
-.TH stone 1 "version 2.3d"
+.TH stone 1 "version 2.3e"
.
.SH 名称
stone \- Simple Repeater
@@ -9,7 +9,7 @@ stone \- Simple Repeater
.br
.B " [-u \fImax\fP] [-f \fIn\fP] [-l] [-L \fIfile\fP] [-a \fIfile\fP] [-i \fIfile\fP]"
.br
-.B " [-X \fIn\fP] [-T \fIn\fP] [-r]"
+.B " [-X \fIn\fP] [-T \fIn\fP] [-A <n>] [-r]"
.br
.B " [-x \fIport\fP[,\fIport\fP][-\fIport\fP]... \fIxhost\fP... --]"
.br
@@ -45,7 +45,7 @@ UNIX マシンでも使うことができます。
.
.TP
.B 2. 単純
-わずか 9000 行 (C 言語) ですので、セキュリティホールが生じる可能
+わずか 10000 行 (C 言語) ですので、セキュリティホールが生じる可能
性を最小限にできます。
.
.TP
@@ -93,8 +93,10 @@ ID を出力するファイルを指定します。
.P
\fB-X\fP は中継を行なう際のバッファの大きさを指定します。デフォルトは
1000 バイトです。\fB-T\fP を指定すると TCP セッションのタイムアウトの
-秒数を変更できます。デフォルトは 600 (10 分) です。\fB-r\fP を指定する
-と \fIst\fP のソケットに SO_REUSEADDR を設定します。
+秒数を変更できます。デフォルトは 600 (10 分) です。
+\fB-A\fP を指定すると listen 呼び出しの未処理接続キューの最大長を変更できます。
+デフォルトは 50 です。
+\fB-r\fP を指定すると \fIst\fP のソケットに SO_REUSEADDR を設定します。
.P
\fB-x\fP を指定すると http proxy の接続先を制限できます。接続先のポー
ト番号のリスト \fIport\fP[,\fIport\fP][-\fIport\fP]... および接続先ホストの