aboutsummaryrefslogtreecommitdiff
path: root/net/straw
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2004-02-18 20:25:10 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2004-02-18 20:25:10 +0000
commite24014bb363eeba1e1b966247187e03bf79b1698 (patch)
treed0c5dc0ddefe3e81804336b10577c57a0aa2e506 /net/straw
parent42331cf4ddaabd611d4a079b4d3f57e8a96a23e6 (diff)
downloadports-e24014bb363eeba1e1b966247187e03bf79b1698.tar.gz
ports-e24014bb363eeba1e1b966247187e03bf79b1698.zip
Notes
Diffstat (limited to 'net/straw')
-rw-r--r--net/straw/Makefile25
-rw-r--r--net/straw/distinfo4
-rw-r--r--net/straw/files/patch-Makefile61
-rw-r--r--net/straw/files/patch-setup.py15
-rw-r--r--net/straw/files/patch-src::lib::Config.py11
-rw-r--r--net/straw/files/patch-src::lib::Main.py6
-rw-r--r--net/straw/files/patch-src::lib::utils.py11
-rw-r--r--net/straw/files/patch-src::straw12
-rw-r--r--net/straw/pkg-plist97
9 files changed, 126 insertions, 116 deletions
diff --git a/net/straw/Makefile b/net/straw/Makefile
index 9d74dc15819d..ca5fa1dab593 100644
--- a/net/straw/Makefile
+++ b/net/straw/Makefile
@@ -6,27 +6,25 @@
#
PORTNAME= straw
-PORTVERSION= 0.21.1
-PORTREVISION= 3
+PORTVERSION= 0.22
CATEGORIES= net gnome
-#MASTER_SITES= ${MASTER_SITE_SAVANNAH}
-#MASTER_SITE_SUBDIR= ${PORTNAME}/${PORTNAME}.pkg/${PORTVERSION}/
-MASTER_SITES= ${MASTER_SITE_LOCAL}
-MASTER_SITE_SUBDIR= adamw
+MASTER_SITES= ${MASTER_SITE_SAVANNAH}
+MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= mezz7@cox.net
COMMENT= A GNOME 2 desktop weblog aggregator written in Python
-RUN_DEPENDS= ${PYXML} \
- ${PYTHON_SITELIBDIR}/mx/DateTime/mxDateTime/__init__.py:${PORTSDIR}/lang/py-mx-base \
- ${PYTHON_SITELIBDIR}/gtk-2.0/gnome/__init__.py:${PORTSDIR}/x11-toolkits/py-gnome2
+RUN_DEPENDS= ${PYTHON_SITELIBDIR}/mx/DateTime/mxDateTime/__init__.py:${PORTSDIR}/lang/py-mx-base
USE_BZIP2= yes
USE_GMAKE= yes
-USE_PYTHON= yes
USE_X_PREFIX= yes
USE_REINPLACE= yes
-USE_GNOME= libglade2
+USE_GNOME= libglade2 pygnome2
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
+PYDISTUTILS_INSTALLARGS= -c -O1 --prefix=${PREFIX} \
+ --install-lib=${PREFIX}/share/gnome
.include <bsd.port.pre.mk>
@@ -38,9 +36,8 @@ RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/_bsddb.so:${PORTSDIR}/databases/py-bsddb
.endif
post-patch:
- @${REINPLACE_CMD} -e 's|%%X11PREFIX%%|${PREFIX}|g ; \
- s|%%PYTHON_SITELIBDIR%%|${PYTHON_SITELIBDIR}|g' \
- ${WRKSRC}/Makefile ${WRKSRC}/src/straw
+ @${REINPLACE_CMD} -e 's|%%PYTHON_SITELIBDIR%%|${PYTHON_SITELIBDIR}|g' \
+ ${WRKSRC}/src/straw
post-install:
@${CAT} ${PKGMESSAGE}
diff --git a/net/straw/distinfo b/net/straw/distinfo
index 12be1455d5cf..23025fed7ea5 100644
--- a/net/straw/distinfo
+++ b/net/straw/distinfo
@@ -1,2 +1,2 @@
-MD5 (straw-0.21.1.tar.bz2) = 504c2614d0a09ae8d484ad1568881b32
-SIZE (straw-0.21.1.tar.bz2) = 108009
+MD5 (straw-0.22.tar.bz2) = 8cdd2ad3c6d8f4e120eae003831152a0
+SIZE (straw-0.22.tar.bz2) = 138825
diff --git a/net/straw/files/patch-Makefile b/net/straw/files/patch-Makefile
deleted file mode 100644
index 0f3825d48d3a..000000000000
--- a/net/straw/files/patch-Makefile
+++ /dev/null
@@ -1,61 +0,0 @@
---- Makefile.orig Thu Nov 13 21:53:33 2003
-+++ Makefile Thu Nov 13 21:57:07 2003
-@@ -1,4 +1,4 @@
--PYTHON ?= python2.2
-+PYTHON ?= python
- INSTALL ?= install
- RM ?= rm
- MSGFMT ?= msgfmt
-@@ -6,16 +6,16 @@
- XGETTEXT ?= xgettext
- FIND ?= find
-
--#PREFIX = /usr/local
-+PREFIX = %%X11PREFIX%%
- # autodetect GNOME prefix, change this if you want it elsewhere
--PREFIX ?= `pkg-config libgnome-2.0 --variable=prefix || echo /usr/local`
-+#PREFIX ?= `pkg-config libgnome-2.0 --variable=prefix || echo /usr/local`
-
- # If you edited PYTHON above, edit this to the corresponding python lib dir
--LIBDIR = $(PREFIX)/lib/python2.2/site-packages/straw
-+LIBDIR = $(PREFIX)/share/gnome/straw
- BINDIR = $(PREFIX)/bin
--DATADIR = $(PREFIX)/share/straw
--APPLICATIONSDIR = $(PREFIX)/share/applications
--ICONDIR = $(PREFIX)/share/pixmaps
-+DATADIR = $(PREFIX)/share/gnome/straw
-+APPLICATIONSDIR = $(PREFIX)/share/gnome/applications
-+ICONDIR = $(PREFIX)/share/gnome/pixmaps
- LOCALEDIR = $(PREFIX)/share/locale
- # change this to just "/etc" if you're installing in /usr
- SYSCONFDIR = $(PREFIX)/etc
-@@ -27,9 +27,9 @@
- schema_DATA = data/straw.schemas
- # modify this if you're running your own build environment (garnome/jhbuild)
- # change it to "xml://path/to/gnome_build_env/etc/gconf/gconf.xml.defaults"
--GCONF_SCHEMA_CONFIG_SOURCE = xml::/etc/gconf/gconf.xml.defaults
-+GCONF_SCHEMA_CONFIG_SOURCE = xml::$(SYSCONFDIR)/gconf/gconf.xml.defaults
- GCONF_SCHEMA_FILE_DIR = $(SYSCONFDIR)/gconf/schemas/
--GCONFTOOL = gconftool-2
-+GCONFTOOL = $(BINDIR)/gconftool-2
-
- SCHEMADIR = $(GCONF_SCHEMA_FILE_DIR)
-
-@@ -60,7 +60,7 @@
- $(INSTALL) -m 644 images/straw.png $(ICONDIR)
- $(INSTALL) -m 644 images/*.png $(DATADIR)
- $(INSTALL) -m 644 data/default_subscriptions.opml $(DATADIR)
-- $(INSTALL) -m 644 src/lib/*.py[co] $(LIBDIR)
-+ $(INSTALL) -m 644 src/lib/*.py $(LIBDIR)
- $(INSTALL) -m 644 straw.desktop $(APPLICATIONSDIR)
- $(INSTALL) -m 644 data/straw.schemas $(SCHEMADIR)
- $(INSTALL) -m 644 images/straw.png $(ICONDIR)
-@@ -69,7 +69,7 @@
- for mo in $$mos; do \
- mo=`basename $$mo`; \
- lang=`echo $$mo | sed -e 's/\.mo$$//'`; \
-- $(INSTALL) -m 644 -D $$mo $(LOCALEDIR)/$$lang/LC_MESSAGES/straw.mo; \
-+ $(INSTALL) -m 644 $$mo $(LOCALEDIR)/$$lang/LC_MESSAGES/straw.mo; \
- done
-
- clean:
diff --git a/net/straw/files/patch-setup.py b/net/straw/files/patch-setup.py
new file mode 100644
index 000000000000..9b497c36e73a
--- /dev/null
+++ b/net/straw/files/patch-setup.py
@@ -0,0 +1,15 @@
+--- setup.py.orig Tue Feb 17 13:31:30 2004
++++ setup.py Tue Feb 17 13:32:32 2004
+@@ -80,9 +80,9 @@
+ '''Build list of data files to be installed'''
+ images = glob.glob('images/*.png')
+ files = [
+- ('share/pixmaps', ['images/straw.png']),
+- ('share/applications', ['straw.desktop']),
+- ('share/straw', images +
++ ('share/gnome/pixmaps', ['images/straw.png']),
++ ('share/gnome/applications', ['straw.desktop']),
++ ('share/gnome/straw', images +
+ ['data/default_subscriptions.opml', 'glade/straw.glade'])]
+ return files
+
diff --git a/net/straw/files/patch-src::lib::Config.py b/net/straw/files/patch-src::lib::Config.py
deleted file mode 100644
index 227b7adbbdb0..000000000000
--- a/net/straw/files/patch-src::lib::Config.py
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/lib/Config.py.orig Sun Nov 16 03:57:07 2003
-+++ src/lib/Config.py Sun Nov 16 03:58:04 2003
-@@ -364,6 +364,8 @@
- last_poll = property(get_last_poll, set_last_poll, None, "Last polled")
-
- def get_number_of_items_stored(self):
-+ if self._items_stored == 0:
-+ return 30
- return self._items_stored
-
- def set_number_of_items_stored(self, num=30):
diff --git a/net/straw/files/patch-src::lib::Main.py b/net/straw/files/patch-src::lib::Main.py
index 3657b72cc4eb..5d3529f4c8ab 100644
--- a/net/straw/files/patch-src::lib::Main.py
+++ b/net/straw/files/patch-src::lib::Main.py
@@ -1,6 +1,6 @@
---- src/lib/Main.py.orig Thu Nov 13 21:57:57 2003
-+++ src/lib/Main.py Thu Nov 13 21:58:51 2003
-@@ -360,7 +360,7 @@
+--- src/lib/Main.py.orig Tue Feb 17 13:35:41 2004
++++ src/lib/Main.py Tue Feb 17 13:36:26 2004
+@@ -479,7 +479,7 @@
return os.environ["STRAW_DATA"]
h, t = os.path.split(os.path.split(os.path.abspath(sys.argv[0]))[0])
if t == 'bin':
diff --git a/net/straw/files/patch-src::lib::utils.py b/net/straw/files/patch-src::lib::utils.py
deleted file mode 100644
index f516ea556b50..000000000000
--- a/net/straw/files/patch-src::lib::utils.py
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/lib/utils.py.orig Sun Nov 16 03:58:11 2003
-+++ src/lib/utils.py Sun Nov 16 03:58:32 2003
-@@ -22,7 +22,7 @@
- previous = None
- while res_len < chars and i < frag_len - 1:
- i += 1
-- current = fragment[i]
-+ current = fragment[i].encode('utf-8')
- if in_tag:
- if in_attr:
- if current == '"':
diff --git a/net/straw/files/patch-src::straw b/net/straw/files/patch-src::straw
index af6ce82249d0..4c08834656f4 100644
--- a/net/straw/files/patch-src::straw
+++ b/net/straw/files/patch-src::straw
@@ -1,12 +1,6 @@
---- src/straw.orig Thu Nov 13 21:59:51 2003
-+++ src/straw Thu Nov 13 22:01:07 2003
-@@ -1,4 +1,4 @@
--#!/usr/bin/env python2.2
-+#!/usr/bin/env python
- #
- # Copyright (c) 2002 Juri Pakaste
- # You may use and distribute this software under the terms of the
-@@ -19,13 +19,14 @@
+--- src/straw.orig Tue Feb 17 13:37:00 2004
++++ src/straw Tue Feb 17 13:37:50 2004
+@@ -20,13 +20,14 @@
return sd
h, t = os.path.split(os.path.split(os.path.abspath(sys.argv[0]))[0])
if t == 'bin':
diff --git a/net/straw/pkg-plist b/net/straw/pkg-plist
index 62332909baac..9a100ab32ef4 100644
--- a/net/straw/pkg-plist
+++ b/net/straw/pkg-plist
@@ -1,58 +1,145 @@
bin/straw
+etc/gconf/gconf.xml.defaults/apps/straw/%gconf.xml
+etc/gconf/gconf.xml.defaults/apps/straw/general/%gconf.xml
+etc/gconf/gconf.xml.defaults/apps/straw/ui/%gconf.xml
+etc/gconf/gconf.xml.defaults/schemas/apps/straw/%gconf.xml
+etc/gconf/gconf.xml.defaults/schemas/apps/straw/general/%gconf.xml
+etc/gconf/gconf.xml.defaults/schemas/apps/straw/ui/%gconf.xml
etc/gconf/schemas/straw.schemas
share/gnome/applications/straw.desktop
share/gnome/pixmaps/straw.png
share/gnome/straw/Config.py
+share/gnome/straw/Config.pyc
+share/gnome/straw/Config.pyo
share/gnome/straw/DashboardFrontend.py
+share/gnome/straw/DashboardFrontend.pyc
+share/gnome/straw/DashboardFrontend.pyo
share/gnome/straw/Event.py
-share/gnome/straw/ExportSubscriptionsDialog.py
+share/gnome/straw/Event.pyc
+share/gnome/straw/Event.pyo
share/gnome/straw/Feed.py
+share/gnome/straw/Feed.pyc
+share/gnome/straw/Feed.pyo
+share/gnome/straw/FeedCategoryList.py
+share/gnome/straw/FeedCategoryList.pyc
+share/gnome/straw/FeedCategoryList.pyo
share/gnome/straw/FeedDataRouter.py
+share/gnome/straw/FeedDataRouter.pyc
+share/gnome/straw/FeedDataRouter.pyo
share/gnome/straw/FeedItems.py
+share/gnome/straw/FeedItems.pyc
+share/gnome/straw/FeedItems.pyo
share/gnome/straw/FeedList.py
+share/gnome/straw/FeedList.pyc
+share/gnome/straw/FeedList.pyo
share/gnome/straw/FeedPropertiesDialog.py
+share/gnome/straw/FeedPropertiesDialog.pyc
+share/gnome/straw/FeedPropertiesDialog.pyo
share/gnome/straw/FindDialog.py
+share/gnome/straw/FindDialog.pyc
+share/gnome/straw/FindDialog.pyo
share/gnome/straw/ImageCache.py
-share/gnome/straw/ImportSubscriptionsDialog.py
+share/gnome/straw/ImageCache.pyc
+share/gnome/straw/ImageCache.pyo
share/gnome/straw/ItemStore.py
+share/gnome/straw/ItemStore.pyc
+share/gnome/straw/ItemStore.pyo
share/gnome/straw/LookupManager.py
+share/gnome/straw/LookupManager.pyc
+share/gnome/straw/LookupManager.pyo
share/gnome/straw/Main.py
+share/gnome/straw/Main.pyc
+share/gnome/straw/Main.pyo
share/gnome/straw/MainWindow.py
+share/gnome/straw/MainWindow.pyc
+share/gnome/straw/MainWindow.pyo
share/gnome/straw/MessageManager.py
+share/gnome/straw/MessageManager.pyc
+share/gnome/straw/MessageManager.pyo
share/gnome/straw/NetworkConstants.py
+share/gnome/straw/NetworkConstants.pyc
+share/gnome/straw/NetworkConstants.pyo
share/gnome/straw/OPML.py
+share/gnome/straw/OPML.pyc
+share/gnome/straw/OPML.pyo
share/gnome/straw/OPMLExport.py
+share/gnome/straw/OPMLExport.pyc
+share/gnome/straw/OPMLExport.pyo
share/gnome/straw/OPMLImport.py
+share/gnome/straw/OPMLImport.pyc
+share/gnome/straw/OPMLImport.pyo
share/gnome/straw/ParsedSummary.py
+share/gnome/straw/ParsedSummary.pyc
+share/gnome/straw/ParsedSummary.pyo
share/gnome/straw/PollManager.py
+share/gnome/straw/PollManager.pyc
+share/gnome/straw/PollManager.pyo
share/gnome/straw/PreferencesDialog.py
+share/gnome/straw/PreferencesDialog.pyc
+share/gnome/straw/PreferencesDialog.pyo
share/gnome/straw/QueueDict.py
+share/gnome/straw/QueueDict.pyc
+share/gnome/straw/QueueDict.pyo
share/gnome/straw/StrawURLOpener.py
+share/gnome/straw/StrawURLOpener.pyc
+share/gnome/straw/StrawURLOpener.pyo
share/gnome/straw/SubscribeDialog.py
+share/gnome/straw/SubscribeDialog.pyc
+share/gnome/straw/SubscribeDialog.pyo
share/gnome/straw/SummaryItem.py
+share/gnome/straw/SummaryItem.pyc
+share/gnome/straw/SummaryItem.pyo
share/gnome/straw/SummaryParser.py
+share/gnome/straw/SummaryParser.pyc
+share/gnome/straw/SummaryParser.pyo
share/gnome/straw/URLFetch.py
+share/gnome/straw/URLFetch.pyc
+share/gnome/straw/URLFetch.pyo
share/gnome/straw/__init__.py
+share/gnome/straw/__init__.pyc
+share/gnome/straw/__init__.pyo
share/gnome/straw/dashboard.py
+share/gnome/straw/dashboard.pyc
+share/gnome/straw/dashboard.pyo
share/gnome/straw/default_subscriptions.opml
share/gnome/straw/error.py
-share/gnome/straw/face-happy.png
-share/gnome/straw/face-sad.png
+share/gnome/straw/error.pyc
+share/gnome/straw/error.pyo
+share/gnome/straw/feedparser.py
+share/gnome/straw/feedparser.pyc
+share/gnome/straw/feedparser.pyo
+share/gnome/straw/file_selector.py
+share/gnome/straw/file_selector.pyc
+share/gnome/straw/file_selector.pyo
share/gnome/straw/hig_alert.py
+share/gnome/straw/hig_alert.pyc
+share/gnome/straw/hig_alert.pyo
share/gnome/straw/httplib_async.py
+share/gnome/straw/httplib_async.pyc
+share/gnome/straw/httplib_async.pyo
share/gnome/straw/image-broken.png
share/gnome/straw/image-waiting.png
share/gnome/straw/offline.png
share/gnome/straw/online.png
share/gnome/straw/rssfinder.py
-share/gnome/straw/rssparser.py
+share/gnome/straw/rssfinder.pyc
+share/gnome/straw/rssfinder.pyo
share/gnome/straw/straw.glade
share/gnome/straw/straw.png
share/gnome/straw/utils.py
+share/gnome/straw/utils.pyc
+share/gnome/straw/utils.pyo
share/locale/de/LC_MESSAGES/straw.mo
share/locale/es/LC_MESSAGES/straw.mo
share/locale/fi/LC_MESSAGES/straw.mo
share/locale/fr/LC_MESSAGES/straw.mo
+share/locale/nl/LC_MESSAGES/straw.mo
share/locale/no/LC_MESSAGES/straw.mo
share/locale/ru/LC_MESSAGES/straw.mo
@dirrm share/gnome/straw
+@dirrm etc/gconf/gconf.xml.defaults/schemas/apps/straw/ui
+@dirrm etc/gconf/gconf.xml.defaults/schemas/apps/straw/general
+@dirrm etc/gconf/gconf.xml.defaults/schemas/apps/straw
+@dirrm etc/gconf/gconf.xml.defaults/apps/straw/ui
+@dirrm etc/gconf/gconf.xml.defaults/apps/straw/general
+@dirrm etc/gconf/gconf.xml.defaults/apps/straw